interlaced but seperate objects

Discussion in 'My Work In Progress' started by stop4stuff, Jan 8, 2011.

  1. stop4stuff
    stop4stuff Well-Known Member
    I've been figuring out some chain maille designs and hit a big stumbling block.

    Pieces with less than 300 interlaced, but seperate parts, e.g. this 4 in 1 sheet of 212 rings upload fine, but get up to around the 300 or above mark and the upload fails with this error message;

    "error while unifying: 17

    We have already tried correcting the issue using our Mesh Medic.

    If you have any questions about your product, please visit www.shapeways.com/mydesign under the header "my errors" or have a look at our relevant tutorial or video.
    * http://www.shapeways.com/tutorials/fixing-non-manifold-model s
    * http://www.shapeways.com/video/fixing-non-manifold-meshes
    "

    I've narrowed the actual number to 300 in one design, but 297 fails in another... the number to trigger the error differs.

    Any ideas what the issue is and/or what needs to be done to make it work?

    Cheers,
    Paul
     
  2. stop4stuff
    stop4stuff Well-Known Member
    I think I figured the answer to my own question :)

    Why Mesh Medic fails is not because of the amount of elements, but because of a relationship between the amount of elements and the total number of triangles.

    What the ratio is, I've not yet figured out, but I did manage to get a chain maille model successfully uploaded with over 2000 links :)
     
  3. stop4stuff
    stop4stuff Well-Known Member
    :eek:

    European 4 in 1 weave Chain maille dice bag - comes in at 319 elements with a total of 343296 faces (trianlges). Hopefully the upper and bottommost layers of rings will be ok as I had to reduce the number of faces by an 1/8th to get the model accepted by Mesh Medic.

     
  4. Now that's *very* interesting. I am at present trying to figure out how to turn my dwarf into something that MeshMedic likes. http://www.shapeways.com/forum/index.php?t=rview&goto=22 006

    He has quite a few loose parts - at least 3k, and 95k faces. I'll have to see how much I have to slim him down before MeshMedic can handle it.

    I'd be interested to know if you peg down more of a formula.
     
  5. stop4stuff
    stop4stuff Well-Known Member
    Daniel, I don't think you're too far off from making your model work, this square ring chainmaille sheet has 3053 elements with a total of 97696 triangles... although there may be another issue involved too, the complexity of the interlaced objects.
     
  6. I believe your link is not publicly visible, but I understand what you're saying. I can't remember how many "shells" I have - I'll have to check netfabb again.

    In any case, I used decimate to reduce *to* 25% and 35% of the original, and both worked. 50% did not. So, I'm going to try backing up a step and selectively reducing the complexity to get the poly count into that magic zone. I'll record the number of "shells" and triangles and we'll see where it goes.

    Incidentally, I was not thinking and specified "faces" as reported in Blender, when I should have reported triangles after exporting to STL.
     
  7. stop4stuff
    stop4stuff Well-Known Member
    Sorry, i made the model public now :blush:
     
  8. stop4stuff
    stop4stuff Well-Known Member
  9. stop4stuff
    stop4stuff Well-Known Member
    Aaaarrrrgggghhh!!!

    OK, this issue is a now 'officially' a right royal PITA!

    My Large Chain Maille Dice Bag arrived today... I noticed two of the draw string chain links were fused. I re-checked my 3d model, and sure enough I hadn't centered the pivot point correctly when manouvering the links... so I corrected this and saved the model.

    Next, I did my thing and uploaded the model...

    Unfortunately, we were not able to process and thus print your product. The error message was:
    error while unifying: 17


    Uhh... wtf.... it is the exact same model with 19 parts moved x +0.191558, y +0.549985, z -0.065353 millimeters. Still the same 445 shells and still the same 261072 triangles, but the volume has changed by a whopping 0.0006 cc (due to orignally overlapping shells which I fixed)

    Come on Shapeways, please resolve this number of shells vs number of triangles issue that Mesh Medic gets upset over.

    Cheers



     
    Last edited: Feb 2, 2011
  10. stop4stuff
    stop4stuff Well-Known Member
    The RRPITA has had some cream applied!

    I uploaded the model a second time, with the 'Please fix my model manually' box ticked, and it was 'fixed' using NetFabb (the NetFabb I have showed no errors before I tried uploading)... and... hey presto... one 'fixed' and printable Large Dice Bag :)

    The moral of this saga...
    If you get a unifying error 17, check the model in NetFabb and then ask for a manual fix... sorted!
     
  11. stop4stuff
    stop4stuff Well-Known Member
    mmm... issue not sorted :(

    My large chain maille dice bag works and is fine.

    My Square Maille flat N coaster uploaded fine.

    However, a placemat with exactly the same Square Maille flat N design but with 1842 shells failed because? (i don't really have a clue all that was shown in the failure image was a X in the shells box)... it was suggested that it may have failed because the model =2.5mm in one dimension and that i should try uploading with 2.51mm - i did this...

    and...

    it still failed :(

    This is not a number of shells issue...
    this tester model was fine with 3053 shells - http://www.shapeways.com/model/200481/

    please can someone (a Shapeways someone would be good) tell me what i need to do to make my "can't be moulded" chain maille designs work - 3d printing is where i see things imagineered bought to life... it may be i got too far outside the box, if so... someone please reel me in a bit

    cheers :confused

     
  12. barrys
    barrys Shapeways Employee Dev Team
    Hi stop4stuff,

    we'll look into this. It seems that Meshmedic can't handle them correctly when it tries to merge shells or repair the model and returns with an error, but in these cases it should not merge anything and except for the many shells there is nothing wrong with the model, so also should not repair anything.

    Barry


    edit:stop4stuff*, hehe sorry for that :)
     
    Last edited: Feb 9, 2011
  13. stop4stuff
    stop4stuff Well-Known Member
    "shop4stuff" :laughing: you saying i spend too much?
    It's stop4stuff :rolleyes:

    I've received an email saying that IT & the NetFabb ppl are looking into this, so hopefully it will be sorted soon.

    Cheers,
    Paul