InShape 2.0 Launch!

Discussion in 'Official Announcements' started by natalia, Aug 17, 2012.

Thread Status:
Not open for further replies.
  1. natalia
    natalia New Member
    Hi Guys,

    We're launching InShape 2.0 tonight - which is so exciting!!

    Inshape 2.0 completely replaces our back-end systems for Order Placement and Order Fulfillment systems with up-to-date, state-of-the-art technology and processes. In the past, we've had to say "no" or "not now" to so many great ideas from the community -- 99% of that is washed away with this release. We anticipate faster turnaround times on orders, and on improvements to our systems.

    For the reason for our excitement, Josh's blog post tells all...
    http://www.shapeways.com/blog/archives/1580-Big-Changes-Comi ng-to-Shapeways-this-Weekend!.html

    How does this affect you?

    In the short term, the site will be down tonight for maintenance and the next few days you may notice things that don't behave exactly as you expect. Bear with us as we work hard to fix any bugs we find.

    If you do spot something that is not quite right, post it here and we'll get right on it!

    When the site is down, you can comment on tumblr:
    http://shapeways.tumblr.com/post/29631655879/inshape-2-0-lan ding-at-shapeways-this-weekend

    Thank you!
    and see you on the other side of awesome!
     
    Last edited: Aug 17, 2012
  2. stop4stuff
    stop4stuff Well-Known Member
    Printable model email subject = Your uploaded model is now available in My Models.
    Within the message of the email, was "Using our Mesh Medic technology, we were able to correct a few issues with your model file." - Both Accutrans3D and NetFabb Studio Basic show the model as perfect.

    For those of us uploading many models this adds confusion and workload - please return to include the model file name in the subject and if MeshMedic finds an issue, please let us know what the issue was.

    Today, at 10:55 BST I received the email as per subject line above.
    Models, confirmed as uploaded by email as at 12:15 and 12:25 BST today still have not have an email confirmation as to their printability status, as at 16:40 BST (GMT+1)

    [edit] bold and itallic still not working in forums ;)
     
    Last edited: Aug 19, 2012
  3. stonysmith
    stonysmith Well-Known Member Moderator
    I just uploaded a model that had a number of intersecting shells that NetFabb was very happy with. MeshMedic could have welded all those shells together and that would be considered a "correction". I don't know that I would want a return notification about any such (minor) correction.

    Remember, we have here both hyper-advainced users and ultra-noobies... I don't necessarily see a problem with a bit more generic email message that is delivered to both groups.
     
    Last edited: Aug 19, 2012
  4. stop4stuff
    stop4stuff Well-Known Member
    lol... my model was a simple profile spun, or lathed, then had a bit chopped out using a splice tool (same as boolean but leaves all of the meshes to be dealt with as the user see fit), the mesh parts merged and checked with Accutrans3D followed but another check in NetFabb - both perfect.

    My main reasons for bringing this up as an issue are that I like to get things right first time and I learn from mistakes - as in I'll only make that mistake once - so if MeshMedic did indeed need to fix something, what was it? If I know, I can ensure it deosn't happen again and if anyone else encounters a similar issue, I can help them out via the forums. Information is knowledge and all that :)

    Now, if the ultra-noobie doesn't care about the nuances of their model at upload time and only wants to see it work, then all well and good, however when the ultra-noob jumps into the forums asking why their model has parts missing, how are they going to understand why those parts are missing and what they can do to fix the model?

    Now, what's the score with the lack of 'your model is printable messages'? (the models are in my models and are printable)


     
  5. natalia
    natalia New Member
    Thanks Paul, noted!
     
  6. stonysmith
    stonysmith Well-Known Member Moderator
    Don't mis-understand, I'm 100% with you. The software I work on in my day job has an "error level" parameter.. you can set it to warn on the smallest things, or tell it to stifle itself completely.

    I uploaded two models at 15:00 UTC, and got both emails within 5 minutes of the upload. It seems that they've stopped sending the "Thank you for uploading a model" email, and are only sending the single "it's printable" email now, which is fine with me.

    Here's an idea: what if the "It's printable" email included some statistics like the time when the Upload button was pressed, time the model is visible on the site, size of the bounding box, number of triangles, file size, etc. :D (Do the developers hate me yet?)

    Let me say one thing: THANK YOU Shapeways for including the link to the (new) model itself !!!!!!!!!
     
  7. stop4stuff
    stop4stuff Well-Known Member
    Model uploaded confirmation email at 12:15 BST (GMT+1), 'Your uploaded model is now available in My Models' referencing said model (with clicky link, thanks) email at 18:13 BST (GMT+1), the second one has just come through (18:27 BST) too.

    Now that seems to be working, please can the model file name be included, as previously, in the subject of the email - finding when a particular model file (as per the model edit page) is easy when the model file name is in the subject (i.e. visual scan of folder) having to use a search function to find the email that contains the model number after finding the model number on Shapeways or c&p the link from the email to cut out the model number (or even going to the model page to get the file name) first takes a lot longer.

    [edit] sorry, sometimes my spelling is carp
     
    Last edited: Aug 19, 2012
  8. pete
    pete Shapeways Employee CEO & Co-Founder
    Thanks for all the feedback guys!

    This has been the biggest release for us since launch, so there are some features missing and known bugs. We are fixing them as fast as possible.

    Thanks,
    Pete
     
  9. stop4stuff
    stop4stuff Well-Known Member
  10. natalia
    natalia New Member
    Thanks Paul, I'm seeing all the feedback on the forum, and putting it in the right places to get addressed!

    Much appreciated!
     
  11. PlainOrb
    PlainOrb New Member
    Really looking forward to the new !! Initially, I found that I could not get access to " Sales History " , is it pending ? Also, does the changes include designer authority to choose preferred printing direction ?
     
  12. coolbutpointless
    coolbutpointless New Member
    I don't know if I'm experiencing a bug or if it's just a slow turn around for files being added to my models.

    Earlier today I uploaded a new model. I didn't get the "thanks for uploading" e-mail. I figured what ever. A couple hours pass and I upload another model. This time I got the "thanks" e-mail.

    So far, I haven't received the "You model is available" nor the "Your model had problems" e-mails and none of the models I've uploaded in the past 10 hours have shown up in the my models section.

    Again, not certain if this is a bug or if it's just a delay in processing due to increased model uploading and such.

    Other than that, I really like the new incarnation of the site!
     
  13. Amicra
    Amicra New Member
    Hello,

    I've got the same problem. I didn't recieved an upload notification and the parts don't appear in the "my models" section.

    Martin
     
  14. natalia
    natalia New Member
    Hi everyone, we wanted to share a quick update after the epic release of our architecture.

    First, thank you for your patience with us! We've done an incredible amount of testing, but some bugs are inevitable when rewriting a full system. We are currently attacking issues with the full force of our brilliant development team -- prioritizing the things that matter the most to you!

    Namely, we're making sure that key website functionality (uploading, ordering etc) and 3D printing are running smoothly. Things are improving by the minute, and you should have a seamless experience very soon!

    In the meantime, please continue to post in this thread:
    http://www.shapeways.com/forum/index.php?t=msg&th=10587& amp;start=0&
    if you see anything or have any issues.

    Thank you from the Product and Development Teams!
     
    Last edited: Aug 20, 2012
  15. lensman
    lensman Well-Known Member
    I would like to know how all these bugs are affecting printing and shipping... ALL my most recent orders have expected shipments FAR ahead of what is posted on the Orders page. By clicking on each order a new shipment date is given. All but one of these is for silver items:

    Original date New date
    23 Aug 12 Sep
    24 Aug 10 Sep
    27 Aug 10 Sep (s/steel)
    28 Aug 12 Sep
    02 Sep 12 Sep


    So for the first item on the list that is a TWENTY DAY delay!

    There are NO delays in production shown on the Material Status Page other than a Slight Delay in WSF.

    So what gives?

    Glenn
     
  16. natalia
    natalia New Member
    Hi Glenn,

    I don't believe production has been held up, but I am confirming this now for you.

    Best,
    Natalia
     
  17. FreakyShape
    FreakyShape New Member
    Since the 19th August, my payement page no longer works.
    Is it normal?
    When it will work again?
    Thanks
     
    Last edited: Aug 26, 2012
  18. Mstyle183
    Mstyle183 New Member
    i would like to know the answer to this also.. let me know if you get a rsponse
     
  19. PlainOrb
    PlainOrb New Member
    Is there any news about the sales history ? I can't find my previous sales history in " My Sales " section.
     
  20. Dragoman
    Dragoman New Member
    As far as I can see, the sales overview excel sheet that you can download still works.

    Greetings
    Dragoman
     
Thread Status:
Not open for further replies.