How do get your object the right scale?

Discussion in 'Design and Modeling' started by BeepBeep3D, Oct 26, 2012.

  1. BeepBeep3D
    BeepBeep3D New Member
    I've been trying to export a model from 3D Studio and have it be the same dimensions once it's uploaded to Shapeways.
    I've tried DAE, STL, OBJ, and WRL and I'm having no consistent results.

    The object is built to scale in MAX. But when I upload it often gives an error saying it was too big or too small.
    I've tried setting MAX's units to MM, CM and M. I've tried picking the matching scale when I upload or even mismatched scales just to see what would happen.

    DAE has scale built in while STL and WRL, OBJ and WRL do not.

    I've uploaded about 30 times, this can't be good for the server having to check and reject or scale all these failed models.

    Is there a magic setting I don't know that will make the file upload correctly?
    Does it change from file to file?

    :confused
     
  2. Fredd
    Fredd New Member
    Export a cube with dimensions of 1 x 1 x 1 as a stl. Upload it to shapeways, setting Sw upload measurement to mm.When its uploaded, edit the model to see its dimensions. If you wanted your model to have the dimensions of a cube cm 1x1x1, and SW lists dimensions cm .1x.1x..1, scale the original model by 10, upload again. This is a brute force technique excuse me. But it will get you uploading models the correct size till you get better advice on specifics. :} Upload tests are free also
    Keith

     
  3. BeepBeep3D
    BeepBeep3D New Member
    Yeah, that was a good idea.
    Alas it hasn't helped. Here's my results.

    Max set to Meters Export as DAE(Meters) = Success

    Unfortunately I'm want to print in Colour Sandstone.

    Max set to Meters Export as WRL – Shapeways set to M = Fail (too big)
    Max set to Meters Export as WRL – Shapeways set to MM = Fail (too small)
    Max set to MM Export as WRL – Shapeways set to MM = Fail (too small)
    Max set to MM Export as WRL – Shapeways set to M = Fail (too big)
    Max set to CM Export as WRL – Shapeways set to MM = Fail (too small)
    Max set to CM Export as WRL – Shapeways set to M = Fail (too big)

    The error message from Shapeways doesn't tell me how big or small the it thinks the rejected file is, so I'd have to just guess different sizes until I found something that worked.
     
  4. BeepBeep3D
    BeepBeep3D New Member
    Did another experiment.

    100mm cube in Max (set to mm) - Exported in WRL - Imported in mm to Shapeways - Produces a 3.94mm cube.
    That's 25.38 times smaller.

    So I made a 2538mm cube in Max (set to mm) - Exported in WRL - Imported in mm to Shapeways - Produces a 100mm cube.
    Problem solved... I guess.

    If I'm doing something wrong I'd like to know but if it is Shapeways that's pretty poor.
    Why would it do that and why are there's no instructions or help for people who are trying to produce models.
    If it's consistent why not check for it / scale object automatically?

    Confused. :confused
     
  5. Fredd
    Fredd New Member
    For a dae it does not matter what upload setting you set at SW, it will print in whatever unit you set in your program.
    Something odd but interesting, set units to meters in max, keep scale factor at 1. If you can change its dimensions(bounding box dimensions) change the values to cm for each. If you have a 10 x 5 x 12 for bounding box dimensions, reenter values if you want it printed in cm 10cm x 5cm x 12cm. Adding the cm at the end of the numeric value seems to do the trick. Now export to SW, choose meters.
    I found out it works for dae, stl so far for uploads, in blender at least. This might possibly solve your problems.
    Lol, so I am off to see if it works for a wrl and x3d file.
    Keith
    PS By the way if you ever get the 394 number, inches are involved 1 mm = .03934 inches
     
  6. Fredd
    Fredd New Member
    The technique actually worked uploading a x3d and a wrl textured model. SW dimensions matched with my programs bounding box dimensions.
     
  7. JACANT
    JACANT Well-Known Member
    http://www.shapeways.com/tutorials/exporting_to_vrml_and_x3d _for_color_printing
    You will find the whole tutorial helpful.
    This quote is taken from the page.
    Q: Shapeways is telling me that my object is too big!
    A: Remember that VRML97 and X3D expect your object to be measures in meters. So, if you want to create something that's 10mm long, you'll have to model it as 0.01m. Some 3D packages will allow you to select a scale during export. If not, you'll have to manually scale your model down by a factor of 1000.
     
  8. Fredd
    Fredd New Member
    Well, if you have a modelling program where you cannot set scale, this works for x3d,wrl, vrml97. Using a model whose bounding box length is 11 units
    1, Model dimensions in cm; scale by .01(11 cm length)
    2. Model dimensions in mm; scale by .001(11 mm length)
    3. If you want it in inches, scale by .0254(11" length
    * This effects all bounding box dimensions

    I am considering Chris Lowes technique, and Blenders good exporters/importers to make the above technique a thing of the past

    http://www.youtube.com/watch?v=dGs-c-YIGbM&feature=share &list=UUHMnBBBXlYdPHfgEtebNssg
     
    Last edited: Oct 27, 2012
  9. victorrings
    victorrings Well-Known Member
    thanks for the plug sir!

    i use MAX at work and if i remember correctly there is a glitch in that max defaults to whatever dimensioning technique that it sets at the start up... and i think i remember there are multiple places in the settings to change the measurements...

    if you have something that works i would use that.

    by the way this is my new shop i am peddleing my rings through. i model everything in blender and they are for sale at:

    http://victorrings.weebly.com/

    chris lowe
    Senoir Designer-Victor Rings Design