Hole filled after upload

Discussion in 'Technologies and Hardware' started by Uranya, Oct 13, 2010.

  1. Uranya
    Uranya New Member
    Dear friends,
    I have done a very simple B-Spline curve profile in blender to do a rotational solid.

    Converted it into a mesh I do a SPIN to create an hollow bowl.

    It works, and it is hollow.

    But after uploading it to print it became closed in one side.
    I need the model completely hollow, as in a ring.

    I have tried to use Meshlab to reconstruct the mesh, but it crashes (tried Uniform Mesh Reconstruction and Surface Reconstruction) when applied.

    Can you help me plese to understand this odd behaviour?
    Thank you!

    Model attached in x3d file format (exported from blender)

    Attached Files:

  2. bartv
    bartv New Member
    Can you post the .blend file? I can't really work with .x3d, I'm afraid..

  3. Uranya
    Uranya New Member
    Dear friend, here it is the blend file.

    Thanks for your availability!
  4. aeron203
    aeron203 New Member
    It looks like Bart is helping you so I don't want to jump in front of him, but for future reference, files with this error are easily fixed in Meshlab.

    The reconstruction is not necessary and would reduce the quality of your model.

    I took a look at the file last night and here's how I fixed it:

    Filters->Normals->Re-Orient Coherently

    Filters->Normals->Invert Faces Orientation

    Cleaning and Repairing->Merge Close Vertices (use default values)

    Saved as STL and uploaded using Inches as units

    It worked for me.

  5. aeron203
    aeron203 New Member
    Wait, sorry, your file was not in inches but in meters and had to be scaled. an appropriate scaling would be 100x which would give you a part 37mm wide, or about 1.43 inches.
  6. Uranya
    Uranya New Member
    Thank you very much for your help!
  7. Uranya
    Uranya New Member
    Hello Aeron203,

    I've tried to do all you told,

    but after that (using millimeters in scaling unit) it says that there is a manifold error.

    Can you help me further?


    Attached Files:

  8. dizingof
    dizingof New Member
    I fixed it for you.


    Attached Files:

  9. bartv
    bartv New Member
    Wow! I didn't even have to do a thing ;)

    Thanks for the help, everybody!

  10. Uranya
    Uranya New Member
    Thank you very much, Dizingof,

    can I ask you where it is the problem?

    I want to learn to fix it by myself.

    Thanks for your help, twice!
  11. dizingof
    dizingof New Member
    The best tip i can give you is use on your 3d modeling software an X-Ray view of the model - then check for inner walls that needs to be removed

    The other tip (which i'm proud to have never used) is to just upload your model and check the box for "please fix my model for me" - than Bart will have lot's of fun with it! :D

  12. bartv
    bartv New Member
    Actually, someone else will ;) (Thank God!)

  13. Uranya
    Uranya New Member
    Hi friend,

    the odd thing is that blender shows the model correctly, without any wall. How you have fixed it?

  14. dizingof
    dizingof New Member
    The software shapeways use to check and fix your model added a wall on top your model , i removed it manually then fixed the manifold errors
  15. aeron203
    aeron203 New Member
    It seems I left out an important detail... hopefully I didn't cause you too much frustration. There is a little bug in Meshlab when scaling. If you don't Go to Normals->Freeze Current Matrix, the scaling won't be applied, and your model will still be so tiny it will cause a manifold error.

    I just repeated the steps I gave you, scaled it, then used the cryptic sounding "Freeze Current Matrix" (which just means "Apply the Filter" in English), and it worked both times I tried it. I'm not sure how big you wanted it to be, but scaling 1000x (not 100x) and uploading as millimeters gave me an object 40mm wide that cost $9 in WSF material. Scaling by 100x and uplaoding as inches gave an object 100mm wide that cost $125 in WSF.

    We do want to help you figure out what is going wrong and not just tell you what to click on. Here is the best explanation I can come up with of what happened:

    Your spline had an extra segment, so your spin was not closed. This confused Blenders export filter and made a mess of your normals. Blenders default unit is meters, so the model was extremely small. After scaling correctly to convert the units and fixing the normals, the "Merge Close Vertices" filter closed the mesh, but left some junk from the extra spline segment inside the model (shown in the screenshot). Shapeways will accept the model with the extra geometry still inside because the software removes it automatically (called "Merging" or "Unifying").

    The best solution is of course to learn these potential problems well enough to avoid them while modeling, but that is easier said than done, so I think this Meshlab approach is a good one since it is fully automatic and doesn't require you to select or manually edit anything. Meshlab can be very touchy though, I admit. I hope that clarified things a little!

    Attached Files:

  16. Uranya
    Uranya New Member
    Dear Aero203,

    thank you very much for your explanations!
    They are very clear, and now I realized the spline error.

    Thank You!