HELP - Problem Uploading UV Mapped Model for Color Printing

Discussion in 'Technologies and Hardware' started by Stiky, Feb 15, 2013.

  1. Stiky
    Stiky New Member
    I am working on a model to be printed in full color sandstone. However, whenever I've tried to upload it, despite the model passing the automated inspections, the preview for the object is quite confusing. I've tried uploading extremely simple models to see if I can even get 1 model to upload correctly, and still nothing works. Here is a picture of my latest attempt. Its a pyramid, with a simple yellow and blue checker-board .png file at 1024x1024 resolution UV mapped.
    [​IMG]
    As you can see, the texture is apparent in the reflection, but the actual model is no where to be seen. The 360 revolving preview just consists of the shadow cast by the would-be model.
    I've searched the forums for any similar problems and I seem to be the only one who's experienced this. I am exporting to .X3D format from Blender v2.63. Any insight into this issue would be much appreciated. Thanks in advance.
     
  2. mkroeker
    mkroeker Well-Known Member
    Have you set objects/colors to (semi-)transparent by any chance ?
     
  3. stonysmith
    stonysmith Well-Known Member Moderator
    As @mkroker said.. I've seen that many times before.. What you see there is not the model itself, but the (reflected) shadow they add to make the models look better. Your object itself has a transparency value.

    I use TrueSpace and it has a very annoying feature of always adding transparency to the UV maps, causing this very problem.
    To get around it, you (may) have to edit the WRL file directly - it's just a text file - and you can simply remove the line(s) that say
    transparency {nnnn}
     
  4. Stiky
    Stiky New Member
    That makes a lot of sense! I remember experimenting with material properties like reflection and transparency when I was first learning Blender. I guess those settings are still in effect. I'll look into it and let you know if it works.
     
  5. Stiky
    Stiky New Member
    Sorry, no luck... I talked with a friend of mine who's more knowledgeable in Blender about how to remove transparency from textures and materials. For anyone savy with Blender, I un-checked the transparency field under my mesh's material tab, and then went to the texture tab and unchecked the "Alph:" field under the "Influence" section. For all I know these are the 2 values that have any say about an object's transparency. When exported to .X3D, archived with the .PNG texture files, and uploaded, I still receive the same troubling preview images. Both me and my friend are stumped. I've successfully uploaded one textured model as a test a week ago, but haven't gotten it to work again since. I'm considering switching to another program to handle the .X3D export.
     
  6. mkroeker
    mkroeker Well-Known Member
    You could try inspecting the texture png file in some image editor to see if blender really removed the alpha channel.

     
  7. Stiky
    Stiky New Member
    Thanks for the response, but I've checked the .PNG in photoshop and assured it didn't have an alpha channel.
     
  8. mkroeker
    mkroeker Well-Known Member
    I guess that leaves only hunting down the "transparency" keywords in the X3D as stonysmith suggested.
    Or is it possible that you have multiple material nodes in your blender file and did not modify all of them ?
     
  9. Stiky
    Stiky New Member
    [​IMG]
    IT WAS SO SIMPLE! Sorry I didn't listen to you as carefully as I should have, StonySmith. I must've been tired and you must have thrown me off when you said "WRL file" since I'm exporting to .X3D. It took Mkroeker to get me to remember what you said. I opened my .X3D file in notepad++ and, sure enough, there was a line that read: transparency="1.0"
    I set it to "0.0" saved, re-uploaded and it works great now! Sorry for not trying that a lot earlier when it was first suggested, but thanks for continuing to reply to this post. Now I can get back to work! :D