Google Sketchup Resizing=Model Degradation Help!

Discussion in 'Software and Applications' started by blaynescott, Feb 21, 2012.

  1. blaynescott
    blaynescott New Member
    Hi everyone,

    I did some 3D modeling work 10 years back in High School, and I'm now getting back into it, using Google Sketchup.

    I've been working on Transformer robot toy head in Google Sketchup for the past 2 days, and I'm ready to export it to Meshlab, then check it in Netfabb for errors.

    The problems are...

    In Sketchup, I'm trying to resize the model down to the correct scale (1.4cm wide), but I noticed that after resizing, the edges degrade (?!), resulting in a substantial loss of detail. That shouldn't happen in any 3D program.

    So, trying to just export it as-is from Sketchup into Meshlab (which is just used to save it as a .STL file?), then Netfabb (which is just used to run mesh-correct scripts?) - results in an error from Shapeways.

    Either there's still some wacky errors with the model, or it's not resizing correctly.

    Just... it's really frustrating. Any suggestions, or offers to check out the model (maybe I'm missing something?) would be much appreciated.

    -Blayne
    blaynescott@gmail.com

    Custom Toys & Action Figures
    http://blayne.dark-ware.org/
    grmilock_wip_3.jpg
     
  2. Kasss_Gnarl
    Kasss_Gnarl New Member
    Upload the sketchup file and I will take a quick look for you. I'm no expert but a fresh pair of eyes can do wonders.
     
  3. stonysmith
    stonysmith Well-Known Member Moderator
    I very commonly use Netfabb Basic to do resizing... it's found under Part / Scale
     
  4. blaynescott
    blaynescott New Member
    Thanks to anyone willing to check this out -- I'm aiming to get this model watertight, scaled to 1.4cm wide (across the head), as he's destine for use in an action figure I've made. :)

    Also, if you find out what I've done wrong in what's causing the errors - I'm open to any/all advice or critique. I'd like to improve my 3D modeling skills. :)

    Thanks!
    -Blayne
     

    Attached Files:

  5. Kasss_Gnarl
    Kasss_Gnarl New Member
    Hi Blayne,

    Heres the model re-sized and cleaned up, I have also included a copy with some red internal faces which would have been causing you problems. Something else I noticed Sketchup was doing was deleting faces each time I saved, as it ran is validity check. The faces were fine it's just that Sketchup really doesn't like to work with small models. You can disable it in the Sketchup prefrences.

    If you are planning to use Sketchup for more modeling, be sure to sign up at Sketchucation and have a look for the solid inspector plugin. When run this will highlight any internal faces/issues stopping your model being watertight.

    Also grab this .STL exporter to allow you to export straight from Sketchup: DXF or STL

    Hope this helps some and keep us posted on the progress.
     

    Attached Files:

  6. blaynescott
    blaynescott New Member
    Hi,

    Thanks for your help. :) The uploaded model still had some issues uploading to Shapeways, but thanks to your advice I found those duplicate internal faces and deleted them though Netfabb. Afterward, I ran their hole-patching general checks - and it worked! :)

    I realize also how to properly resize objects too - the resize tool in Netfabb doesn't offer real-world units, only a ratio scale.

    Since my object was 3.56mm (and needed to be 13mm long), I used my calculator to divide one value into the other (13 / 3.56 = correct ratio to type in.

    The model resized correctly to 13 mm long, and also hit the 'repair' option when exporting - 0 problems found! Shapeways accepted it on upload.

    This has certainly been a learning process - I appreciate the guidance. ^_^

    Looking forward to printing this piece out. Thanks for the links to Sketchup stuff too. Looking forward to making use of those plugins with future projects. :)

    -Blayne

    grimlock_3d_preprinting.jpg
     
    Last edited: Feb 24, 2012