Google Analytics code (partially) exists in page, but Google does not detect it

Discussion in 'Bug Reporting' started by TinyMtn, Jan 9, 2013.

  1. TinyMtn
    TinyMtn Member
    I recently entered my new Google Analytics tracking ID into "My Shop"->"Shop Settings". I confirmed that the code was in the source code for my shop URL (http://www.shapeways.com/shops/TinyMtn). But Google Analytics continues to report:

    Google suggests the following code be inserted:

    Code:
    <script type="text/javascript">
    
      var _gaq = _gaq || [];
      _gaq.push(['_setAccount', 'UA-XXXX-1']);
      _gaq.push(['_trackPageview']);
    
      (function() {
        var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
      })();
    
    </script>
    But the shop page only includes the first portion of that, not the "function" part.

    Should I try again in a few days? Is this Google's problem?

    Thanks!
     
  2. TinyMtn
    TinyMtn Member
    OK. The solution is "wait a day." Google now reports "Status: Receiving Data." Go figure. Go, Shapeways for making that easy!
     
  3. natalia
    natalia New Member
    Glad that worked out!

    It does usually take about 24 hours to start reporting tracking, as (I imagine) it needs time to collect data