Fullcolor Sandstone blender exporting X3D problem

Discussion in 'Technologies and Hardware' started by dathasholly, Apr 1, 2013.

  1. dathasholly
    dathasholly New Member
    I'm relatively new to Shapeways and I'm trying to upload my first full color sandstone model from blender in X3D, but I get the following error message: "It seems your product is missing the textures it needs to be 3D printed. Please check the uploaded file to make sure the texture is in the root directory." Now, in the blender file, the materials all have the needed textures taken from a single folder, wherein I also save the export. I zipped them all together (no not the outer folder, just the textures and export like I'm supposed to) but I always get the error message. As far as I can tell, the file names should be a perfect match and contain no folder titles or anything. I don't know what I'm doing wrong. I'd greatly appreciate any assistance.
     
  2. stonysmith
    stonysmith Well-Known Member Moderator
    Open the X3D file with Notepad or some other text editor.
    Look for the names of the texture files, and make sure that they don't have any folder information as part of the filename.
     
  3. graf1ty
    graf1ty New Member
    also when opening the model in notepad check if the texture name is the same and the filetype is the same,
    I have had the same issue when the actual texture filetype was jpeg and the model opened in notepad said the filetype was jpg. Simply change that and it will work.