Exporting Combined (textured) Objects From Blender For Printing?

Discussion in 'Software and Applications' started by jamesber1012, Mar 25, 2019.

  1. jamesber1012
    jamesber1012 Member
    Hey guys, thanks for taking a look here. I'm having some trouble with using multiple textures in 3D prints. As long as I'm only using one texture/material in Blender and export it, it works just fine with ShapeWay's software, and it'll print fine. However, I'm trying to do more complicated models for printing now, which means I'm doing boolean unions in blender to combine different finished objects together to make a completed figure.

    For example, I have this shield here:
    [​IMG]
    In Blender, it displays just fine. You can't see the back, but it's got a leather handle I added just by modeling and texturing it separately (it was an afterthought), and then combining it with the shield's body with a boolean union operation. Works just fine in Blender! However, when I export the new object and its two textures to Shapeways, the texture gets all messed up:

    [​IMG]

    Pretty weird. Something's obviously getting garbled up in translation between the two pieces of software!
    Anyone know a reasonably easy way to fix this or work around it? I'm trying to make humanoid figures with multiple pieces of weapons and armor on them, which would all be modeled and textured separately, so just keeping everything on the same UV map/texture/material or whatever isn't really a realistic option to me...not with my skill and planning level, anyway.

    Thanks for any advice you can give, everyone! Was excited to try some more complicated models, but being able to use only one texture is going to make that really tough, hahah!
     
  2. Shea_Design
    Shea_Design Well-Known Member
    Seems like you are going to have to get savvy with texture baking, but I can't say for sure never having tried multiple textures or even looked at the constraints of the process. -S
     
    jamesber1012 likes this.
  3. jamesber1012
    jamesber1012 Member
    Thanks, Shea. I'll look into it. Others on the forum have mentioned uploading multiple texture files, though, so I figured it'd work somehow. If texture baking is what I need to do, I'll figure out how to get it working in my workflow, but it'd be great if I could just upload the separate texture files somehow!
     
  4. mkroeker
    mkroeker Well-Known Member
    I suspect it is not the texture files as such, but the addition of the handle that created the problem - something in the boolean addition of the handle seems to have led to a non-watertight geometry, and subsequent automatic fixing attempts by shapeways' site software have led to addition and/or removal of vertices so that your original texture mapping transform no longer fits. Try checking your geometry with meshmixer, meshlab or the trial version of netfabb studio, and then re-importing the (hopefully) fixed file into Blender for texturing.
     
    jamesber1012 likes this.
  5. jamesber1012
    jamesber1012 Member
    Thanks for the suggestions, mkroeker! The mesh geometry is really simple, so I'll be surprised if Blender actually made holes somehow...it's just a cube boolean'd into another cube for the back of the geometry, almost. I'll check out meshmixer, though, and see what it comes up with. Never know! Appreciate the help. I'll update tomorrow with a few things I'm trying. =)

    All the UVs appear to be stacked inside Blender, even though there are multiple textures. Could *that* be causing the problem? When you combine objects in Blender, it seems to combine all UVs too, so that they're all over each other, even though they still refer to different textures somehow. Kind of strange, and seems like it could be the culprit to me. I'm not a 3D pro by any means, so I don't know, though.

    Edit: Alright, after screwing around for a few days and watching ten videos, it seems like Shapeways really wants one texture, at least to me. Here's the best texture baking tutorial I could find for Blender:
     
    Last edited: Mar 29, 2019
  6. ex0rcist
    ex0rcist Member
    Hi James, I was researching extensively on my problem and it seems that you solved yours. Mine is much simpler; I can't get Blender to recognise my textures. Can you tell me which file format you are using in Blender and which settings might there be on export? Thank you!