empty output issue

Discussion in 'Software and Applications' started by 514009265, Dec 20, 2011.

  1. 514009265
    514009265 New Member
    Hi, I'm new to shapeways and I wanted to print out a ring, I uploaded a prototype of my ring (because it was unfinished), in multiple file formats to shapeways and they all gave the same error, empty output. But when I checked my model, all the normals are correct and I made sure to use a boolean operation on all parts. And finally, I used Netfabb to check and repair my ring. it came out correct, with no bad edges, 1 shell, no holes, positive volume, surface is closed, surface is orientable, and I exported it from Netfabb and uploaded it again. It still gave the same error, empty output.
    I'm running out of ideas here, can someone here just take a quick look at my file and tell me what is wrong with it?

    Attached Files:

  2. stonysmith
    stonysmith Well-Known Member Moderator
    I'm not sure how you managed it, but it looks like every triangle here faces both outward and inward.. essentially, your ring is hollow, with a wall thickness of zero. The net volume of the whole thing is zero.

    What did you draw this with? Also, what are the dimensions?
    Last edited: Dec 21, 2011
  3. 514009265
    514009265 New Member
    it was done in 3dsmax 2011, I'm not sure how it became like that, could be the export settings, I need to check 3ds's STL export settings.
    this was my first time exporting to STL.

    the dimensions are 21.017mm 6.228mm and 21.193mm in 3ds max, with a volume of 0.31cm3

    edit: I checked the stl file in 3ds max , I didn't see any 2 side faces.
    Last edited: Dec 21, 2011
  4. stonysmith
    stonysmith Well-Known Member Moderator
    The software exported your file in units of INCHES instead of millimeters.

    There are three ways to fix this:
    1) Convince your software to export in millimeters
    2) Open the STL in Netfabb-Basic and use the command Part/Scale to increase it by a factor of 25.4
    3) On the Shapeways Upload page, select Inches.

    Note: you'll want to use only ONE of these methods to fix it :D

    I don't use that particular software package, but I think somewhere else here on the forum, someone else had the same problem.
  5. 514009265
    514009265 New Member
    thanks a lot, that solved it.