Downscale model

Discussion in 'Software and Applications' started by mazmwa, May 29, 2009.

  1. mazmwa
    mazmwa New Member
    I made a house in sketchup with a size (downscaled) of 100x80x75mm (10x8x7.5cm). I used cadplan to make a .stl file for me, and everything was going good.
    Then i uploaded my model on shapeways, a views minutes later i get a email that said: "Your object is too big! The size is 36.4 x 42.5 x 30.8 cm (h x w x d). We can only produce objects up to 45.0 x 100.0 x 25.0 cm"

    But that size is not the size of my model, my model is smaller then that. And i have select millimetres in the upload screen.

    And when i scale the model (smaller) i get the same email with the same sizes :confused

    Is there somebody who can explain me what i`m doing wrong?

    I uploaded the .stl file so you can take a look at it.
     

    Attached Files:

  2. mazmwa
    mazmwa New Member
    I find out what is the problem, cadspan gave me the wrong stl file so this file is 10x8x7 Meters ...
     
  3. mazmwa
    mazmwa New Member
    Ok! for testing i made a cube, the cube is 0,5x0,5x0,5 cm i make the .stl file in sketchup with the cadspan plugin.
    I uploaded the file end i get a email from shapeways that said that my model has a size of 0.2 x 0.2 x 0.2 cm [We can only produce objects larger than 0.3 x 0.3 x 0.3 cm]

    Strange, that the testing progress says that my cube is 0,2 because i made a 0,5 .. i opened the stl file to look what are the sizes because maybe i made a mistake. But the stl is 0,5.

    Can someone explain this for me?
    This is really frustrating.

    * here is the stl file
     

    Attached Files:

  4. mazmwa
    mazmwa New Member
    I find it out. Cadspan unit is inches and i draw in milimeters so i seleted milimeters when i was uploading. Thats why my model became so tiny.
     
  5. CADspan
    CADspan New Member
    Hello,
    We are aware of an issue when a user wishes for a part to be in Metric
    units that it comes out of CADspan in Standard units. This is due to
    the way SketchUp works behind-the-scenes. No matter what you set your
    working units to be in your SketchUp model, SketchUp is actually
    always "thinking" in Standard units. Setting a different unit type
    simply tells SketchUp to do mathematical conversions on-the-fly to be
    displayed in the bottom-right corner and in dimensions and
    measurements. SketchUp outputs models by default
    in inches and feet no matter what, thus resulting in improperly scaled
    models for those who wish to work in Metric units.
    The current fix is to simply scale the STL file by 1/25.4, from inches
    to mm.
    We are releasing a new version of the plugin early 2010, and this is
    an issue we would like to resolve in that release. Our question to you
    and the community is how would you like it to be resolved? Would
    checking the working units, then scaling by 1/25.4 on export if the
    units are MM be sufficient? Do you have any other suggestions for us?
    I would like to thank you in advance for any feedback you would like
    to give us on this matter. CADspan welcomes all user feedback.