"Design could not be validated" when uploading colour model

Discussion in 'Software and Applications' started by flypig, Jul 11, 2012.

  1. flypig
    flypig New Member
    I've been trying to upload a coloured VRML 2.0 file to shapeways, but no matter what I do it seems to either cause errors, or lose its colour. The file was exported from MeshLab (after importing a PLY file generated elsewhere), and uploading it causes the following error to be emailed back:

    If the file is converted to X3D or STL then it will upload fine, but all of the colour is lost (the result is here in case it helps: http://shpws.me/a4gW ).
    [Edit: I've deleted the colour-free version now, but the full-colour version is available here: http://shpws.me/aorB )


    Can I ask whether this is something that anyone else has experienced, or has any idea about how to fix? I'm happy to share the model file if this would help?

     
    Last edited: Jul 11, 2012
  2. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    I saw this recently in another post, but don't think I saw a resolution for it. You could try emailing it to service@shapeways.com to see if they can figure out why it's failing.
     
  3. flypig
    flypig New Member
    Last edited: Jul 11, 2012
  4. Fredd
    Fredd New Member
    Obviously: its losing its color information somewhere. How is the color being applied to the model, UV mapping, vertex paint or someother way.
    Well least you know its properly modeled, since the STL was accepted.(STL by the way does not support color info) Tinker with the export settings, or try to apply the yellow you want another way.
    I have read here that intersecting faces will also cause a failure for colored models. Has to do with UV mapping, and boolean operations
     
  5. stop4stuff
    stop4stuff Well-Known Member
    If your model is a single (or multiple seperated) watertight mesh(es), the chances are that Shapeways software is timing out on the render phase of the 'checking' process - I had this issue yesterday that caused all sorts of headaches (lord knows why a model render should be included in the 1800 seconds for the model validation check, but that's the way it is).

    The other possibility is that the model is constructed of multiple meshes, as already mentioned, this caused errors too, mostly colour information is lost - my solution to this is to use the NetFabb Cloud Service to boolean merge meshes together before colouring.

    Looking at your model, there's the probability that some of the spiral sections intersect at the sharper corners - go the NetFabb Cloud route first and see what happens.

    Paul

     
  6. flypig
    flypig New Member
    Thanks for the helpful input. The colour is applied per vertex (an RGB value per vertex; no texture). I tried to output it as face colour instead, but MeshLab doesn't offer this option. It's possible it might work as a texture, but I don't know of an easy way to automatically generate this unfortunately.

    However, I have managed to successfully upload colour VRML meshes exported in the same way in the past, so there's nothing wrong with the format in principal.

    Your suggestion about intersecting faces may be a good lead. The previous model had no intersecting faces, whereas this one does, so I'll have a go at fixing this. Unfortunately Blender won't allow me to perform boolean union since it's only a single mesh, but maybe there's another way?

    At any rate, I'll have a look at this; it sounds promising. In the meantime, the model is attached in case this is helpful.

    Thanks again!

     

    Attached Files:

  7. flypig
    flypig New Member
    Hi Paul. Thanks for commenting. The model is a single mesh made of two watertight loops that intersect at various places. What you say about the software timing out would make sense, since Shapeways is successfully managing to calculate the price, but not the image!

    Can I ask how you found a solution to this? Is the only solution to reduce the complexity of the mesh? I can generate it using fewer triangles, but the quality suffers unfortunately.

    From what you write, I'm guessing that (like the software application) the NetFabb Cloud Service doesn't support colour? This is a problem for me, since the mesh and colourings are generated simultaneously using an algorithm. I have no idea how I'd go about adding in colour afterwards.

    I'm just in the process of attempting to merge the mesh so there are no overlaps. Once I've failed to do this I'll try uploading a simpler version of the model; at least this may provide a clearer answer.

    Thanks again for your help. I'm really grateful for all of the replies.

     
  8. stop4stuff
    stop4stuff Well-Known Member
    The models I was uploading were multipart models, my first step was to reduce the number of parts to something that worked, but even then there were occasions when the models would fail so I left it until this morning and started again at ~07:00 GMT+1, all the files that failed yesterday went through first time.

     
  9. flypig
    flypig New Member
    It looks like you were on to something with the suggestion that the rendering was pushing the upload over the timeout period. Uploading a simpler version seems to have done the trick:

    http://shpws.me/aorB

    Although maybe this can't be taken as proof (the fewer triangles means the model has different characteristics, after all), I'd say it was pretty good evidence.

    I'll send an email to Shapeways to let them know. It would be good if they could remove the rendering step from the timeout, but at the very least, it might make sense for them to try to refine their error messages if it's easy to detect this case.

    Thanks again for all of the help from everyone. I'm muchly impressed by the excellent community support.

     
  10. Fredd
    Fredd New Member
    You seemed to have solved the problem, but if the mesh is manifold now, could you not create a image filled with the color of your choice open the image editor, select all faces,UV unwrap the mesh, open the yellow filled image,save, assign its material the texture of the image you saved, then apply UV for mapping type?
    I have no idea if the texture image needs packing though.:(
     
  11. flypig
    flypig New Member
    Hi Fredd. I expect your approach would work well for an image coloured using a texture map. However, in my case the colours are applied per-vertex, so there are no UV coordinates and no texture to save, if you see what I mean. Instead, there's an RGB colour value specified for each vertex of the mesh.

    The problem is therefore that regenerating the mesh with fewer vertices would mean I couldn't then apply these same colours back to the vertices (or at least not using any easy method I know of).

    I think your solution would be a good method for a coloured mesh that uses textures, but I'm afraid I don't know how it would work in my case, unless I'm misunderstanding or you know how this might be done?

     
  12. virtox
    virtox Active Member Moderator
    I am currently running into the same problem.

    Seems like larger complex vertex colored models upload fine (shows on the site with all correct info, is recognized as color, but no render) and I get an email with the "could not validate etc.."

    Did you poll CS already?

    Cheers,

    Stijn
     
  13. flypig
    flypig New Member
    There's a little more discussion about this problem in this thread, including input from Shapeways.

    I'm afraid the only solution I've found has been to reduce the resolution of the model. Once I'd done this, the model uploaded fine, but this may not be viable in all situations.

    One other alternative may be to convert the vertex colouring into a texture. Meshlab will do this for you using the following steps:

    1. Load vertex coloured model into Meshlab (in my case this is a ply file).
    2. Select "Filters > Texture > Trivial Per-Triangle Parmetrization".
    3. Click "Apply" (you may need to adjust the Inter-Triangle border or increase Texture Dimension if this generates an error).
    4. Close the dialogue.
    5. Select "Filters > Texture > Vertex Color to Texture".
    6. Click "Apply" and close the dialogue.
    7. Export the model in a suitable format.

    Although I've successfully imported the results into another graphics package, I've not tried this with Shapeways, so I can't say whether this will actually solve the problem. Also, I experience some loss in the quality of the colouring when doing this.

    Personally I'd be interested to hear if you have success with this or any other method.
     
    Last edited: Jul 31, 2012
  14. virtox
    virtox Active Member Moderator
    Awesome thanks!

    I have contacted CS about and it was confirmed it is only the rendering choking on my files.
    So the guess is, it should print fine, if the model uploads but does not show a render.

    But I am not about to try an $80 blind print ;)

    Thanks again will try the Meshlab method soon!

     
  15. virtox
    virtox Active Member Moderator
    Hmm cool :cool: The method works (sort of) will have to try some more later!

    For me the vrml filesize jumped from 40 to 120 MB, excluding the texture file. And the result looked awful, so far ;)
    Besides, I think the rendered will choke on this combo too :-S

    But still cool, I really love Meshlab, keeps surprising me with all the amazing stuff built in there. But it's hard to find if you don't know if its there ;)