Color model problems (Blender)

Discussion in 'Technologies and Hardware' started by jas870, Dec 7, 2011.

  1. jas870
    jas870 New Member
    I'm working on my most complex model to date -- a certain speedy hedgehog for my brother as a gift -- and am having trouble getting the colors to show up properly once uploaded to Shapeways. I'm sure I'm missing something obvious, but I've searched these forums and the web at large with no luck so far. I've found these forums to be invaluable in general (thanks!) and would greatly appreciate any advice anyone can give me.

    I'm working in Blender 2.60a, and all of the coloring is applied as a material to each component (no UV maps). Here's what my model should look like:

    [​IMG]

    First I tried exporting to .x3d, right from Blender. That worked okay for me on a test file earlier. When I uploaded to Shapeways, though, only a few of the colors showed up:

    [​IMG]

    You can't see it in the image, but the gold buckle on his left shoe is also colored. The lack of consistency seems strange -- there's only one material for each color, so it can't be that I set some materials up correctly and not others. And the legs and shoes are exact mirrors of each other (duplicated objects mirrored, not mirror modifier), so it would seem that if one worked the other should too.

    I checked all my normals and they're as they should be.

    Next I tried opening the .blend file in Blender 2.49b, since that allows VRML97 exports. I did so, and got the same results with that upload to Shapeways.

    Then, I tried opening the x3d export in MeshLab (no color, although some surfaces were reflective and some not, strangely). Tried the VRML97 export in MeshLab ... only some colors showed up, and not the same ones!

    [​IMG]

    Next I tried exporting an OBJ from Blender, and then opening that in MeshLab. Some colors showed up, but all in the wrong places. I exported a VRML97 from MeshLab, uploaded to Shapeways and the colors stuck (wrong colors, but colors nevertheless):

    [​IMG]

    So, now I'm thoroughly confused, and can't think of anything else to try. Any suggestions would be oh-so-very appreciated.

    Oh, one other thing I should add: Since I'm new to 3D modeling, (or that's my excuse, at least) I'm creating each piece of the model separately, and then overlapping those pieces. For instance, the head is a sphere with the eye sockets hollowed out, then the white "eyeball" is another sphere, and each spike is a distorted sphere. I know to make sure each mesh is watertight, and don't have any odd pieces sticking out here or there, but it isn't one solid mesh, which I know is the most elegant way to do things. Still, my other models have used the same technique, and it's worked fine thus far. Plus, the fact that some colors show up and not others makes me think it's not the modeling method.

    Thanks!
     
  2. jas870
    jas870 New Member
    Tried another test, this one using the same materials from the original model, but on simple, overlapping spheres. Exported straight from Blender to .x3d and it worked fine:

    [​IMG]

    So ... that seems to suggest something is wrong with my model itself, but perhaps not specifically that there are overlapping elements? Maybe the model is just too complex? It's just north of 500,000 faces, which is still half of Shapeways' limit ...
     
  3. jas870
    jas870 New Member
    Is it rude of me to be having this conversation with myself? ;)

    Just wanted to report, in case anyone else is having similar difficulties, that I was able to get all the colors to stick with an .x3d export from Blender simply by joining all the surfaces before exporting. I still need to make some tweaks and final checks later in the day, and I'll post back when I can fully confirm everything is working right.

    In the meantime, much less panicked :D
     
  4. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Glad you got it straight. There are no set rules for posting in any forum except modeler for hire. Next time, you could edit your original post though.
     
  5. jas870
    jas870 New Member
    A very good point ... I'll be sure to do that in the future. Thanks!
     
  6. stonysmith
    stonysmith Well-Known Member Moderator
    One thing I discovered recently.. make sure that the colors you use have no Transparency to them.. in the VRML you should be able to see whether the Transparency is 0.0 or not

    If it has even some very tiny amount like
    Transparency 0.000001

    Then the Shapeways renderer has trouble with it.
     
  7. jas870
    jas870 New Member
    Thanks for the tip, Stony ... much appreciated :)

    For anyone with a similar problem reading this thread, it did turn out that joining (CTRL-J) the meshes in blender did the trick. I love it when a solution only involves pressing two keys!
     
  8. skgoa
    skgoa New Member
    I have a stupid question relatied to this: how do I get the texture map out of Blender? Because when I try exporting to x3d and uploading to Shapeways, I get an eMail informing me if the texture missing.
     
  9. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    If you make the image in blender, you have to switch to UV/image editor, then under the image menu there is save and save as. Then when uploading to shapeways you have to have your x3d and your image zipped together, and upload that zip file.
     
  10. skgoa
    skgoa New Member
    That only gives me a wireframe of my modell projected onto 2D. I somehow managed to find the textures of the constituent meshes in the .blend file and could export one of them. Can I just stick all of them into the .zip? They are quite large, can I simply save them ias e.g. 512x512 without messing up the mapping?
     
  11. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    I'm going to let someone better at Blender answer that for sure, but I think you have to bake the textures? making it one texture map.
     
  12. skgoa
    skgoa New Member
    Well, thanks anyways. :D
     
  13. jas870
    jas870 New Member
    i haven't progressed far enough in my work with blender to start using texture maps, so i'm afraid i'm no help. good luck!
     
  14. skgoa
    skgoa New Member
    OK, texture problem solved, but now I can't get all textures to show up in the render. Joining them didn't change anything.

    edit: Actually... since part of one texture is being rendered, I suspect it's a problem in the renderer. I might just order a prototype right now. :D
     
    Last edited: Jan 19, 2012
  15. 3dPrintingNoob
    3dPrintingNoob New Member
    skgoa,

    I'm having the same texture problem you described. None of my textures appear in the shapeways render box. The only material color I have on my model does show, however.

    Did your prototype turn out with all you texture colors?
     
  16. stonysmith
    stonysmith Well-Known Member Moderator
    One question.. do any of these textures have an transparency value to them? You must have a value of
    Code:
    transparency  0.0
    or the renderer does funky stuff.
     
  17. 3dPrintingNoob
    3dPrintingNoob New Member

    Attached Files:

  18. bvr
    bvr New Member
    As a relative Blender noob alI can do is pass along what worked for myself.

    First thing is to use the newest version of blender(i'm using 2.61)
    I read in a few places that the .x3d format needs its texture files to be named in a 8.3 format, ie: keep your file name to 8 characters or less. I'm not sure if this applies to Shapeways but I kept my texture names short.
    I could not get a material alone to display in the shapeways renderer. That was my major issue, I had to set my image to a uv mapped texture.
    If you go into the UV editor, and go into edit mode you should see your uv mesh with an image under it.

    fwiw

    bvr
     
  19. 3dPrintingNoob
    3dPrintingNoob New Member
    bvr,

    Thanks for the response.

    I think my problem does have something do with texture file names as you've stated. I'm not sure what exactly the issue is though. I've had models show textures with texture file names over 8 characters. And I've had other models that didn't. So, my next step will be to research the 8.3 format you discussed. I appreciate your feedback! I'll let you know if I figure it out.
     
  20. afrodri
    afrodri New Member

    Thanks for this tip! I was getting some really weird upload problems and this solved them!