Can't at all upload color model to Shapeways , tried lot of times in X3D or WRL !

Discussion in 'Software and Applications' started by alaincassis, Jun 18, 2015.

  1. alaincassis
    alaincassis Member
    Hi all,
    I print color 3d scans with another supplier, everything is OK with all my .obj files.

    I what to try print some 3D color scans with Shapeways.
    My problem that I work with Blender or Meshmixer, and I try to export and upload X3D or WRL.


    Nothing works with Shapeway !!! . Seems in X3D or WRL source code, texture path is on my computer : ( mycomputer/me/myfolder/mytexture.jpg, but I don't know this kind of files.

    What path I have to write ?. Seems bizarre to have to change something inside code !
    Or can do it direct in Blender or Meshmixer ? and what path I have to write ?


    Thank in advance if somebody can help me !

    @


     
  2. mkroeker
    mkroeker Well-Known Member
    WRL and X3D are text files, just open them in an editor and remove the path and drive letter from the ImageTexture entries so that it is just "mytexture.jpg". Then when you zip the wrl and jpg, make sure that the zip contains just these files, no folder. BTW the blender folks appear to claim
    that this problem was fixed in 2011 ( https://developer.blender.org/T25903), almost looks as if it crept back in later ?
    Or try exporting to DAE (Collada) format, where the texture is usually included in the same file as the geometry.
     
  3. alaincassis
    alaincassis Member
    Thanks for advice,
    but I suppressed path in text, leave only mytexture.jpg. And spent lot of time uploading it in very many ways !!

    I just do with collada format : ok , but texture not appears.

    I tried X3D, WRL with and without path , and now Collada . At the best, image appears, but color never appears.

    here one of my file (on Sketchfab) :
    https://skfb.ly/EOUI
    You can download this file, and if somebody can upload it in colors on Shapeways, please, tell me how you did this miracle !!!!!


    Thanks anyway !!
     
    Last edited: Jun 18, 2015
  4. mkroeker
    mkroeker Well-Known Member
    Could you upload one of your problematic zip files with the WRL/X3D and texture here ? (Or send it to me by PM ?)
     
    Last edited: Jun 18, 2015
  5. alaincassis
    alaincassis Member
    Thanks,

     

    Attached Files:

  6. mkroeker
    mkroeker Well-Known Member
    Hmm. The zip has the wrl and jpg inside a subfolder named "MarcelineWRL 2" where shapeways expects just the two files (I do hope the Mac-specific __MACOSX "resource fork" folder gets ignored). Also that WRL - apparently from meshmixer - does not use the texture at all, it is "vertex-painting" the model white (with a looooong list of color entries for each vertex). Brute-force replacement of the color list with an ImageTexture node unfortunately led to the texture being wrongly mapped with the face of the poor lady on her left shoulder (there being no textureCoordinates for the mapping).
    Wonder what the export from Blender looked like - in meshmixer, apparently the texture simply was not mapped for export.

     
  7. Joe_Colling
    Joe_Colling Member
    Hello -

    When you say nothing works, do you mean your getting errors? What errors? Are you zipping the texture file with the WRL? If your model comes in black try flipping the U and V on the texture, I had that problem at first, myself. Once I flipped the U and V my texture showed up after upload. I noticed my uploads only work if the texture file is named same as the mesh - for example, If I upload a file called "my3Dmodel.wrl", then the texture file would be named "my3Dmodel_TEX.jpg" or something like that.

    Im not sure how to help you beyond that, because I don't know exactly what errors your getting when uploading. Need more info to help you better....
     
  8. alaincassis
    alaincassis Member
    Thanks a lot for your tips and advices !

    I'll try this asap.
     
  9. alaincassis
    alaincassis Member
    I retried now ,after 10 days, during I order few color prints from another supplier..
    I am far from success hère :
    myfile.X3D file & texture.jpg from Blender in a .zip file.
    Files in zip:
    lain29juin.x3d
    mytexture.jpg
    Résult error :
    Unsupported format. Unknown format, missing header not supported.

    :-(((
     
    Last edited: Jun 29, 2015
  10. mkroeker
    mkroeker Well-Known Member
    Hard to tell without the file, perhaps some extraneous information in the x3d header that shapeways' code does not like. (But should not happen with something as common as Blender). Did the exact same zip work when you uploaded it to the other supplier ?
     
  11. TGAW
    TGAW Member
    This may be a big shot in the dark-- but I did have an issue with X3D files and Blender when I had a Material and a Texture Map defined for the same object. When I exported the X3D, there wasn't an "ImageTexture" reference to my texture file for that object. Here's some excerpt of my notes (and some screenshots).

    So originally when I exported to X3D, I made my zip file and I noticed the Shapeways render wasn't picking up one of my image maps (even though it was in my zip file)
    image003.jpg

    When I opened the X3D file in notepad, I saw that only one of my texture maps had a "ImageTexture" line in the file.
    image004.jpg

    It took me a while to figure it out, but I also had a Material defined on the object--- that apparently was hindering my image map from being included in the X3D export. I removed the material, exported again, and made a new zip file.
    image005.jpg

    This time BOTH images were referenced. When I zipped the X3D file and my two image files, everything was fine and dandy in the Shapeways render and more importantly, my print.
    image006.jpg
     
  12. alaincassis
    alaincassis Member
    I think I'll resign,

    Best results here, with W3D or WRL, Blender & MeshMixer :


    Code:
    <iframe width="625" height="652" frameborder="0" allowfullscreen allowtransparency src="//www.shapeways.com/fragments/product?spin=2D5D7EFLX"> </iframe>
    ( Impossible to show my uploading object with embed code I found here )
    Same with Blender & Meshmixer.

    I can upload this 3d files everywhere expert here !!

    I try to print something in Shapeways, but I am not a smart développer, and Shapeways seems too tricky for me :
    Other competitors are more for idiots like me !
    https://skfb.ly/FpAD

    or:
    [​IMG]
     
    Last edited: Jul 3, 2015
  13. mkroeker
    mkroeker Well-Known Member
    Could you provide the problematic zip (wrl/x3d and texture) as well, the one that shapeways cannot cope with ? As far as I see the file you uploaded
    to sketchfab is obj, so it would "only" allow someone to create a working wrl+texture, but not tell what the problem is with your uploads (also I do not have - nor intend to create - a sketchfab account).
    Or is it that the competing services can handle the texture information from the obj, so you use obj there and try wrl only for shapeways ? In that case, you could also try .dae ("Collada format") where - I believe - the texture can be included in the same file as the geometry, just like obj.
     
  14. alaincassis
    alaincassis Member
    Thanks !
    here is a .dae & texture zip.

    Yes I usually use .obj, but try X3D & .DAE only for Shapeways, without success.


     

    Attached Files:

    Last edited: Jul 3, 2015
  15. mkroeker
    mkroeker Well-Known Member
    Had a quick look at it - the DAE contains only a plain white color setting for the bust, and does not use the texture file at all (same as the marceline wrl
    you uploaded earlier). I am at work and cannot simply install meshmixer here to try for myself, but from a quick internet search meshmixer should be perfectly able to export from a textured OBJ to a textured DAE. (BTW the source of that information - a discussion thread in the official autodesk forum for something named "recap" also happened to suggest another currently free Autodesk product for working with textured meshes named "Memento" from memento.autodesk.com)
     
  16. alaincassis
    alaincassis Member
    Blender, Mesmixer don't work for me to upload to Shapeways..

    Tried with Meshlab( just downloaded) .X3D file


    That give me this error :
    "We're unable to process this file. Check your file for errors and click 'Update File' to upload a new version."

    Very useful :-(((


    I suppose .obj files are too exotic for Shapeway ? why they don't accept this kind of files ?

    I am not a développer, nor a 3d artist, only 3dscanner builder/user.

    And tried tens and tens times something that I upload in a minute in any others websites ( in .obj+mtl+jpg) ) .

    Perhaps with new millions $ they found few days ago, I really hope they can now hire a développer for one or two days to write few code lines in order to accept .obj files as other 3d websites do ?





     
    Last edited: Jul 4, 2015
  17. mkroeker
    mkroeker Well-Known Member
    Probably depends on how many others express a strong interest in texture support for OBJ, perhaps open a new thread in Suggestions ?
    (That's the beauty of competition - from their point - or choice - for us: I know I cannot upload most of my WRL files to those competitors, as they do not support certain parts of that specification. And your meshlab file could simply be too big or too complex, or be in a zip that has subfolders - we are going in circles if we can only guess at what you are uploading.)
     
  18. @TGAW That was it.

    The process for adding a texture to a model is kinda weirdly specific and prone to not working for indiscernable reasons, hopefully they make the process more airtight and straightforward.
     
  19. Gotele
    Gotele Member
    Thanks @TGAW, I was going nuts over this!
     
  20. RJP_MODELS
    RJP_MODELS Member
    This drives me crazy. I've asked repeatedly over the years for help from shapeways and they refer me to the same useless information on how to attach zipped image files. There are many shapeways staff that make photo texture models and they can't be bothered talking us through how they actually do it. There must be multiple ways they know of to achieve this. They should upload videos on youtube that walk you through. What's the point in offering photo textured 3d printing when only rocket scientists can use it? )-:
    Does anyone know any of the rival companies that can 3d print photo textures and give advice that actually works?