Blender: How to create meshes without tons of n-manifolds

Discussion in 'Software and Applications' started by MickLang, Dec 15, 2008.

  1. MickLang
    MickLang New Member
    Hey everyone,

    I've got a dilemma and every noob2pro/book or guide I've found doesn't answer the question on how to create extruded models without non-manifolds.

    I create 'bodies' of a mesh that are simply one-sided. When I extrude them (by region), I get loads of these non-manifold polygons that take hours to correct. Is there a better way to create objects that have double-walls?

    Thanks for your help and happy holidays!

    Mick
     
  2. bartv
    bartv New Member
    Hi Mick,

    that's not easy to answer without seeing your models. Could you post the model before and after extrusion? I'll then take a look at it for you.

    Cheers,

    Bart
     
  3. MickLang
    MickLang New Member
    Here's the .blend after extrusion.

    Thanks,

    Mick
     

    Attached Files:

    Last edited: Dec 16, 2008
  4. MickLang
    MickLang New Member
    Hi Bart,

    Attached are the two blender files. The first, with 'no_extrusion' as the file name, has just the shell of the mesh without being extruded. It only has one side.

    After I select the polys that I want extruded, I performed an 'individual face' extrude and get (as predicted) loads of non-manifolds.

    Is there a recommended way of extruding or adding a second face onto a mesh so that I can have a hollowed object in Blender?

    Thanks for your time-- I really appreciate it.

    Mick
     

    Attached Files:

  5. frigi
    frigi New Member
    Don't use "individual faces" because that does exactly what it says, it extrudes individual faces. You really don't want that.

    What you should do instead is use "region" and then scale it along the normals with alt+s or even better: Just use the solidify script. (mesh -> scripts -> soldify selection) Most of the times you get better results with that.
     
  6. MickLang
    MickLang New Member
    Thanks Joris!

    I currently don't have that script loaded, but I'll go get it now.

    Thanks for your great help!

    Mick
     
  7. frigi
    frigi New Member
    I'm not exactly Joris but I'm glad I could be of help anyhow. ;)

    You don't need to download that script btw. it's built in right in Blender. (just follow the instructions I already gave you)

    Yours,
    Fabian
     
  8. MickLang
    MickLang New Member
    I'm sorry Fabian,

    Dumb-ass me for some reason thought it was Joris that supplied that bit of help.

    Thanks a million anyways. My 2.48 version didn't have any scripts (or it was loaded wrong. Either way I downloaded the scripts (and correct version of Python) so I should be on my way.

    Thanks again and happy holidays!

    Mick
     
  9. Hi, I would appreciate some help.
    I use Ashlar Vellum Cobalt to creat my 3D models. So far so good as I have never had a problem with an STL file before.
    I upload it to shapewaysand am told that it contains non- manifold surfaces.
    I open it in Mesh lab where it looks fine and tells me there are no non-manifold surfaces, then I open in Blender trying to follow the tutorial. None of those nice remove duplicate surfaces or check for non-manifold surfaces seem to be available to me. I have downloaded and installed python along with it, but these options don't appear.
    What can I do? I have a model that looks fine in 3 applications but looks decidely iffy when I view it on the shapeways viewer. Tired and frustrated and would appreciate any help.

    Thanks
     

    Attached Files:

  10. PeterHermans
    PeterHermans New Member
    Fixed it using magics. There were some overlapping poly's and open edges.

    However, I have a model that was 100% ok in magics and still does not pass the Shapeways validation (inverted normals) so I'm not guaranteeing success.

    Oh and you have some very thin areas (thicknesses of 0.6mm and less) that might not come out ok. It is best if you thicken those to at least 1mm.
     

    Attached Files:

  11. Thanks for that
    I now need to move on to 2 other files that still won't pass the shapeways tests.
    Again, I have removed the double vertices but no non-manifold surfaces show up.
    When you know there are no non-manifold faces to find, for me with very little mesh experience it makes finding the real problem almost impossible.
     
  12. ArMOO
    ArMOO New Member
    Joseph,

    If the file is fixed with magics then yoy just have to open the file in meshlab and save it again as stl.

    Aparently shapeways needs another type of stl, wich what or how I don't know, but it worked for me.

    Greetings AO
     
  13. I am not famiiar with Magic.is it Magic 3D?
    I have two other files that are resolutely refusing to be acceptable. I don't want you fix them (yet) as I would rather find the tools to solve it myself and learn in the process.
    Proving time consuming though.

    Thanks
     
  14. ArMOO
    ArMOO New Member
    Hi Joseph,

    Peter fixed it with magics from Materialise wich is I think a very specialistic and expensive piece of software.
    But very good and fast.
    Just post your files if you have problems. There's always somebody that finds pleasure in helping others.

    Greetings AO
     
  15. Hi
    Deep frustration setting in.
    The file is attached. I have rebuilt it and checked for errors but cannot find any in the 3d Data, Can't find any non manifoldness about it either.
    On another part I removed some blended surfaces and that seemed to solve the problem. not with this one unfortunately.
    I would appreciate it if someone had the time and patience to have a look at the file and see if it can be fixed.

    Thanks
     

    Attached Files:

  16. robert
    robert New Member
    Hi Joseph,

    You have 3 open edges in your model. You can see them highlighted in yellow in the screenshot below.

    headinner1.png.jpg

    Best regards,

    Robert
     
  17. ArMOO
    ArMOO New Member
    Joseph,

    This file is printable, check the size if you upload.
    I didn't do it.

    Greetings AO
     

    Attached Files:

  18. Thank you very much for that. I spent a day in blender trying to fix it but couldn't get my head round it.
    Re; The scale. The file needed to be reduced to .941 of the size you sent me in order to get it back to it's correct size. Funny scale that. Is there a scaling issue when importing into certain software that would send it off ever so slightly like that?
    Anyway, its off to shapeways now with the other 11 parts that make up its assembly. This is my first with Shapeways. I'm hoping its all ok from hereon.

    Thanks again
     
  19. ArMOO
    ArMOO New Member
    Joseph,

    Thanks for the info about the scale. I have a setting somewhere wrong and I have to find out what or where.
    I new it can be something like 10 percent.
    Therefore I mentioned to check the scale, just in case.

    Greetings AO