Blender 2.5 and shapeways

Discussion in 'Software and Applications' started by calli, Aug 31, 2010.

  1. calli
    calli New Member
    Hi,

    I just tried to get some simple test case up to shapeways. After two days I am quite frustrated. STL is ok beside that strange scaling. But colored formats give me headache.

    I think I tried a hundred times with no real luck (either nothing happened or textures where misaligned, wrong scale, etc)

    - The error messages from shapeways are strange, sometimes helpfull (your design is 2x3x2 Lightyears or such) sometime just vanilla "Based upon the size, volume and wallthickness of your product there is no printer available which is able to print your product. Please adjust the volume and/or size of your product. " which does not mean anything to me, is it too big, too smal? Just print the size here also

    - Meters, Inches, Millimeters? Why not also Centimeters? Why not just give us the possibility to scale by a factor here?

    Then I tried meshlab. Used .OBJ as format to load into Meshlab, then tried to export as .dae, .wrl and x3d, packed into a .zip with the texture and uploaded: "The fileformat of your object cannot be processed by our software. Please investigate the problem and try again. "

    I think the tutorials and guides are a bit outdated and not tagged with the version numbers of (in my case) Blender. Possibly shapeways does not work ok with Blender 2.5 (only dae and x3d exporters avail).

    I know about the offer that shapeways tries to fix my files, however I want to be able to do it myself ofcourse...

    A new tutorial how to use Blender 2.5 and be ready to print a 2cm sphere with a world map applied correctly would do also ;.-)

    Carsten
     
  2. Laertes
    Laertes New Member
    Hi there,

    I for myself found that Blender 2.5 was completely incapable of uploading files so that it really worked together with Shapeways(I didn't even get it to read a non-color-file).

    The workaround I propose(and use) is to model in Blender 2.5, then import the model to Blender 2.49(where you shouldn't loose anything, as the model shouldn't be animated or anything - only posing could be a problem), then possibly setting up all color-related data if that is required and then export it via Blender 2.49, which works perfectly well.

    It is sort of no real solution, but if you're in a hurry to get something printed...

    Greetings,
    Laertes
     
  3. macky
    macky New Member
    I concur!
    This whole color thing is driving me f**ng crazy due to either docs being extremely poor or any blender info / blender itself being from another planet entirely.

    I won't get into what I think of Blender as a 3D app but suffice to say I'm not extremely happy atm.

    Anyway frustrations aside..
    I have one very simple question...


    "Is it even possible to export from blender(2.49b and above) using the X3D format, an object that has a material associated with it that has an image map and a uv for uploading to blender????????:"


    IF SO....
    Can some one PLEASE update the docs with a working X3D exporting Tutorial (the current X3D tutorial is for STL not X3D I might add) this includes what happens inside blender with materials, do yaneed to assign one? Manually edit a file? ????
    Lets get this nut can be cracked once and for all and stop making peoples hair turn grey (which is entirely the wrong color things should be going) ...
    kk ty

     
    Last edited: Oct 1, 2010
  4. macky
    macky New Member
    finally I cracked it...
    I feel a video tutorial posting coming on.....
     
  5. Sevensheaven
    Sevensheaven New Member
    Hi,

    I'd love to read or see what the solution is for this issue. I've switched from 3ds Max to Blender 2.5x and there is no VRML97 exporter yet, and X3D gives me an error (saves as a 0 bytes file).

    Thanks in advance.
     
  6. bartv
    bartv New Member
    Hey guys,

    I'd love to see more info on how to work with Blender 2.5 and color models. Let me know if you don't have the time to prepare the videotutorial and I'll find someone who does!

    Bart
     
  7. Zander Nicolic
    Zander Nicolic New Member
    Hi Calli,
    I've to admit that my uploads are not always successfull at first trial.
    Anyway, in my experience, choosing "Metric" in the Scene panel (the one to the right of the render camera icon) solves the problem.
    Usually you see that your model has meter dimensions in the Toolbox, so scaling by a factor of 0.01 in Object mode brings it to cm.
    Saving as Collada (.dae) permits to avoid choosing dimensions at upload time and usually works well.
    Accutrans3D is useful to verify "water tightness", but does a mess with dimensions (it may well be that this is my fault, though).
    I'm sorry that I cannot say anything about colors.