Bevel/Chamfer Mesh in Blender

Discussion in 'Design and Modeling' started by Aquillyne, Oct 14, 2010.

  1. Aquillyne
    Aquillyne New Member
    I have a complex mesh (a sculpture) with sharp edges all around that I want to chamfer/bevel i.e. smooth off.

    I have the model in Blender but I'm open to any other free solutions!

    My trouble with blender is when I apply the bevel modifier it bevels every single faces, or not enough of them, and I get a resulting model full of holes! I can't work out how to just bevel the sharp edges.

    Any help much appreciated - this is for a present.

    Thanks.
     
  2. Go into edit mode and use the edge selector to choose your sharp edges. Hit the 'w' key, and Bevel should be in the menu that pops up. Alternately, you can get there through the GUI: Mesh » Edges » Bevel. Either one gets the same result.

    Play around with it, see what comes up. Sometimes I get different results in certain models depending on if I bevel it a chunk at a time, or if I just select all my sharp areas and bevel them all at once.

    Hope this helps!
     
  3. Aquillyne
    Aquillyne New Member
    How do I select the edges?

    I'm sorry I just can't work this out. I'm quite new to Blender.

    I keep getting the result that each edge is bevelled as if it were isolated - I end up with gaps between all vertices.
     
  4. Aquillyne
    Aquillyne New Member
    Alternatively I end up with little dips at every vertex in the final bevel.
     
  5. clsn
    clsn Well-Known Member
  6. Ivan_
    Ivan_ New Member
    The problem might stem from the way your object was modeled. I've had problems with duplicate vertices (from canceled extrudes, and whatnot). To clean those up go into Edit Mode, select all vertices ('a' key), hit the 'w' key and select the 'Remove Doubles' option. Then try beveling again.

    Don't know if this is the problem or not, but worth a try.
     
  7. Aquillyne
    Aquillyne New Member
    Thanks for all the help, but what I keep getting is that when I bevel, the model gets loads of 'dents' in it - at every vertex - and some 'cuts' as well along certain edges.

    Even if I painstakingly select a whole edge, 1 edge at a time, and then use W -> Bevel, it forms a dent at each vertex along the way.

    I have run the model through all manner of simplification, using Meshlab, netfabb, and removed doubles in Blender. These helped a lot to clean up the mess, but mess still remains.

    I'm really at a loss. I just want to cut off the sharp edges!

    Solution? - print with sharp edges, file them off. What do you think? Is this a viable solution? What material would I have to use? I am hoping to use Silver or Steel. Will that make post-production difficult?

    Thanks everyone.
     
  8. roofoo
    roofoo Well-Known Member
    Try using a subsurf modifier and add edge loops close to the edges you want beveled. For sharper edges, keep the edge loops very close together.
     
  9. clsn
    clsn Well-Known Member
    Bevel always bevels the whole model. I don't know why. There isn't anything you can do about it, removing doubles and stuff won't help.

    The "bevel center" script I linked to is the only thing I know offhand that will bevel only certain edges. Has that not worked for you?

    roofoo's subsurf modifier idea is also worth trying.
     
  10. clsn
    clsn Well-Known Member
    Looks like you can also add a "Bevel" modifier, which can be set only to bevel edges of a certain sharpness, etc.

    (I haven't experimented enough with modifiers in general, there may be other goodies there that could help you.)
     
  11. GHP
    GHP New Member
    You could also trying smoothing (the "Smooth" button in Mesh Tools in Edit mode, or HC Laplacian in MeshLab). This will work best if your model hasn't been simplified too much, so you may want to try subdividing first, or going back to a version of the model that hasn't been simplified.

    Smoothing selected faces may cause a noticeable ridge to develop at the edges of the selected areas, so try applying it to your whole model. The effects should be most noticeable at the sharp edges.
     
    Last edited: Oct 14, 2010