Anyone successfully exporting from Solidworks?

Discussion in 'Software and Applications' started by crisrose, Jul 29, 2008.

  1. crisrose
    crisrose New Member
    Hey there,

    So i'm a real Solidworks head, but i've had problems in the past getting pieces accurately printed/CNC Milled due to the limited output formats.

    I exported an STL (which looked far too tessellated) and on transfering it to my Mac and uploading, came back errored. It seems that the file wasn't even openable when i emailed it to Joris.

    Tried again with more detail, and Solidworks crashes out.

    Solidworks uses the .prt file format.


    So, has anyone had any success getting something built in Solidworks, printed up without too many errors or lost detail?

    Really keen to get this piece printed so i can make a mould from it asap!!

    Thanks for any help :)
     
    Last edited: Jul 29, 2008
  2. crisrose
    crisrose New Member
    okay, a bit of an update for anyone else using Solidworks and suffering these issues:

    STL Scale

    Firstly, there are no settings in Solidworks for adjusting the scale. It was set for Millimeters, but was being read by the Shapeways uploader as Meters.

    The only solution was to save in STL, reopen in AccuTrans 3D, and on Saving (with options) setting the scale to 0.001 on all 3 axis.

    NOTE: The suggestion to 'Extrude Pseudo 2D Surface' made my model seem quite screwed up in the thumbnail, but still uploaded and said it would print. However, it was saying it would cost 2x what it should, suggesting that it doubled the volume somehow.



    STL Resolution/Quality

    For some reason, there were errors in the app itself that meant that no matter how high i set the resolution detail, it would output at around 8K polygon.

    It took me a while to realise that even though the preview showed a smooth mesh, it was still saying "is 8K polys ok?" when i saved.

    I found that by starting at the "Fine" setting, i could nudge the sliders up a bit, exit the program, and the next time i tried to export to STL, it would be a slightly higher Poly count.

    After a lot of nudging, exiting, opening, saving, exiting, nudging, exiting, opening... etc etc, i managed to get 10K, 20K, 50K, 100K and then finally 200K.

    NOTE: I had to minimise the Part window when i was saving, as the preview of the mesh would crash the app - however the dialogue window would read out the number of triangles before you save.

    100K looked okay, but there were still visible tessilation - only a slight nudge of the angle, doubled the Polycount and made it finally super smooth.

    Final filesize was 10mb.



    Up to 50K polys, the part becomes avalible on the website very quickly. I'm still waiting for the 200K model to become avalible.
     
  3. joris
    joris New Member
    Thank you so much for your advice for everyone!
     
  4. crisrose
    crisrose New Member
    Just an update - I uploaded 100k and 200k poly version, and neither of them have appeared on the website.

    However i have had no feedback or error message. They've just vanished!!

    I need to get this printed shortly too, so some feedback regarding the max polycount would be useful?!

    Cheers
     
  5. pete
    pete Shapeways Employee CEO & Co-Founder
    Hi,

    have you solved the issue?

    Peter
     
  6. crisrose
    crisrose New Member
    I've dropped the resolution right down to 60k faces, and i'm still not getting a reply saying it's uploaded, or any other email for that matter.

    There was an error before in that the mesh wasn't "watertight" - i had a floating surface, but that's fixed now.

    Any feedback chaps? 60k should be fine, right?

    It can't be an error with the file, even when i had that floating surface i was able to upload a 20k face version and it said it would print...

    Cheers :)
     
  7. pete
    pete Shapeways Employee CEO & Co-Founder
    Please drop a mail to service[at]shapeways[dot]com.
    Will have a look for you.

    regards,
    Peter