Anyone having trouble with scale today?

Discussion in 'General Discussion' started by Zeeflyboy, Jan 27, 2013.

  1. Zeeflyboy
    Zeeflyboy New Member
    I'm having a very strange problem... I uploaded some parts earlier today and they worked fine.

    I went to upload some more parts just now and shapeways takes them as meters rather than mm. I checked my models and they are correct, I checked the .stl settings when I save and that is set to mm, I checked the shapeways drop down menu is set to mm and yet still it comes back and uploads in meters!

    No idea what's going on.... first time I've had this problem and I've uploaded many many models previously.

    EDIT - and I just updated a couple of models that previously updated fine - I get a note saying they were too big at the meter scale and have been changed to mm. Something is screwy for sure, but is it only me?
     
    Last edited: Jan 27, 2013
  2. Magic
    Magic Well-Known Member
    Yes same issue here. Updating a previous model works fine though.
    So I guess the work-around is to upload a very small model like a cube of 0.01x0.01x0.01mm and then to update it with the correct model.
    Or you can wait for the bug to be fixed...

     
  3. Zeeflyboy
    Zeeflyboy New Member
    I just updated two models and they were resized too - but due to their physical size they were changed from meters to mm which ends up correct anyway.

    Hopefully they fix this soon, I'm not going to risk an order while the scale is messing around.

    cheers
     
  4. Fredd
    Fredd New Member
    I know that for several file formats you have to set unit measurement at upload to the size you want printed, especially a stl but how do you set it to mm at save?
     
  5. Zeeflyboy
    Zeeflyboy New Member
    in my program when exporting my model as an .STL I can click options, then set the desired resoution settings and scale to mm etc.

    I'm not sure it's strictly relevant, as it's still just "units" and if you choose inches when you upload then it'd end up in displaying those units as inches... but the option is there.

    Anyway, since it's not just me clearly there's a bug in the shapeways system at the moment. For the record I'm still having issues with uploaded models but updating existing models appears to be working.
     
    Last edited: Jan 27, 2013
  6. Bathsheba
    Bathsheba Well-Known Member
    STL files don't have units -- they contain only triangles, there's no place to put anything else -- so any software that claims it's saving an STL "as" a certain unit is lying. STL units are set at upload time, not at save time.

    That's why you have to tick the mm/inches/meters box when you upload to Shapeways: otherwise it truly has no way to know the size, because there are no units in the file.

    I uploaded a file in the wee hours today (http://www.shapeways.com/model/892684/the-1-pendant.html, it's super silly) and it went fine. New model, not an update.
     
  7. Zeeflyboy
    Zeeflyboy New Member
    Hence why I said I'm not sure it's strictly relevant lol. Thanks for confirming.

    I too uploaded earlier today and it was fine, it's only since this afternoon that I've experienced trouble. The units selected when I upload are 100% for certain mm, but it then tells me it was too large so has been changed from meters to mm/inches depending on the model.

    Could you try uploading a new model now to see if you get the same?
     
  8. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    I just tried this, and it uploaded as mm. Can you try again to verify the issue is still happening? And if so, what OS and browser?
     
  9. Zeeflyboy
    Zeeflyboy New Member
    Just tried and it's still happening for me on new model uploads.

    Using both OSX with safari and Windows 7 with IE. Scale is selected as mm from the drop down menu but it ends up trying to do it in meters, model is too big and ends up in inches.

    This particular model is 20 "units" in diameter, as you can see from the link shapeways ends up making it 20 inches despite my selection of mm from the drop down menu when I upload. On other models that are bigger it changes the scale from meters to mm and ends up correct by an incorrect means.... like I say this problem only started for me on sunday afternoon - previously I never had a problem.

    http://www.shapeways.com/model/894761/damiano_flir_pod_beari ng_mount.html

    when I first enter the model page i get this message

    "Attention

    Your model was too big for the printer when using the meter scale
    However, we scaled your model using the inches scale, now your model at 20.0 x 20.0 x 5.0 inches, or 50.80 x 50.80 x 12.70 cm can be printed!
    If this is not the scale you intended, please rescale your model and re-upload."


    By first uploading a part that gets converted by shapeways from meters to mm and then updating the file with the actual desired model I end up with a correctly scaled model....

     
    Last edited: Jan 28, 2013
  10. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Can you email me the model, or post it up on this thread? I'll get someone to look into what's going on.
     
  11. Zeeflyboy
    Zeeflyboy New Member
    Here's the .STL

    as I say though it isn't just this model, it's every model I've tried to upload since sunday.... including ones that previously uploaded fine. I confirmed it by uploading another .stl from a few weeks ago which worked fine the first time I uploaded it back then and the same happens.
     

    Attached Files:

    Last edited: Jan 28, 2013
  12. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    I realize that, but it helps to have a "this item does this" when figuring out what's going wrong.
     
  13. Zeeflyboy
    Zeeflyboy New Member
    yeah sure, no problem - I just wanted to be clear it's happening across all models for me.

    If you need anything else just shout.

    cheers
     
    Last edited: Jan 28, 2013
  14. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    Alright verified that it happened to me as well, so I'll report it.
     
  15. Zeeflyboy
    Zeeflyboy New Member
  16. MitchellJetten
    MitchellJetten Shapeways Employee CS Team
    Hey guys,

    We have found the issue and are currently fixing this.

    This will be fixed before the end of this day.

    Our apologies for the inconvenience and confusion :)

    Cheers,
    Mitchell
     
  17. MitchellJetten
    MitchellJetten Shapeways Employee CS Team
    Hey all,

    The fix has been released :)

    Please let me know if you are still having these issues!

    Mitchell
     
  18. Magic
    Magic Well-Known Member
    No, it is working properly now.
    Thanks!