Anyone have a Bulk Uploader (or any other) Examples to Share

Discussion in 'Shapeways API' started by wisar, Feb 26, 2016.

  1. wisar
    wisar Member
    I have hacked the Python example script that Shapeways provides to do a bulk upload. It worked for a while and then stopped. I tried getting help from Shapeways and then sent me packing. I have also tried StoneySmiths demo script and get a security error with it as well. The step to generate keys works fine but then I get this message "{u'reason': u'Authentication Error',> u'result': u'failure', u'oauth_error_message': > u'oauth_problem=parameter_absent&oauth_parameters_absent =oauth_token'} " This is the same message that I am now getting from my previously working script. The one that had no changes made to it and now does not work...but is in no way related to any possible problem with the server side according to Shapeways.

    I really would like an example in Python but Node would be good as well. Kind of disappointing that Shapeways would not at least look at my issue or point me to an example that does more than just a signon.

    Thanks for any help. I hope there are people actually using the API as this seems like a very quiet room!

    Will

     
  2. Bathsheba
    Bathsheba Well-Known Member
  3. wisar
    wisar Member
    Thanks for the info. This is a very very quiet area of the forum. Can't be many people using the API or they are all a lot smarter than me.

    My code is now working. Interestingly it seems that restarting the browser fixed the issue. Does not make sense to me as I had tried on different machines ... but ... on one of the machines I tried I was getting an SSL certificate error and I wonder if the server took that as a security exception and turned me off? It still will happen occasionally but again a restart fixes it. Like I said, does not make sense, but as long as I can upload my files, marrying information from a flat file for the name, description, and tags, I am happy.

    In any case, no thanks to a pretty worthless exchange with Shapeways API support, I have the upload functionality that I need working.

    Cheers,
    Will
     
  4. stonysmith
    stonysmith Well-Known Member Moderator
    Ahhhhhh.....
    If the problem was resolved by restarting your browser, that means that the certificate had not been stored on your computer yet.
     
  5. wisar
    wisar Member
    Except that it works for a while before starting to error out....

    I am going to try your script again but I could never get it to authenticate using both sets of tokens. It does not matter as I have the upload working well enough to do what needs to be done.

    Thanks,
    Will
     
  6. NimlothCQ
    NimlothCQ Shapeways Employee Product Team