Anyone else having trouble opening a shop?

Discussion in 'Shapeways Shops' started by Kaede, Feb 7, 2011.

  1. Kaede
    Kaede New Member
    Is anyone else having trouble opening a shop? I fill everything in and click the button, and nothing happens.
     
  2. cniemira
    cniemira New Member
    Same!

    I thought it might be the javascript blockers I have enabled in Firefox, but I switched and tried two other browser... no luck. :(
     
  3. Youknowwho4eva
    Youknowwho4eva Shapeways Employee Community Team
    This is no good. I'll start bugging the people that can help :p
     
  4. ana_xyz
    ana_xyz New Member
    Officially bugged! Lemme see what going on here guys...
     
  5. ana_xyz
    ana_xyz New Member
    FYI that was "bugged" in a good sense. It was the short-hand wording for "issue registered. Thank you for the heads up, Michael. :D
     
  6. cniemira
    cniemira New Member
    I was just able to create a shop! Just waiting on a manual review.

    Thanks!
     
  7. ana_xyz
    ana_xyz New Member
    Can you guys give me any more detail on the problem, and what happens? @Kaede, you put in all the information and it just hung there, with no response from the page?
     
  8. Kaede
    Kaede New Member
    Yep, I put in the info, and nothing happened. I was expecting something along the lines of a "Thank-you, we are reviewing your request and will get back to you shortly." message, but it looked like nothing happened at all if I clicked the "save" button. ( I was using Chrome, and I believe it did say "javascript error. " )

    Still, it must have gone through since I got a notification today letting me know the shop had been opened.
     
  9. ana_xyz
    ana_xyz New Member
    Ok, it definitely does sound like a Javascript error.

    I'm glad it finally worked out for you two, but I'll still have the dev team take a look.
     
    Last edited: Feb 10, 2011
  10. As an FYI on this issue, I have been trying to open a shop and haven't had any success, but I'm waiting patiently.
     
  11. Bunrattypark
    Bunrattypark New Member
    Me too, same as above.
     
  12. ana_xyz
    ana_xyz New Member
    Sorry to hear it, guys. @Elizabeth, @Bunrattypark I'm hoping you two can give me a little more info so I can provide the dev team with as much detail as possible.

    1. Which browsers did you try this in?

    2. Which operating systems are you both running?

    3. When did you both have this problem?

    Is there anyone else on this thread who's still experiencing the same issue?

     
  13. Hi, Ana,

    I'm using Internet Explorer 8 and Windows Vista. I tried several times on Feb. 28 to open the shop before posting in this thread, but nothing happened when I clicked on the button to open the store. I'm in the U.S., on EST (GMT-5), just to help keep the timeline of events straigtht.

    I think I know now what was happening, though.

    Since I'm in the U.S., Shapeways didn't need a VAT number from me to open the shop because I will be responsible for collecting and paying the taxes myself.

    However, as with the others above, there was no immediate reaction or message from the site itself to show that my information had been processed and was being reviewed for approval.

    Meanwhile, I used Creator and a photo to create a 3D photo, just to see what it would look like, and I saved the model. The e-mail that the model had become printable was sent out at 2:32 AM EST, Mar. 1.

    Then, the e-mail saying that my VAT, or lack thereof, had been checked and my business information had been approved was sent out at 3:17 AM EST, Mar. 1.

    When I opened and read that e-mail, I came back to the site, clicked the button to open the store, and at that time the Javascript opened to ask for the business name and URL that I wanted to use. I filled that in and received a message that my shop had been opened and, when that information had been reviewed and approved, my shop would be unlocked.

    The e-mail that said my store had been unlocked was sent out at 8:34 AM, Mar. 1.

    So, it seems as if everything is actually working as it should. All that's missing is some sort of immediate response from the site, a message that lets those who try to open shops know that the first set of information, the billing and shipping addresses and so forth, has been received and needs to be reviewed and approved before the button to open the shop will respond to being clicked. There is a message that does say that the VAT or Chamber of Commerce number must be approved before a store can be opened, but that apparently isn't enough to make it clear enough to some of us that Shapeways did receive our information. It was also confusing to me, particularly after I realized that Shapeways did not need a taxpayer ID from anyone outside of the EU.

    Thanks for you attention and help,

    Elizabeth

     
  14. Bunrattypark
    Bunrattypark New Member
    I have tried every evening this week, but always the same, I cannot access the SAVE function to open the shop. I have used Firefox and IE9, with Vista, and the latest version of Java uploaded.

    Any word of progress on this issue? Many thanks...
     
  15. bluelinegecko
    bluelinegecko Well-Known Member
    Having the same issues with crome and IE8. Can't open a shop with either because it wont save my info

     
  16. Bunrattypark
    Bunrattypark New Member
    I downloaded Google Chrome, and managed to open the shop that way.
     
  17. ana_xyz
    ana_xyz New Member
    Hey guys, sorry about the glitches here.

    @Bunrattypack, switching browsers is how I eventually got shop creation to workl, only I started in Chrome, and was eventually successful in Firefox.

    Last I heard the development team was trouble shooting this. I'll try and get an update on where things are at.
     
  18. horstnyc
    horstnyc New Member
    I've definitely been able to reproduce this issue. It looks like a javascript problem on the page that's preventing the button from submitting its input to our web server.

    I've bumped this up to a high priority and am hoping to fix it in the next couple days.

    -Ben
     
  19. horst
    horst New Member
    I see everyone on this thread now has a working shop. Can anyone follow through and let me know what breakthrough solved the problem(s) for you?

    I've continued testing and the functionality has been working much more solidly for me lately. Could be related to some ongoing work we've been doing...

    -Ben
     
  20. Hi, Ben,

    I posted a follw through above in response to a request for information from Ana. Now, I just have to master MeshLab. :)

    Elizabeth