3dsMax .DAE Export

Discussion in 'Software and Applications' started by JamesClarke, Jan 7, 2016.

  1. JamesClarke
    JamesClarke Member
    I'm using 3dsmax 2016. Anyone know if the built-in .dae exporter from Autodesk (that goes through the FBX exporter I believe) works with Shapeways with regard to including texture files designed for Full Color Sandstone? I have tried a couple tests so far and they seem to fail on the shapeways object preview. Objects just show grey(material's diffuse color), no texture. I tried a .dae directly (in case the texture file was embedded), as well as zipping the .dae and the texture file together. Material is Standard with a regular bitmap, texture file is JPG.

    Upon import back into 3dsmax, the dae has the texture file mapped appropriately. Attached is a test box object with the texture file, as uploaded.

    New to Shapeways, trying to learn the ropes, thanks!
     

    Attached Files:

  2. Shea_Design
    Shea_Design Well-Known Member
    Probably a bitmap path issue. If you have to, open the WRL file and check the txtr map name and path. This format has worked for me. -S

     

    Attached Files:

  3. mkroeker
    mkroeker Well-Known Member
    I looked at the .dae and saw nothing wrong with the texture file path, and nothing obviously wrong among the texture options.
    Can you try saving as wrl (VRML2) instead (same procedure of creating a zip file) ?
     
  4. JamesClarke
    JamesClarke Member
    Going into more detail here than needed in case it helps more folks next time -
    Yeah okay, I didn't realize that collada was ascii. Prior to your responses I opened it up and it is writing to collada schema version 1.4.1, not sure what shapeways expects. The texture and material references are both mentioned in the dae (I'm just inspecting the file I uploaded on previous post.) I found some references to using this "View 3dScene" app to inspect your files, I tried it out and it did indeed error on no 2d sampler found and can't find material #26. I messed with some ideas there but abandoned it not knowing enough about the collada schemas to fix by hand.

    So instead I tried the Khronos group / OpenCOLLADA plugin available here. That generated a slightly different dae, it had a 2d sampler, though the texture path was wrong so I edited that for the correct texture. Once the texture path was corrected, it opens in view3D without any errors displayed, but renders it wireframe, no surface or texture displayed. I uploaded it to shapeways anyway, and interestingly enough it almost works. the texture file appears, but the texture coordinates appear to have been corrupted or the vertex ordering is different somehow, because the texture is stretched incorrectly across each face. (and again this was just a simple test with a box where each face should have 0-1 texture space and the texture displayed normally, about as basic as you can get.)

    So that brought me back to WRL. I was trying collada because I had more faith in that being a newer format, and also for some reason VRML is not exposed to Max's "Export Selected" menu item, you have to do "export" which typically exports your entire scene, not just one object, so I tend to avoid. Luckily, the VRML exporter does have a checkbox on whether or not to export hidden objects, so that will let me control what gets exported form a larger scene easy enough. EDIT: False. It appears the "export hidden objects" checkbox does nto actually work. Leaving it unchecked still produces a wrl that includes the hidden ones. I'll have to make a 3dsMax scene that has only my print objects :(

    So indeed, looks like VRML is the way to go. My next steps are going to be testing out multi material setups VRML to see what I can get away with there (MultiSubObject materials in Max supported? Multiple map channels supported?)

    Next question - anyone know if the hardware for the sandstone printers (I'm assuming they're the 3dSystem's Projet660 line) has specific limitations for texture resolution? I know Shapeways has a 65MB upload limit, and I know there is a DPI/resolution limitation as far as how detailed the actual printed result is, but I was hoping I can just cheat with my uvmaps and do an easy quick flatten and just bake really high resolution to account for any poor UV mapping
     
    Last edited: Jan 8, 2016
  5. Shea_Design
    Shea_Design Well-Known Member
  6. mkroeker
    mkroeker Well-Known Member
    Doing some more digging to make sense of the view3dscene warning, the correct syntax for the Collada texture option appears to be:
    as written in diff/patch syntax, i.e. you need to add the lines prefixed with "+" and remove the one prefixed with "-",
    or in other words, add the <newparam>...</newparam> blocks for a "surface" that uses the image and a "sampler2D"
    that uses that surface, and finally replace the name of the image in the texture statement by the name of the "sampler2D"
    entity. The resulting zip now actually uploads to shapeways, so it seems their Collada converter is a bit less versatile than view3dscene.
     
  7. mkroeker
    mkroeker Well-Known Member
    regarding your resolution questions, I think I saw mentioned that one should keep the total resolution of the texture file(s) below 4096x4096 pixels (either in one of the tutorials, or in an older thread). Actual resolution of the printed image would appear to be somewhere in the 100dpi ballpark although 3ds claims something like 600dpi resolution (which is probably positioning accuracy) so do not expect to print high-resolution aerial photography onto elevation models etc. with the current level of technology.
     
  8. JamesClarke
    JamesClarke Member
    Thanks for all the help, especially appreciate that detailed dive into the dae format.

    I've continued going down the vrml path at this point since it seems from my testing and about half the other posts on here, that still seems to be the most straightforward way to get things into shapeways properly.

    So far I've had no issues using a combination of Standard materials with only diffuse color, Standard materials with a texture map (all map channel 1), and MultiSubObject materials containing both of the previous items.

    Of note, for testing locally in 3dsMax viewport as well as the view3dscene tool linked previously, I was setting all my materials to be fully self illuminated to best gauge how the texture look without any additional lighting. On a few of them I had set their diffuse colors to white, although they had textures on them that, at least in Max, were overriding the base diffuse color. It seems however that the shapeways webGL viewer still adds light to a self-illuminated material and moreso it completely blew out the colors of my texture in the viewer once uploaded. The fully white diffuse color self illuminated plus light, was purely a solid white object. So much so that I initially thought it didn't support multiSubObject materials with multiple texture maps, because the object showed entirely solid white. On a whim I killed the self illumination and re-uploaded, and all my texture maps appeared. FYI....


    Lastly regarding texture size, I'm hoping the 4k resolution is a many years old recommendation and not any sort of legit software or hardware limit when it comes to actual printing. As of now, this current model I'm testing (have yet to buy a print) I am attempting to use multiple separate texture files that are 6k x 6k resolution. So far it all uploads and previews successfully, no issues.
     
  9. https://www.shapeways.com/tutorials/full_color_3d_printing_from_3ds_max this helped really much.

    I had alot of troubles in order to make my textures to show up on the WRL models. But when I rendered to texture I did not notice it was set to render to material shell... and I have looked through various kind of guides... THNX 3D MAX. for letting me know - hey your material shell does not export to wrl..