3ds Max texture export problem

Discussion in 'Software and Applications' started by Sevensheaven, Sep 27, 2011.

  1. Sevensheaven
    Sevensheaven New Member
    Hi guys,

    I've created a model (units: meters), baked a texture in it, and it looks correct in 3ds Max. But I can't get a reference to the accompanying texture to be included in a VRML97 export from 3ds Max. A texture reference is missing in the output file.

    I've tried adding the texture reference manually to the VRML97 file with a text editor, but then Meshlab gave me errors about missing or too much parentheses, which I couldn't get fixed.

    A Zip with the 3ds Max 2012 file and texture can be downloaded from here. Any help would be appreciated.

    Many thanks in advance.
  2. stop4stuff
    stop4stuff Well-Known Member
    Did you try opening the VRML file in MeshLab before editing the file?

  3. bartv
    bartv New Member
    Hey Metin,

    when you say 'baked in a texture', do you mean you UV-mapped it? Or did you do something else.

    I'm not sure how 3DS Max works, but we require UV mapped textures.

  4. stop4stuff
    stop4stuff Well-Known Member
  5. bartv
    bartv New Member
    For sure, you can use vertex/face coloring as well. But as sevensheaven was referring to a texture map reference I figured the problem was related to texturemapping ;)

  6. stop4stuff
    stop4stuff Well-Known Member
    I figured the same, but as 'baked in' is mentioned, I'm thinking that the sevensheaven's colouring is per face.

    @sevensheaven - more info is needed please :)

  7. Sevensheaven
    Sevensheaven New Member
    Many thanks for your replies!

    I tried importing the Max-exported VRML97 file in Meshlab first, but it indicates no presence of a texture. When I export it from Meshlab, there's no texture entry in the resulting WRL file, because the texture reference is already missing in the 3ds Max WRL export.

    In 3ds Max itself (Standard material with diffuse map) the texture is showing correctly on the model. I have followed the instructions in this page, but used the mesh's own UV coordinates for baking the texture in stead of an unwrap method, otherwise the texture became mangled on the model.

    But somehow the texture reference isn't saved along in the 3ds Max VRML97 export. The Max-exported VRML97 file + texture can be downloaded here, and here's the Max file + texture.
    Last edited: Sep 27, 2011
  8. Jettuh
    Jettuh Well-Known Member
    Hi Martin,

    Have you checked the export settings of the file in 3ds max?
    Maybe one of the check boxes is marked as yes but should be no?
  9. virtox
    virtox Active Member Moderator
    I'd be happy to take a look, can you save a legacy max (2010) file ?

  10. Sevensheaven
    Sevensheaven New Member
    Last edited: Sep 27, 2011
  11. virtox
    virtox Active Member Moderator
    The material currently assigned to the object is a "shell" material, which is not compatible with the wrl exporter and is thus ignored.

    If I assign the medit material, or one of the submaterials of the shell, the texture gets exported mostly correct.
    Only the base is somehow mapped wrong, which I can't explain (yet)

    Hint: the file will be twice as large if exported ok, because it will contain texture coordinates :)

    I am not sure how to fix the base, probably best to collapse the whole object and reapply mapping for the base only.

  12. Sevensheaven
    Sevensheaven New Member
    Thanks a lot Virtox!

    You're right, when I reassign the Material Editor's material a bitmap path appears in the VRML97 export. Weird, as the same material should have already been assigned to the mesh.

    Maybe the baking process caused a different material to become active on the mesh. I hadn't used baking before.

    Going to reupload the mesh and texture now, hope it works, and thanks again!
  13. virtox
    virtox Active Member Moderator
    Your welcome, btw you can use meshlab (freeware->google) to check how things look quickly :)
  14. Sevensheaven
    Sevensheaven New Member
    It looks good in Meshlab! You da man, Virtox! ☺