3ds Max Ring Failure to Process

Discussion in 'My Work In Progress' started by Malek, Sep 17, 2011.

  1. Malek
    Malek New Member
    heyy guys, hope you are all doing great! I have just signed up with Shapeways and I have been designing a ring in mind to be able to 3D print. After completing my ring at 3ds Max, I exported it .STL and uploaded it to Shapeways. I received an email from Shapeways informing me a problem with printing saying:

    "If you have any questions about your product, please look at our relevant tutorials or videos.
    * http://www.shapeways.com/tutorials/fixing-non-manifold-model s
    * http://www.shapeways.com/video/fixing-non-manifold-meshes"

    I went back to my 3D file and applied a STL Check modifier. I started cleaning up my file and making sure it is water-tight. After doing a final STL check, 3ds max informed me of 'zero errors'. Again, I exported it .STL and uploaded it to Shapeyways and i received the exact failure message.

    At this point I really don't know what to do with my file. I even don't know what do adjust. Hope for some advices.
     
  2. Magic
    Magic Well-Known Member
    Hi Malek and welcome to Shapeways.

    Is you model made of a single object or several ones?
    If it is made of several objects, you could have all of them being manifold but the set not being manifold itself (like two cubes sharing a face for instance: each cube is manifold but the set of 2 cubes has a double face and 4 double edges).

    Hope this helps.
     
  3. stop4stuff
    stop4stuff Well-Known Member
    Hi Malek,

    Welcome to Shapeways :)

    Grab yourself a copy of NetFabb Basic (its free). Netfabb has some good error checking and repair tools that should help you either fix your model or give you insights into what changes need to be made to make it work.

    If you get stuck, shoot me a PM & I'll try & help you out.

    Paul

     
  4. Malek
    Malek New Member
    Thank you.. I have made some changes for the model and I have downloaded NETFABB. When I tried re-uploading my model to Shapeways again a new failure message appeared to me: "empty output'. When I placed my model in NETFABB, the statistics show that my model had zero holes but 60 shells. What are shells? How can I fix them? When I used the repair tool in NetFabb, it deleted significant parts of my design. How can I fix "shells" in 3ds Max? What are they? Thank you!
     
  5. stop4stuff
    stop4stuff Well-Known Member
    'Shells' are seperate objects that make up a model. For visuals this is fine as the rendering side of things only looks at the externals, but for 3D printing, the shells need to be merged as one unit. Somewhere along the line, you've got 3 or more shells that overlap and/or 2 or more shells that share common sides.

    I'm not familiar with 3DS Max, but have a look for booleam merging tools to combine shells... I'd say start with two shells, merge them, save the file, check it out and carry on adding one shell at a time.

     
  6. Malek
    Malek New Member
    ahh ok.. that is true. My ring consists of many shapes that intersect with one another. I used to 'attach' each object with the other but it seems that this doesn't work. The only way I see what you mean in 3ds Max would be to merge vertices together. So shells are the components that make up the object. So the solution would be to weld the vertices together, is that correct? Thank you so much for the help.
     
  7. stop4stuff
    stop4stuff Well-Known Member
    Hi Malek,

    Merging verts would only merge those verts within a specified distance from each other, you'd still be left with the intersecting part within the merged shells, this might cause even more problems.

    I had a little hunt around, I think this thread on 3dtotal forums might help you out - the search phrase i used was 3Ds Max boolean merge, there's many more results on Google including video tutorials.

    Paul
     
  8. Malek
    Malek New Member
    Yeappp.. Finaalllyyy, It worked! Thank you very much! Boolean did the trick ;))