3DS Max and unit conversion

Discussion in 'Software and Applications' started by Magic, Apr 1, 2009.

  1. Magic
    Magic Well-Known Member
    Hi all,

    I was very excited by the new material made available, so I decided to print icecubes.
    I wanted to take advantage of this opportunuty to test unit conversion since I had some problems with my previous model.
    So I designed a 1cm3 cube in 3DS Max. As my default unit is mm, I made it 10mmx10mmx10mm.
    I exported it as STL file. While uploading it to Shapeways, I specified mm as the unit. And I got an error message :
    I went back to 3DS Max, changed the default unit to meter, without modfying my model. The cube was now 0.01mx0.01mx0.01m (and still 1cm3). I exported it as STL file again. While uploading I specifyed meter as a unit.
    New error message :
    Note that 39.4 inches are 1 meter.
    Finally I did a last conversion in 3DS MAx to change the default unit to inch. My 1cm3 was now 0.394"x0.394"x0.394". I save it as STL file. Of course while uploading I specifyed inch as a unit.
    This time all was correct.

    I did not make any test of "cross-unit" (saying in 3DS Mas that I work in mm and then pretending at the upload that the unit is inch). But, with this experiment, has anyone an idea on how 3DS Max and/or the upload function of Shapeways are dealing with the unit conversion ?

    Thanks,

    Magic.
    PS: I finally give up with the idea of printing icecubes as they seem not to be safe to add in your beverage. :laughing:
     
  2. virtox
    virtox Active Member Moderator
    In case the question about units is real ;)

    Max uses internal units, these are the actual values exported using STL, as far as I can tell.

    In Customize->Units Setup->System Setup you define what this max unit will be in real measurements.
    (I have this on 1 unit = 1,0 mm, seems you have it on 1 unit = 1 inch or something)

    This setting has no influence on the way Max displays measurements, only on the internal unit size.

    From your question I gather you only changed the display value ?

    Hope this helps !

    Did you try the 3ds Max pricing tool ?
    That currently forces the above issues by setting all units to 1 mm (display and system) and should probably solve your issue ;)

     
    Last edited: Apr 1, 2009
  3. Magic
    Magic Well-Known Member
    Hi Virtox,

    the question (and all the rest :D ) was real.
    And your explanation is crystal clear.
    In effect, I went to the Unit Setup panel to change units, but I missed the System Unit Setup button which was in this panel. I guess it should work now. By the way, changing the System Unit Setup actually scale your object...
    And I did not try the 3ds Max pricing tool yet. Thanks for the tip.
    Thank you very much again for your help.
     
  4. virtox
    virtox Active Member Moderator
    I think you can work around the rescale problem by first setting your system units to mm and then load your max file.
    It will complain it has a different unit size, with the option to rescale or not. I don't know which of the two, but one option should work ;)
     
  5. Magic
    Magic Well-Known Member
    Yes, in effect, there are two options when you swiitch the system unit to mm and reload a model done with inches:
    - The first propose you to switch back to inch (that what I've done, so the Zen Box is still internally in inches).
    - The second - if I have well understood - does nothing, so 1 inch become 1 mm.
    It is not complex to rescale manually, but I decided not to do it. For my next models, I will set the system unit from the beginning in mm.

    Thanks again Virtox.
     
  6. Whystler
    Whystler New Member
    Umm, aren't we supposed to reveal April Fools jokes after 12 noon of April1st? :)

    -Whystler