3d view is sometimes not updated?

Discussion in 'Bug Reporting' started by woody64, Dec 16, 2012.

  1. woody64
    woody64 Well-Known Member
    The title is: 3d view is sometimes not updated

    recently I've uploaded a model ferquently and it seems that the animated 3d view isn't updated.

    It seems to happen frequently but today I wanted to share this render and it now shows an old model version.

    Last edited by a moderator: Dec 21, 2012
  2. stonysmith
    stonysmith Well-Known Member Moderator
    The 3d preview looks to me like it's in sync with the rendered model, but I don't know what you changed to be sure.
    Is there a chance you need to clear your browser's cache?
    What Browser and OS are you using?
  3. woody64
    woody64 Well-Known Member
    Think it's not a local problem. If you take a look on the model link you should see it. compare it to the picture and you would see that the men in the rotating view has nothing in hand.
    I'm.using nearly all OS .. win7, ubuntu, android ....
    Last edited: Dec 16, 2012
  4. mkroeker
    mkroeker Well-Known Member
    But he has now - probably took the rotating guy a while to pick up his crowbar/crash axe tool.
    (There have been several reports in recent weeks of either the 3d renderer itself or the site update
    process lagging behind, sometimes for a few hours)
  5. woody64
    woody64 Well-Known Member
    I've checked my latest 6 models. None of them shows the latest version in the 3d animated view.

    That seems to me a major bug!!!
  6. natalia
    natalia New Member
    This is happening because the 3D viewer caches for about 24 hours.

    We know this is an issue (as it would be great that when you change the file the difference is seen right away!) so it will actually be fixed this week.

    You should see all your updated models by Thursday, and from then on, when you re-upload a model, the 3D view will be updated as well without a long time lag!

    Last edited: Dec 17, 2012
  7. woody64
    woody64 Well-Known Member
  8. stonysmith
    stonysmith Well-Known Member Moderator
    This is what I see in a couple of different browsers:

    It looks correct to me.
  9. woody64
    woody64 Well-Known Member
    That's really strange:
    - I still can't see that (also after deleting the browser cache)
    - I also can't see it on my android device
    - and also not on my vmware image on my Win7 laptop

    PS: (1)
    At least I've found this:
    (so the two versions are available at the server)
    http://images1.sw-cdn.net/3dviewer/sprite/828275_v1/4x5-482x 357-4.jpg
    http://images1.sw-cdn.net/3dviewer/sprite/828275_v2/4x5-482x 357-4.jpg

    PS: (2)
    Indeed there are all versions available v1... v6.
    The viewer is started with:
    <iframe id="HTMLViewer" src="http://images1.sw-cdn.net/3dviewer?model=828275" .

    and results in some Java script containing the v1 as internal parameter.

    Indeed all versions were update in a time frame of 24 hours. It seems to me that the viewer can't handle several versions of a file in 24 hours correctly.
    Still not clear why Stoneysmith gets another result. (different time zones leading to different results?)
    Last edited: Dec 17, 2012
  10. woody64
    woody64 Well-Known Member
    @Nathalie: By the way, why not simple allow a http reference for pictures then these prerendered pictures used for the 3d viewer could easy be referenced and used as additional pictures.

    There was often the question to have the main image rendered from a different angle. That's already half of the solution ...
  11. mkroeker
    mkroeker Well-Known Member
    Same as I see (and saw when I confirmed stonysmith's observation on sunday), so timezones are probably
    not an issue. Could it be that all your devices go through the same caching proxy server ?
  12. woody64
    woody64 Well-Known Member
    No caching proxy on my side but maybe on the internet provider's sid.
    To overcome that I have reconnected my tablet to my handy thus going a complete other way into the internet and get still the same result.

    Last edited: Dec 18, 2012
  13. mkroeker
    mkroeker Well-Known Member
    Very strange. Accessing the site through your mobile phone should indeed ensure a different pathway to the internet.
    One last idea - does it matter if you are logged in to shapeways or not ? (Not that i would expect any user-specific caching
    on the server side)
  14. woody64
    woody64 Well-Known Member
    No, but let's see what the change on Thursday will bring.
  15. bartv
    bartv New Member
    Hi woody64,

    could you please test this? We released the fix for this issue.


  16. woody64
    woody64 Well-Known Member
    Yes clearly fixed. The items are now rotating with the correct version and also the fix is visible in the source code.

  17. bartv
    bartv New Member
    Great, thanks!