3D embedded viewer not working anymore?

Discussion in 'Bug Reporting' started by robs_mw, Mar 16, 2013.

  1. robs_mw
    robs_mw Well-Known Member
    Hi,

    The 3D embedded viewer doesn't seem to work on my own webpages anymore.
    Is this a common problem?

    Also on the http://www.shapeways.com/labs page I don't get a preview if I fill in my product url (www.shapeways.com/model/365957).
    The product is public and for sale.

    Any ideas?

    BR,
    Robert
     
  2. Bathsheba
    Bathsheba Well-Known Member
    I also see this broken. I'm going to report it to service@ -- I'd like it to work, but if it's not going to work I need to know that.
     
  3. Bathsheba
    Bathsheba Well-Known Member
    Is there an ETA on a fix for this?

    I kinda need it. Or if it's not going to work in the foreseeable, I need to know that...I can deal with either case but can you let me know?

    Thanks...
     
    Last edited: Mar 27, 2013
  4. stonysmith
    stonysmith Well-Known Member Moderator
    Need more specifics: What exactly is not working?
    Which browser are you using, what Shapeways URL did you link to from your webpage, etc.?
    Where on your webpage is the image that's not working?
     
  5. Bathsheba
    Bathsheba Well-Known Member
    The "3D Viewer Embed" on the Labs page (http://www.shapeways.com/labs) is not working. No image or animation appears.

    I have Windows 7. I see it failing on Firefox, MSIE, and Chrome.

    It doesn't work for any model I can find. A specific public/for-sale model that it doesn't work for is
    http://www.shapeways.com/model/832022/my-favorite-hair-claw. html

    The preview in the Labs page itself isn't working. I haven't included this feature on any webpage because it doesn't work.

    I'm pretty sure this isn't that difficult to reproduce. :-}

    Thanks for checking in, I'd love to see it working!
     
    Last edited: Mar 27, 2013
  6. stonysmith
    stonysmith Well-Known Member Moderator
    The Labs page needs to be updated. I've passed on that fact to the developers.
    Until that gets updated... you can use this if you replace NNNNNN with your model #
    Code:
    <iframe src="http://images1.sw-cdn.net/3dviewer?v=1&model=NNNNNN" width="482" height="357" frameborder="0"></iframe>
    ===
    Last year as part of the site enhancements, the images were moved to a cloud server for better performance. All that changed was the base URL where the images reside... it's now
    Code:
    images1.sw-cdn.net
    At some point in the future (years??) that may change again and you'd need to update the link again.
     
    Last edited: Mar 27, 2013
  7. Bathsheba
    Bathsheba Well-Known Member
    Thanks, I see it working with that change.
     
    Last edited: Mar 27, 2013
  8. lensman
    lensman Well-Known Member
    Yes, I see this is working now, however, this viewer is only for models that are both viewable AND for sale. I would like this work for models that are ONLY for sale and NOT viewable to the publc. I make a lot of custom stuff that my clients might not want the public to see and I don't necessarily want to share either, and yet I want to be able to show the 3D Viewer image to my client WITHOUT him/her going to the shop page.

    SHAPEWAYS: Any chance of making this change?