Now Through Sunday Night. Black Friday Deals & Free Shipping! See the deals.
Search Search  
Today's Messages (OFF)  | Unanswered Messages (ON)

Forum: 3D Applications
 Topic: photos to 3d, point cloud
photos to 3d, point cloud [message #103133] Tue, 18 November 2014 14:03 UTC
avatar Keymaker  is currently offline Keymaker
Messages: 173
Registered: February 2013
Go to my shop
Senior Member
Shapeways Crew
Hi there,

I would like to know your experience with creating point clouds and printable models from it. So far i tried several softwares (like 123d catch), but nothing is working for me and i have no idea what am i doing wrong.

What software do you use?


The only thing that limits us is our imagination.
 Topic: Maze Bolt (Image to cylindrical design?)
Maze Bolt (Image to cylindrical design?) [message #98552] Sat, 13 September 2014 19:59 UTC
avatar Blastpod  is currently offline Blastpod
Messages: 3
Registered: July 2014
Go to all my models
Junior Member
Hi, Blastpod here. I'm looking for some help on a very important issue. I need to find an app that can create a cylindrical 3D model using a grayscale image, and most importantly one that will allow editing of said model.

This is because I am working on making a Maze Bolt. For those of you who don't know, a maze bolt is a cylindrical key inserted into a negative to unlock something. I have my maze designed and ready, but it's in a 2D format. I need to design a 3D maze to operate the bolt lock on a custom machine.

See the problem?

Help is appreciated. I will provide any knowledge I can that will help the cause, but will not disclose the maze image itself as this could be replicated and make the machine be less of a family secret.
 Topic: Wall thickness not recognized by Shapeways. (3d Max)
Wall thickness not recognized by Shapeways. (3d Max) [message #91686] Tue, 10 June 2014 12:32 UTC
avatar MasterSport  is currently offline MasterSport
Messages: 1
Registered: April 2014
Go to all my models
Junior Member
I created a model in 3d Max. In order to keep prices down I made it hollow by creating 1,5 mm thick walls, using shell modificator.
But shapeways system keeps thinking it's solid and gives me the same volume for the solid and hollow models.
Anybody could help identify the problem?

[Updated on: Tue, 10 June 2014 12:40 UTC]

 Topic: Booleans Made Easy
Booleans Made Easy [message #90506] Tue, 27 May 2014 14:36 UTC
avatar LaurieMBerenhaus  is currently offline LaurieMBerenhaus
Messages: 17
Registered: September 2013
Go to all my models
Junior Member
I work here
I just wanted to share this new tool that I'm really excited about! It makes editing boolean operations easy and creates a clean mesh for printing.

http://www.3dprinterworld.com/article/foundry-announces-mesh fusion-plugin-for-modo-3d-modeling-software

A teacher of mine was one of the beta testers for this and shares his work on it here:
http://pushingpoints.com/v2/mesh-fusion-for-modo/


Content Consultant @Shapeways www.Laurie3d.com
 Topic: Archicad
Archicad [message #83671] Thu, 23 January 2014 00:46 UTC
avatar Cullen  is currently offline Cullen
Messages: 1
Registered: August 2013
Go to all my models
Junior Member
Has anyone had success using models created in Archicad?
 Topic: Maya 2014 > OpenCOLLADA Export
Maya 2014 > OpenCOLLADA Export [message #83410] Sat, 18 January 2014 14:17 UTC
avatar andy625  is currently offline andy625
Messages: 3
Registered: January 2014
Go to my shop
Junior Member
Hi, can anyone give (or a link) to a definitive way to do this? this is killing me.

I just want to install the plugin so i can export as a DAE file,

im presuming this is the best way using this
https://github.com/KhronosGroup/OpenCOLLADA

i've tried the cmake way hasn't worked, and i've tried using maya's plugin manager and its not recognising the bundle.
i've had a search and can't really find a solid answer for this.
any help very much appreciated, this really shouldn't be so painful, thanks in advance.

EDIT: for Mac

EDIT2: Right from everything i can gather the 2013 collada release isn't compatible with 2014 Maya,and i can't find a way round, if anyone can shed more light on this it would be very appreciated.

[Updated on: Sat, 18 January 2014 14:56 UTC]

 Topic: Cubify Design 2014 - STL
Cubify Design 2014 - STL [message #82295] Tue, 31 December 2013 03:08 UTC
avatar lgrfbs  is currently offline lgrfbs
Messages: 35
Registered: February 2011
Go to my shop
Member
Hi
what is the best best setup for STL in Cubify Design 2014 ?
Cubify Design 2014 was Alibre Design in the begin of 2013.


Member of JemtRallarna
 Topic: is there a good program that i could use to make robots or minifigurs
is there a good program that i could use to make robots or minifigurs [message #82228] Mon, 30 December 2013 04:34 UTC
avatar Darkai175  is currently offline Darkai175
Messages: 1
Registered: December 2013
Go to all my models
Junior Member
No Message Body
 Topic: Does anyone use Hexagon 2.5 by Daz Studio
Does anyone use Hexagon 2.5 by Daz Studio [message #81819] Fri, 20 December 2013 21:16 UTC
avatar BlackJack  is currently offline BlackJack
Messages: 1
Registered: September 2012
Go to all my models
Junior Member
Hi

I have hexagon 2.5 does anyone use this for creating 3D models to 3D print, is it reliable when it comes to printing your model 3D.

Kind Regards
Ammo Box Games

 Topic: Convert 3D PDF to IGES or OBJ
Convert 3D PDF to IGES or OBJ [message #80677] Fri, 06 December 2013 13:40 UTC
avatar Dotsan  is currently offline Dotsan
Messages: 376
Registered: August 2008
Go to my shop
Senior Member
Hi, I have a file in 3D PDF format. Is there anyone on the forum who can convert this to IGES or OBJ to be read in Rhino 3D?
Thanks for looking.
Regards
Vijay


www.dotsan.com
 Topic: Shipping abroad
Shipping abroad [message #80502] Wed, 04 December 2013 14:27 UTC
avatar Kandam90  is currently offline Kandam90
Messages: 2
Registered: November 2013
Go to all my models
Junior Member
Today we noticed this phrase in the explanation about shapeways shipping system:

We're working to make it easier for you to send gifts to friends and family across the world. Currently, to guard against online fraud, we require that the country of your Ship To address matches the country of your Bill To address.

Does it work also for applications or it's just for "normal customers"

Thanks for your help

Dario
 Topic: 3D printing for Architects using 3DS Max 2013 and ZBrush 4R6
3D printing for Architects using 3DS Max 2013 and ZBrush 4R6 [message #78547] Sat, 09 November 2013 01:30 UTC
avatar JGarrett  is currently offline JGarrett
Messages: 26
Registered: January 2013
Go to my shop
Junior Member
I'm looking for feedback on a blog I wrote today. Part One of the article is near completion and I believe some Shapeways users could benefit and share ideas with me. Cheers,


 Topic: Maya - custom scripts - more maya users?
Maya - custom scripts - more maya users? [message #75469] Wed, 25 September 2013 15:14 UTC
avatar vileraisin  is currently offline vileraisin
Messages: 14
Registered: September 2013
Go to my shop
Junior Member
Hello,

I'm not sure how many Maya users are out there, but if there are any I figured it might be useful to exchange any custom scripts etc. people use specifically for 3D printing / Shapeways. Perhaps this could turn out into a nice collection thread.

Anyone have any custom scripts or workflow that is invaluable to the process?

I don't have much myself, but I'll start, perhaps this will be to use to someone.

I have a command on my shelf that finds all open border edges on a mesh, using selection constraint:
(select a mesh and then run this command)
polySelectConstraint -mode 3 -type 0x8000 -where 1;
resetPolySelectConstraint;


Also found another script to measure the distance between 2 nodes/vertices:
(select two nodes / vertices and run getDistance()Wink
// from: http://www.montu.biz/2010/03/measure-distance.html
// select 2 nodes / vertices, run getDistance()

global proc getDistance(){
    string $currentsel[] = `ls -sl -fl`;
    if ($currentsel[0] == "") error "You must select two nodes or vertex to measure the distance";
    else {
        int $numofvertex = size($currentsel);
        if($numofvertex > 2) error "More than 2 nodes selected. Make selection again with only two nodes to measure distance between them";
        else {
            if(`objectType -isType "mesh" $currentsel[0]` || `objectType -isType "nurbsCurve" $currentsel[0]`) {
    
                vector $va = `pointPosition $currentsel[0]`;
                vector $vb = `pointPosition $currentsel[1]`;
                vector $distpos = $va - $vb;
                float $d = `mag <<$distpos.x, $distpos.y, $distpos.z>>`;
                string $unit= `currentUnit -query -linear`;
                print ($d + " " + $unit + "\r");
    
            }
            else if (`objectType -isType "transform" $currentsel[0]`) {
    
                vector $va = `xform -q -ws -a -rp $currentsel[0]`;
                vector $vb = `xform -q -ws -a -rp $currentsel[1]`;
                vector $distpos = $va - $vb;
                float $d = `mag <<$distpos.x, $distpos.y, $distpos.z>>`;
                string $unit= `currentUnit -query -linear`;
                print ($d + " " + $unit + "\r");
    
            }
    
        }
    }
};


Measure the volume of a mesh:
computePolysetVolume;


Also because I like to make full use of the grid, I have 1 command that centers the pivot to absolute 0,0,0 (center of the scene), and another to move the mesh to absolute 0,0,0

Move pivot to center of the scene:
xform -a -ws -piv 0 0 0;


Move mesh to center of the scene:
proc moveToZero(int $option)
{
string $selObj[] = `ls -sl`;
for($obj in $selObj)
{
    float $startingCoord[] = `xform -q -ws -rp $obj`;
    float $xOffset = $startingCoord[0] * -1;
    float $yOffset = $startingCoord[1] * -1;
    float $zOffset = $startingCoord[2] * -1;

move -rpr -x ($startingCoord[0] + $xOffset) -y ($startingCoord[1] + $yOffset) -z ($startingCoord[2] + $zOffset) $obj;
    
    if($option == 1)
    {
        makeIdentity -apply 1 -t 1 $obj;
        move -rpr $startingCoord[0] $startingCoord[1] $startingCoord[2] $obj;
    }
}

}

moveToZero(0);



Anyone else?
 Topic: Creating textured x3d/wrl for sandstone printing
Creating textured x3d/wrl for sandstone printing [message #70707] Sat, 29 June 2013 06:22 UTC
avatar flyingcat  is currently offline flyingcat
Messages: 7
Registered: July 2011
Go to my shop
Junior Member
Hello everyone,

I model with alibre (now geomagic) and like it. Now, for the first time, I want to create a colored object for full-color sandstone printing - an architectural model of a house.

Alibre does not support exporting to x3d or wrl, so I tried zbrush and a few other applications. However, they all seem more tailored towards artistic texture painting rather than scientifically accurate coloring. I'd like to be able to assign a color to each triangle/quad in my mesh, whereas these applications allow me to assign a color to vertices, meaning adjacent triangles share a color around a common point, which is not what I want (because, for example, a wall and a floor have different colors but share a corner).

Any recommendation how best to achieve this or which software to use would be greatly appreciated. Software license costs are, within reason, not a problem.

Thank y'all!

Christian
 Topic: Ring design, tricks to attaching mesh objects? (3ds max)
Ring design, tricks to attaching mesh objects? (3ds max) [message #70626] Thu, 27 June 2013 22:18 UTC
avatar meshfx  is currently offline meshfx
Messages: 9
Registered: June 2013
Go to my shop
Junior Member
Hey all,

I was trying to find this info on the site but it seems all the image links are busted. I am looking at doing some ring and pendant designs but not sure about attaching the ring body (the over the finger part) to the object that is going to be the focus point of the ring.

Basically I have a few ring templates I have created for the various finger sizes and then when I design the object for the ring I am going to attach them. I was just wondering from others experience in using 3ds Max for Shapeways if you have had dramas printing when combing poly objects.

From what I understand, my workflow would be to have the 'ring' and the design piece as editable polys, attach them and then weld some verts from the ring to the base of the object so my mesh is all one piece with no overlapping polys?

I was looking for some ring design tips but couldnt see a tutorial or guide specific to this.

Can anyone help me with some tips or experiences when it comes to attaching different objects together to prepare for printing.

Thanks.

S.
 Topic: Any 3ds Max users out there want to help a guy out?
Any 3ds Max users out there want to help a guy out? [message #66809] Wed, 24 April 2013 15:08 UTC
avatar paulelderdesign  is currently offline paulelderdesign
Messages: 56
Registered: August 2012
Go to my shop
Member
Hi guys

I have a file in max that I want to bake but I keep getting unknown exception errors in the script. The one time I got the file baked when
it was uploaded to SW it came was missing geometry and texture. Sad

It's a phone cover and very small file but I need to get it up soon and I'm pulling my hair out to where I went wrong. I would like the texture baked into
the model and exported as a VMRL file.

If anyone can help then I'll send yo the MAx file with textures.

Thanks in advance

Paul

[Updated on: Wed, 24 April 2013 15:09 UTC]

 Topic: Can anyone help me with a 3DS Max model?
Can anyone help me with a 3DS Max model? [message #65996] Thu, 11 April 2013 15:20 UTC
avatar paulelderdesign  is currently offline paulelderdesign
Messages: 56
Registered: August 2012
Go to my shop
Member
Hi guys I have a bit of a problem exporting to vrml. My Max file is all set up and the texture mapped. Can anyone help or possibly do it
for me? It's a simple iphone cover with a mapped texture (see image)

Would be great if someone can help as so far I have only uploaded my models in STL and OBJ so this is new to me Shocked

Paul

 Topic: PROBLEM IN EXPORTING TEXTURES FROM C4D
PROBLEM IN EXPORTING TEXTURES FROM C4D [message #63993] Wed, 13 March 2013 14:08 UTC
avatar ormaybenot  is currently offline ormaybenot
Messages: 1
Registered: March 2013
Go to all my models
Junior Member
Hi! I need to create a parallelepipedon (40x40x3mm) with smooth edges with a small hole and apply two different textures on the two opposite sides, then send it to Shapeways for 3D printing in fullcolor sandstone.
I'm doing it this way:
- I create the solid with VectorWorks (by subtracting an extruded cilinder from an extruded parallelepidedon with smooth edges); I also tried to extrude the square with the hole in it, but I got a worse result in the dxf export
- I export the model in dxf format and open it with C4D release 10
- I select the polygons that form the side I want to apply the texture to, and I apply the texture to the saved selection keeping the solid as one object
- I do the same with the second side and apply the second texture
- I export to vrlm 2 format, but the file I get doesn't reference the textures (my version of C4D doesn't offer any setting for exporting in vrlm 2)

NB: in one previous attempt I applied one texture only to the entire object wich was in that case a parallelepipedon with no rounded corners and no hole in it and - with the same exact procedure - it worked and the vrlm 2 file had the texture referenced.
I checked the vrlm file with a text editor and saw that it didn't reference at all the texture files, so It's not a matter of embedding the texture into the zip file.
Even re-opening the vrlm file in C4D shows a no texture solid.

Can anybody help me please?

Thank you very much,
Ormaybenot.
 Topic: Texture problems, EDIT: Solved it I think.
Texture problems, EDIT: Solved it I think. [message #59652] Sat, 05 January 2013 06:22 UTC
avatar Scout  is currently offline Scout
Messages: 1
Registered: January 2013
Go to all my models
Junior Member
Hi, so, I'm new to 3D printing, and I'm also pretty new to 3D modelling. I've been using Blender, and I converted an .obj file to .x3d, then tried uploading it, but got a message saying "It seems your product is missing the textures it needs to be 3D printed. Please check the uploaded file to make sure the texture is in the root directory (we don't support textures in subfolders). ", anndd I have no idea what I'm doing wrong.

I tried uploading the .x3d file on it's own, that didn't work, I tried putting it in a zip file with the texture(a png file), that didn't work, I don't really know what I'm meant to do, sorry if this is an incredibly n00by question but I'd really appreciate it if someone could tell me what I'm doing wrong.


Nevermind, I'm still not sure what I did wrong, but I tried another model and it worked fine, I guess there was just something wrong with my last model. Now to find out why a 2 inch figure is going to cost $50. I suck at this.

[Updated on: Sat, 05 January 2013 08:37 UTC]

 Topic: Rhino Users - Naked Edges
Rhino Users - Naked Edges [message #59518] Wed, 02 January 2013 21:24 UTC
avatar MODbot  is currently offline MODbot
Messages: 37
Registered: July 2011
Go to my shop
Member
I often have problems with naked edges in my rhino models. I am never quite sure how I got there and it is often hard to repair. I run the check - for naked edges and when the pink areas come up. I try join edge but it appears as though there is only one naked edge and nothing to join it too. I also try to repair it by meshing the model and then doing doing match mesh edges or fill mesh holes but again this has not worked. It is also hard for me to often understand how I got the naked edges because generally the naked edges appear on an area that was built similiarily to another but they only show up in one place. I am wondering if any Rhino users out there could take a look at my model and give me some feedback on what is going on with the pink/naked edges - (1) how they got there (2) how to fix them. If you respond here, I can send the model to you. Thank you for your help in advance!
 Topic: 3dsmax units setup
3dsmax units setup [message #53341] Thu, 30 August 2012 00:04 UTC
avatar Jchalfant  is currently offline Jchalfant
Messages: 3
Registered: January 2012
Go to my shop
Junior Member
Howdy,

I just recently noticed that it seems to be a pretty big deal if you keep your units setup as 1unit = 1inch... this will cause a lot of errors when uploading to shapeways.

The correct scale settings inside 3dsmax should be 1unit = 1mm. This is under Customize > units setp > system units in 3ds. Real important 1unit = 1mm... or there's a big chance your model will fail the automated checks.

I say "recently noticed" because I have already printed two models at 1unit = 1inch... both uploaded and printed fine... but now if I export and upload at that setting the obj or stl will fail nine times out of ten. I was pulling my hair out for a week or so trying to figure out the problem, seems obvious now.

Note to shapewyas: It might be wise to mention 3dsmax unit setup settings in the shapeways tutorials for 3ds users.... I didn't anything about that when looking ( http://www.shapeways.com/tutorials/3d_modeling_in_3d_studio_ max_for_shapeways)?

best
-John


www.jchalfant.com/web
 Topic: Trouble with balance point testing (Softimage)
Trouble with balance point testing (Softimage) [message #49113] Tue, 29 May 2012 20:13 UTC
avatar Jenncat  is currently offline Jenncat
Messages: 4
Registered: May 2012
Go to all my models
Junior Member
I am trying to hang up my pendant and test its balance point, but when I do it I hang it up and then do gravity simulation it falls through the thing I hang it on? how do I get it to work?


Nothing travels faster than the speed of light with the possible exception of bad news, which obeys its own special laws. -Douglas Adams
 Topic: Download ParaCloud iRing 3D for Ipad
icon9.gif  Download ParaCloud iRing 3D for Ipad [message #48225] Thu, 10 May 2012 22:50 UTC
avatar Chavenelle2  is currently offline Chavenelle2
Messages: 10
Registered: May 2012
Go to all my models
Junior Member
I have done the video tutorials and want to try this. But...
I can't find it in itunes store from the ipad or from the desktop searches..
Please help me find it. I have lots of tutorial videos but no app.
I'd love to try.
 Topic: Google SketchUp question
Google SketchUp question [message #45203] Sat, 10 March 2012 05:04 UTC
avatar nana  is currently offline nana
Messages: 1
Registered: March 2012
Go to all my models
Junior Member
I need to design intelligent military robotic tank , this tank can avoid obstacle
programs used :
1- Microsoft robotic developer studio .
2- Google SketchUp
3- Artificial Robotics
http://www.artificialrobotics.com/productInformation.php

i follow the steps at http://www.artificialrobotics.com/createAREnabledProjects.ph p to create my project

and i follow this video http://www.artificialrobotics.com/displayVideo.php?video=how ToCreateALaserRangeFinder
to make my tank move

problem i face :
1- i can't attach my tank to the differential drive as a mesh and make the tank move

2- when i make plugins --> "full export" in Google SketchUp to display the differential drive in my project appear message say " you can not export more than 64 entities with the express version of AR "

  • Attachment: tank.rar
    (Size: 1.24MB, Downloaded 95 time(s))

 Topic: Autodesk 123D Capture advice needed
Autodesk 123D Capture advice needed [message #42161] Wed, 18 January 2012 03:45 UTC
avatar yoni.binstock  is currently offline yoni.binstock
Messages: 23
Registered: November 2011
Go to my shop
Junior Member
Hi guys,

Has anyone used Autodesk 123D Capture to print stuff with shapeways? http://www.123dapp.com/catch

It looks pretty impressive to capture a physical image and bring it into 3d software. I'm just wondering if anyone has printed with it.

If so, love to hear your thoughts on it.


Yoni
 Topic: Model is different size in Inventor and Shapeways
Model is different size in Inventor and Shapeways [message #32900] Thu, 18 August 2011 16:17 UTC
avatar Mathavious  is currently offline Mathavious
Messages: 2
Registered: August 2011
Go to my shop
Junior Member
Hi, I'm new and just trying to upload a cube that should be an inch wide. In inventor it is 1 unit wide and when I upload it I select "inches" when prompted. But the result is 2.5 inches. The same problem happens when I modeled one 18mm wide (I selected "mm") but it became 46mm (which happens to be 1.8 inches). What am I doing wrong?
 Topic: Model is different size in Inventor and Shapeways
Model is different size in Inventor and Shapeways [message #32899] Thu, 18 August 2011 16:15 UTC
avatar Mathavious  is currently offline Mathavious
Messages: 2
Registered: August 2011
Go to my shop
Junior Member
Hi, I'm new and just trying to upload a cube that should be an inch wide. In inventor it is 1 unit wide and when I upload it I select "inches" when prompted. But the result is 2.5 inches. The same problem happens when I modeled one 18mm wide (I selected "mm") but it became 46mm (which happens to be 1.8 inches). What am I doing wrong?
 Topic: Units in Autodesk Maya
Units in Autodesk Maya [message #31392] Sat, 23 July 2011 16:06 UTC
avatar mtc777  is currently offline mtc777
Messages: 1
Registered: July 2011
Go to all my models
Junior Member
I am planning to do 3D model in Maya and I would like to know how do I set the units (grid)?

For example if I want to make a cube with 10 mm sides should I set units to millimeter and draw 10 unit cube?
 Topic: MeshLab: Render obj file with my own computed normals
icon4.gif  MeshLab: Render obj file with my own computed normals [message #29886] Wed, 29 June 2011 00:31 UTC
avatar ravi.dighade  is currently offline ravi.dighade
Messages: 1
Registered: June 2011
Go to all my models
Junior Member
I am trying to write a obj file with vertices. I am computing the vertex normals in my code and writing to this file as well. When I try to render this file in Meshlab it reads the vertices correctly, but when I go to 'Render->Show vertex normals', it is not showing the normals that I computed. Rather MeshLab computes its own normals and shows them.

I am not sure how I can visualize the normals that I computed/wrote to file. I want to apply Meshlab shader later based on my computed normals.

To test this I created a test obj file-

vn 0.517350 0.517350 0.517350
v 0.500000 0.500000 0.500000
vn -0.333333 0.666667 0.666667
v -0.500000 0.500000 0.500000
vn 0.666667 -0.333333 0.666667
v 0.500000 -0.500000 0.500000
vn -0.666667 -0.666667 0.333333
v -0.500000 -0.500000 0.500000
f 1//1 2//2 3//3
f 4//4 3//3 2//2

This is just one square. Now if I change the normal values in this file, it still shows its own vertex normals when I select 'Render->Show vertex normals'.
How can I have my own normals and apply shader that works on my computed normals?? Please help.

Thanks!!
 Topic: SolidWorks problem, lack of colour
icon4.gif  SolidWorks problem, lack of colour [message #27110] Sun, 08 May 2011 14:47 UTC
avatar MehMeh27  is currently offline MehMeh27
Messages: 1
Registered: May 2011
Go to all my models
Junior Member
I am having problems with saving as .stl or .wrl, in SolidWorks. It works, but it loses all colour. At first I had individual faces coloured, which took a long time, now I've got a seperate bodies for each colour, which saves a lot of time when trying to change it. Using either method though, it's not saving the colour to .stl or .wrl, and I don't know why. :\

Help!

Oh, it saves the colour of the overall part specifically, but not any applied to faces or individual bodies.


Edit:
Okay, I'm trying to use Blender now to colour the parts. I've attached the .blend file. When I try to export all the parts as .stl, .obj, or .x3d it doesn't save with colour.

Am I doing something wrong here? Or is it not supposed to save with colour? :\


Okay, I figured out how to add colour using textures with AccuTrans 3D, to .wrl format. Very happy I've done it, now I can start making more stuff. :) (well, I'll order this and see how it turns out...)

[Updated on: Tue, 10 May 2011 11:34 UTC]

 Topic: plz help me shell this!
plz help me shell this! [message #26822] Mon, 02 May 2011 03:30 UTC
avatar austinmitchell  is currently offline austinmitchell
Messages: 2
Registered: February 2011
Go to my shop
Junior Member
I have tried everything. I have these 8 puzzle pieces that currently cost 900 dollars Sad I used rhino to model them and i cant figure how to shell these polysurfaces! i moved it into solid works and only 3 of the 8 pieces are recognized as solids and can be shelled there. It would be great if someone could explain how to do this or just do it for me. I already tried Meshlab but i can figure that out.

  • Attachment: BALLFINAL.stl
    (Size: 3.50MB, Downloaded 150 time(s))

 Topic: Simple Wavefront obj to STL converter.
icon1.gif  Simple Wavefront obj to STL converter. [message #22576] Thu, 13 January 2011 17:52 UTC
avatar cyborg_ar  is currently offline cyborg_ar
Messages: 24
Registered: December 2009
Go to all my models
Junior Member
I have had some bad problems with blender's STL exporter so i wrote my own script. My solution is a bit kludgy, i didn't write a "real" exporter, because i really cant be assed to study the necessary python api in blender yet (besides it's always changing), but i wrote a standalone script that takes a Wavefront .obj file and outputs a binary STL, since the .obj exporter works WONDERFULLY, and both formats are dead simple to read and write the script was fairly short. That also means that it's useful for other software which can export .obj too.

As an extra i added a feature to let you specify the scale in the STL conversion. So for example you can model your stuff in centimeters and put a scaling factor of 10 to output a STL in Milimeters that Shapeways will accept. The script also automatically skips degenerated faces (points and segments) and triangulates the mesh using a pretty naïve triangle-fan triangulation, so don't use it if you have grossly deformed/non-planar quads or n-gons that are not completely convex.

Well enough babbling, here's the code (attached) As the header says, you're free to do whatever you want with it.

  • Attachment: obj2stl.py
    (Size: 2.05KB, Downloaded 219 time(s))

 Topic: exporting from FORM-Z
exporting from FORM-Z [message #19431] Wed, 20 October 2010 10:31 UTC
avatar ZiggyFolkmanis  is currently offline ZiggyFolkmanis
Messages: 1
Registered: October 2010
Go to my shop
Junior Member
Friends,

I have been trying every possible export fromat from Form-Z and I just can't get the model to look right in any supported format. Does anyone have experience with this? It appears to support a lot of features and I've tried numerous settings for STL and VRML and tried also every format that MeshLab supports and there are problems with all of them!

Perhaps someone has experience with this and can tell me the magical formula - though at this point I'd rather have someone else do the conversion for a fee or a commission from possible sales on this site.

Thank you

Ziggy
 Topic: Attack of the 50 ft. model
Attack of the 50 ft. model [message #19129] Thu, 14 October 2010 23:44 UTC
avatar dougj99  is currently offline dougj99
Messages: 7
Registered: October 2010
Go to my shop
Junior Member
Hello.

I was uploading my very first model, which I created in Maya. I had set the units to cm. and the measuring tool measured the height as approximately 13.4 units (cm). all good. I exported an .obj file, and opened it in Meshlab. Here, too the measure tool read 13.4- I assume- cm. I exported a Collada file and uploaded it to SW. The Email I got back said the model is 1090 cm (over 30 ft. tall!)

I have never used Meshlab before, so it's not clear what the units are set to- if it isn't cm. how do I change it? And if it is cm.- what do I do now?

Thanks for any help!

Cheers,
Doug


Doug Johnson
G61 Designs
doug@galaxy61.com
 Topic: adding depth
adding depth [message #19087] Thu, 14 October 2010 13:37 UTC
avatar npkeith  is currently offline npkeith
Messages: 2
Registered: October 2010
Go to all my models
Junior Member
Hi all.
Complete noob here. Just downloaded sketchup a few days ago, and I've been playing with it. I have a specific project in mind, and I assume sketchup can do it, I just don't know how.

I want to make a steel pendant about an inch square (25mm x 25mm x ~3mm) with a QR code on it, with the black parts being recessed about 1-1.5mm. I have the code, and I can extract either the white data or the black data, but then I can only paste it onto the 25 x 25 x 3mm object as a skin.

Is there any way in sketchup turn that 2d image 3d without having to hand-create each cube and join them together? If not, what about Blender?

Thanks in advance.
-Keith
 Topic: Autodesk Inventor and full collor sandstone
Autodesk Inventor and full collor sandstone [message #18912] Mon, 11 October 2010 09:14 UTC
avatar jdjong  is currently offline jdjong
Messages: 12
Registered: June 2010
Go to all my models
Junior Member
Did any one here ever try to print a full collor sandstone object from Autodesk Inventor?
I have a collored object in inventor but as far i can see Autodesk Inventor 2009 doesnt save files as VRML or X3D.

I only know how to work with inventor so it would be difficult and a lot of work if i need to open the object in a other program and then put colors on it (again)

[Updated on: Mon, 11 October 2010 09:19 UTC]

 Topic: Viewing upload virtual models
Viewing upload virtual models [message #18848] Fri, 08 October 2010 17:02 UTC
avatar npkeith  is currently offline npkeith
Messages: 2
Registered: October 2010
Go to all my models
Junior Member
What am I doing wrong here?

I want to design a ring with some lettering in it. I used the design your own .PDF template, drew it out, took a high res .jpg and uploaded it. I can see the image of the template on the order page. The three-d image, however, is still of the generic ring with a stylized flower in the middle. Is it possible to see a proof of the ring I designed? If so, how?
 Topic: meshlab question
meshlab question [message #17289] Sun, 05 September 2010 12:49 UTC
avatar Inlite  is currently offline Inlite
Messages: 116
Registered: June 2009
Go to my shop
Senior Member
Can you use meshlab to flip SELECTED normals? I have some inverted normals in my model (.x3d) and the filters will flip ALL the normals but I want it to invert the normals I have selected.Can it?
 Topic: Can't undo in netfabb ?
Can't undo in netfabb ? [message #14652] Mon, 12 July 2010 09:14 UTC
avatar Kevin K  is currently offline Kevin K
Messages: 1
Registered: July 2010
Go to my shop
Junior Member
I downloaded the basic version of netfabb,4.5.

The program look nice and clean, and i was verry happy with it untill i realised i can't undo my steps in the repair proces.
But i cant undo, let's say i'm in rapair mode, and delate a triangle.
If i then undo, it undos the rapair mode, and my part is gone.
Can't redo ither.

Runing the program under vista 32 bit.
 Topic: Win a free SketchUp eBook
Win a free SketchUp eBook [message #13777] Thu, 17 June 2010 22:51 UTC
avatar bitstoatoms  is currently offline bitstoatoms
Messages: 407
Registered: March 2009
Go to my shop
Senior Member
I work here
If you are interested in learning SketchUp we have a couple of eBooks to give away, full details on the Shapeways blog at http://www.shapeways.com/blog/archives/480-Book-Review-Sketc hUp-7.1-for-Architectural-Visualization.html

But basically If you are interested use twitter to tweet a link to one of your Shapeways models and include @shapeways.

Easy.

Cheers

Duann


Duann Scott

Pages (2): [1  2    »]

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.