Our Gift to You: 20% off your own designs in Strong & Flexible Plastic through Dec 23, with promo code MY2014 · details
Home » Support » 3D Design » Sorry for another frustrated Rhino4 --> STL question
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
Sorry for another frustrated Rhino4 --> STL question [message #3771] Mon, 06 April 2009 03:37 UTC Go to next message
avatar nluken  is currently offline nluken
Messages: 3
Registered: January 2009
Go to all my models
Junior Member
Hi Everyone,

(I can see from the topics on this forum that i'm not alone in my frustration!)

I have a relatively simple stl file (attached) that appears to meshlab and rhino to be a good mesh. At this point I'm kind of at a loss as to next steps. I would greatly appreciate any help from the experts on this board.

(As an aside, I know there are tons of resources (both online and in book form) specifically about this workflow (3d modelling in rhino for rapid prototyping). There is so much out there that it's a bit hard to wade through for a near beginner. It might be helpful if the shapeways folks put together some 'case studies' on the site about common problems with the most popular programs and workflows.)

Thanks again for any help you can provide!

Noah Luken
Chicago, IL

Re: Sorry for another frustrated Rhino4 --> STL question [message #3772 is a reply to message #3771 ] Mon, 06 April 2009 06:23 UTC Go to previous messageGo to next message
avatar garenc  is currently offline garenc
Messages: 30
Registered: January 2009
Go to my shop
Member
Hello,
Tell us how you construct it... The problem is in the way you took. I like this project because I manage with some projects in sound also. Sorry for my english, I'm French.
Philippe Garenc
Nancy, FR.


philippe garenc
Re: Sorry for another frustrated Rhino4 --> STL question [message #3775 is a reply to message #3771 ] Mon, 06 April 2009 08:29 UTC Go to previous messageGo to next message
avatar virtox  is currently offline virtox
Messages: 1171
Registered: August 2008
Go to my shop
Shapie Expert
moderator
What kind of error do you get ?
What should the printed object size be ?


- Artist / Engineer / Designer / Shopowner / Volunteer / Moderator -
Re: Sorry for another frustrated Rhino4 --> STL question [message #3789 is a reply to message #3775 ] Mon, 06 April 2009 14:32 UTC Go to previous messageGo to next message
avatar nluken  is currently offline nluken
Messages: 3
Registered: January 2009
Go to all my models
Junior Member
Hi All,

Sorry, I should have been clearer about the problem. The error message in this case is about my normals being flipped. Usually I have to deal with manifold issues so this is a change of pace for me.

I modeled the meshes in Rhino from a point cloud, and built the solid to be a single mesh. I used CheckMesh and RepairMesh to fix several small 'naked edge' problems, and Checkmesh gave me a clean bill of health from Rhino. UnifyNormals reported that all normals are pointing in the same direction, and the little arrows all seem to indicate that the normals are all facing out. Extensive visual inspection of the model (with colored backfaces, etc) do not reveal any issues.

Meshlab similarly reported no errors, no non manifold points or edges, and the normals all seemed to be okay as well.

As for the size of the object, I don't have the model in front of me, so I can't give an exact dimension. I intended to print the model on the shapeways machines, so I think it was 6" x 8" or so.

Thank you in advance for any assistance you can provide. It never ceases to amaze me that people all over the world can help out with these technical problems via the internet.

Thanks,
Noah Luken
Chicago, IL
Re: Sorry for another frustrated Rhino4 --> STL question [message #3795 is a reply to message #3789 ] Mon, 06 April 2009 15:52 UTC Go to previous messageGo to next message
avatar virtox  is currently offline virtox
Messages: 1171
Registered: August 2008
Go to my shop
Shapie Expert
moderator
Hi,

I checked the file, and a raw import into 3ds max, also did not find anything wrong with it.

After a weld with an exremely low threshold, 0.001 inch or something, there were 4026 of 4142 left.
For you to decied if it deformed your mesh Wink

Since there were no detected open edges, spikes, or double faces, I don't have an answer as to what happend.
Probably errors below the error checking threshold, but a good weld seems to fix it.

Attached is a shapeways accepted file.

Stijn

  • Attachment: 3d_music.stl
    (Size: 393.05KB, Downloaded 82 time(s))

[Updated on: Mon, 06 April 2009 15:54 UTC]


- Artist / Engineer / Designer / Shopowner / Volunteer / Moderator -
Re: Sorry for another frustrated Rhino4 --> STL question [message #3796 is a reply to message #3795 ] Mon, 06 April 2009 16:18 UTC Go to previous messageGo to next message
avatar nluken  is currently offline nluken
Messages: 3
Registered: January 2009
Go to all my models
Junior Member
Wow, thanks!

I think I follow what you did: After opening the file in 3d studio MAX, you set a weld tolerance of .001" (or similar) and then welded the mesh together. Whatever little errors that were part of the model got welded closed and the model had no issues after that.

What would be really helpful is to know is a rhino-equivalent command (or series of commands) that can accomplish the same thing. If there are any rhino experts who can help, that would be great. Otherwise, I'll play around and see if I can replicate your success.

Thanks again,

Noah Luken
Chicago, IL
Re: Sorry for another frustrated Rhino4 --> STL question [message #3801 is a reply to message #3796 ] Mon, 06 April 2009 18:33 UTC Go to previous message
avatar AO  is currently offline AO
Messages: 76
Registered: September 2008
Go to my shop
Member
Noah, Virtox,

The nonwelded mesh probably created overlapping triangles. I notice also that this happens if you try to use a very high resolution for the stl. It causes problems in small corners and sharp edges.
Therefore the file was not printable.

Greetings AO

 
   
Previous Topic:I need help to correct these two files
Next Topic:Another inverted normals issue

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.