Home »  » 3D Applications » RHINO USER
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
RHINO USER [message #42160] Wed, 18 January 2012 02:15 UTC Go to next message
avatar MODbot  is currently offline MODbot
Messages: 37
Registered: July 2011
Go to my shop
Member
Hi. I am curious if there are any others out there who use rhino for their 3D creations. I used the program throughout grad school and in various positions. I am not expert but I am adept. I am though running into some new issues with creating models for 3D printing - errors like too many shells or negative volumes. The whole issue of 2-manifold edges is new to me too. at any rate, I am wondering if there is anyone out there very experienced with rhino for 3D modeling who could help me trouble shoot a few things/help explain a few issues. I prefer to keep using this software as I am skilled with it and would like to build on that. Thank you!! Susan.
Re: RHINO USER [message #42170 is a reply to message #42160 ] Wed, 18 January 2012 04:55 UTC Go to previous messageGo to next message
avatar TurtlesAreCool  is currently offline TurtlesAreCool
Messages: 268
Registered: October 2010
Go to my shop
Senior Member
I haven't used Rhino. However, some of your issues might be solvable with Netfabb Basic. http://netfabb.com/basic.php

See if that helps with the resolution of manifold issues and negative volumes (they show up as red in the program).
Re: RHINO USER [message #42189 is a reply to message #42170 ] Wed, 18 January 2012 15:05 UTC Go to previous messageGo to next message
avatar MODbot  is currently offline MODbot
Messages: 37
Registered: July 2011
Go to my shop
Member
Thanks for your input. I use netfabb.

I haven't had issues with manifold problems. I have more issues with the negative volumes and netfabb only fixes them if the whole model is negative and then it inverts them all. If you only have one small area of negative volume there is nothing you can do. Do you have a solution for this? Do you know what it means -= to have a negative volume? I know what negative means and I know what volume means but the models certainly look like they have volume to me so I don't fully get the concept. I guess that is what gets me too. if it made more sense I could fix it more easily.

thanks.
Re: RHINO USER [message #42194 is a reply to message #42189 ] Wed, 18 January 2012 17:52 UTC Go to previous messageGo to next message
avatar TurtlesAreCool  is currently offline TurtlesAreCool
Messages: 268
Registered: October 2010
Go to my shop
Senior Member
The red parts have the normals flipped. In netfabb, you can use edit mode to correct them (the red plus button). There are several selection modes in edit mode - click the green cube button (this means that you'll be selecting a whole solid). Then left click on each red section, right click somewhere else on the model, and select "flip selected triangles". When you deselect those triangles, they should appear green.

To avoid the problem altogether, you would have to correct the normals in Rhino. I do not know how to do that, but I suspect that Rhino has a tool or command to do that. In Blender, I would select the faces in edit mode and press "Ctrl+N", which makes the normals "consistent". Generally, that results in outward-facing normals. Otherwise, I just flip all the normals manually.
Re: RHINO USER [message #42480 is a reply to message #42194 ] Sun, 22 January 2012 05:10 UTC Go to previous messageGo to next message
avatar MODbot  is currently offline MODbot
Messages: 37
Registered: July 2011
Go to my shop
Member
Thank you for your help. It appears as though I was successful with one of my models by flipping the triangles individually in netfabb. I was not aware you could do that. Thank you for your help.
There is a command in rhino to unify the mesh normals but it is problematic for other reasons. Thank you again so much for your help.
Re: RHINO USER [message #42481 is a reply to message #42480 ] Sun, 22 January 2012 05:12 UTC Go to previous messageGo to next message
avatar TurtlesAreCool  is currently offline TurtlesAreCool
Messages: 268
Registered: October 2010
Go to my shop
Senior Member
Glad to be of service. I look forward to seeing your creations.
Re: RHINO USER [message #42675 is a reply to message #42481 ] Tue, 24 January 2012 22:04 UTC Go to previous messageGo to next message
avatar MODbot  is currently offline MODbot
Messages: 37
Registered: July 2011
Go to my shop
Member
Thank you again for your help. I am wondering if you or anyone else out there has any suggestion. Now the same model is being rejected for having too many shells. I believe it has three rather than one. I see where this is indicated in Netfabb. But I don't know how to modify it. Does anyone have any advice?

Thank you,
Re: RHINO USER [message #42691 is a reply to message #42675 ] Wed, 25 January 2012 02:21 UTC Go to previous messageGo to next message
avatar TurtlesAreCool  is currently offline TurtlesAreCool
Messages: 268
Registered: October 2010
Go to my shop
Senior Member
In general, the Shapeways processing software (derived from a Netfabb product, I believe) is able to combine shells. I suspect that the issue with yours either relates to the normals still or the shells overlap in such a way that they cannot be combined. If you post a picture of the model, I or someone else might be able to give you specific guidance. You could also provide the STL to me in a PM and I can look at it. Finally, you could attach the STL to this post if you don't mind other people having the file.
Re: RHINO USER [message #44508 is a reply to message #42691 ] Sun, 26 February 2012 18:17 UTC Go to previous message
avatar billy57  is currently offline billy57
Messages: 20
Registered: August 2011
Go to my shop
Junior Member
Hi Susan -

This is the procedure I use. It is rather tedious, but it is simple and it works. It will give you an STL mesh with no naked edges or other horrors.

1. Join two parts together, using Boolean. (If for any reason the parts will not Boolean, this indicates a problem which you will need to fix before you proceed.)

2. Immediately create a test mesh from the resulting combination (Mesh/From NURBS object).

3. Run CheckMesh. Disregard the first line ("This is a good mesh" or "This is a bad mesh"), as a 'good' mesh from Rhino's point of view will not necessarily be 'good' for 3D printing. If there are any degenerate faces, naked edges or other issues listed, go back (ctrl-Z) and manipulate the parts until you get a result with zero problems. (The exception is 'Unused vertices' which seem to be harmless.)

4. Delete the mesh. (At this stage, it was only for testing.)

5. Save the altered Rhino model under a new version number, so that you can easily backtrack to an earlier stage if necessary.

6. Return to (1) and repeat until the whole model has been successfully joined.

7. Export the final mesh in STL format.

8. Run a final check on the STL mesh with NetFabb Studio Basic, as recommended above. (I do not recommend that you attempt to fix a faulty mesh with NetFabb, though – better to go back and fix the original model in Rhino.)

Good luck!


Billy

 
   
Previous Topic:Google Sketchup Resizing=Model Degradation Help!
Next Topic:Why are textures skewed after uploading?

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.