Home » Support » 3D Design » Missing Textures, and I Don't Know Where...
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
Missing Textures, and I Don't Know Where... [message #24492] Sun, 06 March 2011 03:42 UTC Go to next message
avatar Oracle of Wuffing  is currently offline Oracle of Wuffing
Messages: 46
Registered: March 2009
Go to my shop
Member
I wanted to get back into 3D Sculpting and Printing, and the last time I ran into a noggin' scratcher, asking around on the forum helped...

So, I have what I call a "Dice Token Thing," and I would like to get this printed in Full-Color Sandstone. I'm attaching the files as they were created by my program.

Thing is, trying to get this uploaded to Shapeways, I end up receiving an error e-mail saying that texture files are missing. I've tried, for example, renaming the BMP file from "Dice_Test2Tex0" to "Dice_Test2", as well as converting the BMP files to PNGs, but it doesn't seem that any permutation of this is passing through the texture check. I also sent an e-mail to service@shapeways, but I haven't heard back from them in a while. Does anyone have any suggestions on what I'm missing or what I did wrong?

  • Attachment: Archive.zip
    (Size: 14.48MB, Downloaded 59 time(s))

Re: Missing Textures, and I Don't Know Where... [message #24498 is a reply to message #24492 ] Sun, 06 March 2011 08:29 UTC Go to previous messageGo to next message
avatar stop4stuff  is currently offline stop4stuff
Messages: 2990
Registered: June 2010
Go to my shop
Senior Member
I downloaded your zip file, but WinRAR can't open it, both files are corrupt (Archive size 721kB rather than the 14.4mB)

Stepping past that hurdle for a moment...
According to the tutorial ( http://www.shapeways.com/tutorials/exporting_to_vrml_and_x3d _for_color_printing) only PNG & JPG image files are accepted. (Upload page includes GIF)... also note the maximum 2048x2048 pixel image size.

You can check the name of the expected image within the colour file using a text editor such as Word Pad, look for a line of text similar to
ImageTexture { url "IMAGE_FILENAME.jpg" }
where 'IMAGE_FILENAME' is the expected image for the texture map... the image filename should be just the name with extension, remove any drive/directory path... make sure the filenames are the same.

Hope this helps Smile
Re: Missing Textures, and I Don't Know Where... [message #24503 is a reply to message #24498 ] Sun, 06 March 2011 15:46 UTC Go to previous messageGo to next message
avatar Oracle of Wuffing  is currently offline Oracle of Wuffing
Messages: 46
Registered: March 2009
Go to my shop
Member
stop4stuff wrote on Sun, 06 March 2011 08:29

I downloaded your zip file, but WinRAR can't open it, both files are corrupt (Archive size 721kB rather than the 14.4mB)

Swell! Laughing

It downloads and extracts fine on my end, so it sounds like the corruption occurred on your end, and it probably cached the downloaded file on your computer.

stop4stuff wrote on Sun, 06 March 2011 08:29

can check the name of the expected image within the colour file using a text editor such as Word Pad, look for a line of text similar to
ImageTexture { url "IMAGE_FILENAME.jpg" }
where 'IMAGE_FILENAME' is the expected image for the texture map... the image filename should be just the name with extension, remove any drive/directory path... make sure the filenames are the same.

Hope this helps Smile

Awesome, yeah, this'll help. I'm kinda glad that BMPs aren't usable, I just didn't know how to tell it to look for a png instead. I've uploaded it now, and am waiting to see if I get any more error messages. Thank you!
Re: Missing Textures, and I Don't Know Where... [message #24504 is a reply to message #24503 ] Sun, 06 March 2011 16:13 UTC Go to previous messageGo to next message
avatar stop4stuff  is currently offline stop4stuff
Messages: 2990
Registered: June 2010
Go to my shop
Senior Member
I got it figured...

Your zip file contains an archive file - so a double unzip is needed (don't know if shapeways supports this).

Your wrl file is 104mB (fully unpacked), upload says max is 64mB... the texture file is a BMP (not supported)

The model contains 786,432 triangles, the maximum is 500,000 (after MeshMedic does its stuff) - looks like your model is made up of 393,216 four sided polygons.

Possible solution;
Reduce polygons to half the number, include an accepted texture image file and unpload a single zipped file containing the wrl and image only.



Smile
Re: Missing Textures, and I Don't Know Where... [message #24505 is a reply to message #24504 ] Sun, 06 March 2011 17:20 UTC Go to previous messageGo to next message
avatar Oracle of Wuffing  is currently offline Oracle of Wuffing
Messages: 46
Registered: March 2009
Go to my shop
Member
stop4stuff wrote on Sun, 06 March 2011 16:13

Your zip file contains an archive file - so a double unzip is needed (don't know if shapeways supports this).

Well, the tutorial on this shows MacOS using Archive Utility to zip things up, and I actually got an e-mail saying my scale was out of whack, so yes, they do support that.

stop4stuff wrote on Sun, 06 March 2011 16:13

The model contains 786,432 triangles, the maximum is 500,000 (after MeshMedic does its stuff) - looks like your model is made up of 393,216 four sided polygons.

Rats!

Thanks for the heads-up. I'll go back to the drawing board on this for a bit, as I was planning to make a hollow model after I knew the upload worked, but seeing as I'll just blow poly count out of the roof, I might as well re-make the mesh and see if I can get the Decimation Master to work well with UV Mapping...
Re: Missing Textures, and I Don't Know Where... [message #24508 is a reply to message #24505 ] Sun, 06 March 2011 18:20 UTC Go to previous messageGo to next message
avatar stop4stuff  is currently offline stop4stuff
Messages: 2990
Registered: June 2010
Go to my shop
Senior Member
TBH. unless your model is huge in size, you don't need such fine triangle resolution... 0.2mm triangles work well for smooth curves in both WSF and detail, flat faces can be one (or more) big triangle(s) faced out from cormers to the smooth curve edges to cut down on the overall count, and internal hollow spaces that aren't visable can be significantly reduced too.

Re: Missing Textures, and I Don't Know Where... [message #24523 is a reply to message #24508 ] Sun, 06 March 2011 23:47 UTC Go to previous messageGo to next message
avatar Oracle of Wuffing  is currently offline Oracle of Wuffing
Messages: 46
Registered: March 2009
Go to my shop
Member
Thanks for the vote of confidence.

I'm doing this in ZBrush, which (and here comes the understatement of the year) abstracts a lot of the intricacies of modeling, like detail-and wall-thickness. I do a lot of eyeballing things rather than actual measurement (a crime, I know)- the model that that file came from is actually scaled down from well over a million four-sided polygons. I'm pretty certain of what I need to do from here, it'll just come down to playing with the settings and fiddling with the dials.

[Updated on: Sun, 06 March 2011 23:49 UTC]

Re: Missing Textures, and I Don't Know Where... [message #24527 is a reply to message #24523 ] Mon, 07 March 2011 04:02 UTC Go to previous message
avatar Oracle of Wuffing  is currently offline Oracle of Wuffing
Messages: 46
Registered: March 2009
Go to my shop
Member
Oh gosh, I just got the "It's printable!" e-mail! I need to not work so late on 3D stuff, now I'll be up all night being excited.

It's just private for now, as I want to give these a bit of testing before I walk public with it. The hollowed out version is 3.67+1.50 US, just enough to make five work out pretty nicely, which was my target cost.

Edit: Aaaand drat. The red test die uploaded fine, but the texture is wrong on additional uploads. I don't get what could be causing it, as I just took the same texture file and did some hue and saturation editing.

Edit Again: Got it. Looks like ZBrush flipped the texture horizontally when I exported it for editing. Easy fix.

[Updated on: Mon, 07 March 2011 21:19 UTC]


 
   
Previous Topic:Two or more meshes
Next Topic:Rejected printing: How do I detect thin walls?