Now Through Sunday Night. Black Friday Deals & Free Shipping! See the deals.
Home » Support » 3D Design » Bevel/Chamfer Mesh in Blender
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
Bevel/Chamfer Mesh in Blender [message #19093] Thu, 14 October 2010 14:14 UTC Go to next message
avatar Aquillyne  is currently offline Aquillyne
Messages: 29
Registered: January 2009
Go to my shop
Junior Member
I have a complex mesh (a sculpture) with sharp edges all around that I want to chamfer/bevel i.e. smooth off.

I have the model in Blender but I'm open to any other free solutions!

My trouble with blender is when I apply the bevel modifier it bevels every single faces, or not enough of them, and I get a resulting model full of holes! I can't work out how to just bevel the sharp edges.

Any help much appreciated - this is for a present.

Thanks.
Re: Bevel/Chamfer Mesh in Blender [message #19109 is a reply to message #19093 ] Thu, 14 October 2010 16:50 UTC Go to previous messageGo to next message
avatar Charmed_Life_Designs  is currently offline Charmed_Life_Designs
Messages: 118
Registered: February 2010
Go to my shop
Senior Member
Go into edit mode and use the edge selector to choose your sharp edges. Hit the 'w' key, and Bevel should be in the menu that pops up. Alternately, you can get there through the GUI: Mesh » Edges » Bevel. Either one gets the same result.

Play around with it, see what comes up. Sometimes I get different results in certain models depending on if I bevel it a chunk at a time, or if I just select all my sharp areas and bevel them all at once.

Hope this helps!


When in doubt... Duct tape!
Re: Bevel/Chamfer Mesh in Blender [message #19113 is a reply to message #19109 ] Thu, 14 October 2010 17:46 UTC Go to previous messageGo to next message
avatar Aquillyne  is currently offline Aquillyne
Messages: 29
Registered: January 2009
Go to my shop
Junior Member
How do I select the edges?

I'm sorry I just can't work this out. I'm quite new to Blender.

I keep getting the result that each edge is bevelled as if it were isolated - I end up with gaps between all vertices.
Re: Bevel/Chamfer Mesh in Blender [message #19116 is a reply to message #19113 ] Thu, 14 October 2010 17:55 UTC Go to previous messageGo to next message
avatar Aquillyne  is currently offline Aquillyne
Messages: 29
Registered: January 2009
Go to my shop
Junior Member
Alternatively I end up with little dips at every vertex in the final bevel.
Re: Bevel/Chamfer Mesh in Blender [message #19117 is a reply to message #19116 ] Thu, 14 October 2010 18:10 UTC Go to previous messageGo to next message
avatar clsn  is currently offline clsn
Messages: 151
Registered: July 2010
Go to my shop
Senior Member
Not sure if it's in the default installation, but there's a script called "Bevel Center" under the Mesh menu in Edit mode, that bevels only the selected edges.

Googling found my this page: http://wiki.blender.org/index.php/Extensions:2.4/Py/Scripts/ Mesh/bevel_center

If you're on Blender 2.5, not sure what to suggest.
Re: Bevel/Chamfer Mesh in Blender [message #19119 is a reply to message #19093 ] Thu, 14 October 2010 18:16 UTC Go to previous messageGo to next message
avatar Ivan_  is currently offline Ivan_
Messages: 1
Registered: June 2010
Go to all my models
Junior Member
The problem might stem from the way your object was modeled. I've had problems with duplicate vertices (from canceled extrudes, and whatnot). To clean those up go into Edit Mode, select all vertices ('a' key), hit the 'w' key and select the 'Remove Doubles' option. Then try beveling again.

Don't know if this is the problem or not, but worth a try.
Re: Bevel/Chamfer Mesh in Blender [message #19120 is a reply to message #19119 ] Thu, 14 October 2010 18:42 UTC Go to previous messageGo to next message
avatar Aquillyne  is currently offline Aquillyne
Messages: 29
Registered: January 2009
Go to my shop
Junior Member
Thanks for all the help, but what I keep getting is that when I bevel, the model gets loads of 'dents' in it - at every vertex - and some 'cuts' as well along certain edges.

Even if I painstakingly select a whole edge, 1 edge at a time, and then use W -> Bevel, it forms a dent at each vertex along the way.

I have run the model through all manner of simplification, using Meshlab, netfabb, and removed doubles in Blender. These helped a lot to clean up the mess, but mess still remains.

I'm really at a loss. I just want to cut off the sharp edges!

Solution? - print with sharp edges, file them off. What do you think? Is this a viable solution? What material would I have to use? I am hoping to use Silver or Steel. Will that make post-production difficult?

Thanks everyone.
Re: Bevel/Chamfer Mesh in Blender [message #19122 is a reply to message #19120 ] Thu, 14 October 2010 21:03 UTC Go to previous messageGo to next message
avatar roofoo  is currently offline roofoo
Messages: 254
Registered: August 2008
Go to my shop
Senior Member
Try using a subsurf modifier and add edge loops close to the edges you want beveled. For sharper edges, keep the edge loops very close together.


http://www.eyephoriadesign.com http://www.shapeways.com/shops/eyephoriadesign http://www.etsy.com/shop/eyephoriadesign
Re: Bevel/Chamfer Mesh in Blender [message #19125 is a reply to message #19093 ] Thu, 14 October 2010 22:18 UTC Go to previous messageGo to next message
avatar clsn  is currently offline clsn
Messages: 151
Registered: July 2010
Go to my shop
Senior Member
Bevel always bevels the whole model. I don't know why. There isn't anything you can do about it, removing doubles and stuff won't help.

The "bevel center" script I linked to is the only thing I know offhand that will bevel only certain edges. Has that not worked for you?

roofoo's subsurf modifier idea is also worth trying.
Re: Bevel/Chamfer Mesh in Blender [message #19126 is a reply to message #19093 ] Thu, 14 October 2010 22:23 UTC Go to previous messageGo to next message
avatar clsn  is currently offline clsn
Messages: 151
Registered: July 2010
Go to my shop
Senior Member
Looks like you can also add a "Bevel" modifier, which can be set only to bevel edges of a certain sharpness, etc.

(I haven't experimented enough with modifiers in general, there may be other goodies there that could help you.)
Re: Bevel/Chamfer Mesh in Blender [message #19128 is a reply to message #19093 ] Thu, 14 October 2010 23:33 UTC Go to previous message
avatar GHP  is currently offline GHP
Messages: 118
Registered: October 2009
Go to my shop
Senior Member
You could also trying smoothing (the "Smooth" button in Mesh Tools in Edit mode, or HC Laplacian in MeshLab). This will work best if your model hasn't been simplified too much, so you may want to try subdividing first, or going back to a version of the model that hasn't been simplified.

Smoothing selected faces may cause a noticeable ridge to develop at the edges of the selected areas, so try applying it to your whole model. The effects should be most noticeable at the sharp edges.

[Updated on: Thu, 14 October 2010 23:36 UTC]


 
   
Previous Topic:Coffin Joe cartoon statue
Next Topic:Some problems with 3d viewing and downloading

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.