Home » Community » General Discussion » Can't edit Model details after uploaded...
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
Can't edit Model details after uploaded... [message #83309] Thu, 16 January 2014 18:57 UTC Go to next message
avatar UsefulIdiotDesign  is currently offline UsefulIdiotDesign
Messages: 18
Registered: November 2012
Go to my shop
Junior Member
I got the model in, it shows up on the site but it seems that the layout of the "edit detail" page has changed yet again.

I can't see my default materials pricing, or set it for that matter. The "Save Changes" button just kinda floats up and down the screen as I scroll. And after I hit it... nothing happens.

Do I have to update my Internet Explorer.. again? Do I have to stop using XP? Do I need to upgrade my flash player to the latest and greatest as well?

Sorry if I sound cranky but it just seems like everytime I get on here, something changes or moves.

[Updated on: Thu, 16 January 2014 19:00 UTC]

Re: Can't edit Model details after uploaded... [message #83315 is a reply to message #83309 ] Thu, 16 January 2014 19:15 UTC Go to previous messageGo to next message
avatar trey_mckay  is currently offline trey_mckay
Messages: 7
Registered: July 2013
Go to my shop
Junior Member
I work here
Hey UsefulIdiotDesign,

We're working on making improvements to this section of the site currently, so the changes in layout were made in an effort to provide you with a better experience in the future.

If you wouldn't mind, could you share what version of Internet Explorer you're viewing the page on?

For the issue with material prices, make sure the material is enabled for sale (checkbox on top of the material thumbnail) in order to see the pricing & markup sections for that material.

As for the save button, we're working to improve that experience. If you don't have any changes to save, that button won't inherently do anything. If you have made a change somewhere on the page, when you hit 'Save Changes', you should see the button turn green with a checkmark icon, and a notice at the top of the page that the changes have been saved successfully.

Apologies for the layout shifting around on you, but please bare with us as we try to make this experience the best we possibly can for you :)

-Trey ( p.s. - I work here :D )

[Updated on: Thu, 16 January 2014 19:16 UTC]


Interaction Designer | Shapeways
Re: Can't edit Model details after uploaded... [message #83324 is a reply to message #83315 ] Thu, 16 January 2014 20:15 UTC Go to previous messageGo to next message
avatar UsefulIdiotDesign  is currently offline UsefulIdiotDesign
Messages: 18
Registered: November 2012
Go to my shop
Junior Member
Version 8, so said the google link...

Pretty sure that's what I just upgraded to at home as well.

I do understand that I have to set the "display/sell" option before I can set pricing, but it didn't seem to matter or allow me to see what I needed.

Also clicked on the checkboxes in the material options and still nothing for the default material. I could set the pricing for the non-default material though, but when I hit "Save Changes"... nothing happens.

I understand about having a good experience, I've had many with Shapeways! But some of us old folks ;) like consistency too.

Thanks again, and I hope this gets resolved soon... wouldn't want to miss a customer!
Re: Can't edit Model details after uploaded... [message #83326 is a reply to message #83324 ] Thu, 16 January 2014 20:25 UTC Go to previous messageGo to next message
avatar trey_mckay  is currently offline trey_mckay
Messages: 7
Registered: July 2013
Go to my shop
Junior Member
I work here
Thanks for the response.

I want to get this resolved for you also. IE8 shouldn't be a problem, so I don't think that's the root of the issue.

Would you mind sending me a PM with the url to the model in question? I'll have a look at it and see if I can figure out what is going on. It could possibly just be a bug, and if so, I'll alert the proper person to help us get this issue resolved for you.

Thanks!

-Trey



Interaction Designer | Shapeways
Re: Can't edit Model details after uploaded... [message #83339 is a reply to message #83324 ] Thu, 16 January 2014 21:44 UTC Go to previous messageGo to next message
avatar UsefulIdiotDesign  is currently offline UsefulIdiotDesign
Messages: 18
Registered: November 2012
Go to my shop
Junior Member
Hey UsefulIdiotDesign,

So I took at a look at the model that you sent over. As far as I can tell, there isn't a default material set for the model. I'm not totally sure what caused this to happen. Have you tried setting a different default material, then trying to save changes? I wonder if something might have just gotten messed up in the model data.

The other option that I can see is to re-upload the model in question (I know this may be a hassle to you, but might resolve the issues you're seeing).
On that note, am I correct in assume that this is the only model you're having this issue for, or is it all of your models? From my end, everything is working normally, except that you don't have a default material selected in the model we've been discussing.

Let me know if you're seeing this issue on other models or not, and if you're up for it, possibly re-uploading said model to see if that resolves the issue.

- Trey
Re: Can't edit Model details after uploaded... [message #83354 is a reply to message #83339 ] Fri, 17 January 2014 07:42 UTC Go to previous messageGo to next message
avatar UsefulIdiotDesign  is currently offline UsefulIdiotDesign
Messages: 18
Registered: November 2012
Go to my shop
Junior Member
I will reload it right now... with fingers crossed.

It wouldn't let me see the pricing at all this time around (before I checked here), I could select default before but it still wouldn't save any changes.
Re: Can't edit Model details after uploaded... [message #83364 is a reply to message #83354 ] Fri, 17 January 2014 14:11 UTC Go to previous messageGo to next message
avatar UsefulIdiotDesign  is currently offline UsefulIdiotDesign
Messages: 18
Registered: November 2012
Go to my shop
Junior Member
Ok... was up at it last night for a while, still no go.

So, made a slight change to the model so I could be sure it was the most current version that I was uploading.

The newly created STL file uploaded with no issue.

Site still will not let me pick my usual default material (unpolished white)... I can select it with the little check box, but after I do, nothing comes up in the pricing area.

I can pick the polished white and strong and set it as a default material, I can also set my pricing on that once I do.

Then I click what I now consider to be the floating pink block of frustration (save changes) and get nothing.

Nothing saves, not the categories, not the material choice... nothing.

So, I go about trying to load in a completely different revision of a completely different model and go about trying to set that one up as well...

Same deal. It loads up, I get onto the edit page and it's the same exact thing... floating frustration block, non-visible price settings, etc...

Now I've tried this from 2 desktops and 1 modile device... all have shown the same exact issues.

I have never had a problem with the old edit page, and I miss it terribly.

[Updated on: Fri, 17 January 2014 14:18 UTC]

Re: Can't edit Model details after uploaded... [message #83365 is a reply to message #83364 ] Fri, 17 January 2014 14:22 UTC Go to previous messageGo to next message
avatar mkroeker  is currently offline mkroeker
Messages: 1772
Registered: June 2012
Go to all my models
Shapie Expert
Javascript support disabled for some reason, or IE gone into one of its "compatibility modes" ?
Re: Can't edit Model details after uploaded... [message #83370 is a reply to message #83309 ] Fri, 17 January 2014 14:54 UTC Go to previous messageGo to next message
avatar UsefulIdiotDesign  is currently offline UsefulIdiotDesign
Messages: 18
Registered: November 2012
Go to my shop
Junior Member
Ok, java is good to go... compatibility view is not the issue.

Just tried it from another machine here as well, so that makes 3 desktops, 1 mobile device... 3 different OSs and still the same exact thing everytime.

Just getting irritated now!

Not to mention the fact that everytime I try to even check this thread here I keep getting kicked off because it's not a secure site. Must've clicked this thread for the past 15 minutes trying to get in to respond again. Had the same deal at home too.

Tell ya what, if I don't respond to this thread or you get no signal from me on this site whatsoever from here on out... Send out a search party!!!


Re: Can't edit Model details after uploaded... [message #83371 is a reply to message #83370 ] Fri, 17 January 2014 15:05 UTC Go to previous messageGo to next message
avatar mkroeker  is currently offline mkroeker
Messages: 1772
Registered: June 2012
Go to all my models
Shapie Expert
UsefulIdiotDesign wrote on Fri, 17 January 2014 14:54


3 desktops, 1 mobile device... 3 different OSs and still the same exact thing everytime.

But all of them some version of Microsoft OS and IE ?

Quote:


Not to mention the fact that everytime I try to even check this thread here I keep getting kicked off because it's not a secure site.


IF this is related at all, it would seem to point at some firewall/antivirus setting. (Probably one of the seemingly ubiquitous tracking pixels/cookie monsters is still served via http although the shapeways site itself uses https)

Quote:


Tell ya what, if I don't respond to this thread or you get no signal from me on this site whatsoever from here on out... Send out a search party!!!


Not to raise any false hopes -- we might just print us a replacement, you know :-)
Re: Can't edit Model details after uploaded... [message #83375 is a reply to message #83309 ] Fri, 17 January 2014 15:19 UTC Go to previous messageGo to next message
avatar UsefulIdiotDesign  is currently offline UsefulIdiotDesign
Messages: 18
Registered: November 2012
Go to my shop
Junior Member
Three IEs, one Safari.

I doubt they can print my replacement right now, I didn't see any raw materials in the shop labeled "pure frustration".

:)
Re: Can't edit Model details after uploaded... [message #83376 is a reply to message #83375 ] Fri, 17 January 2014 15:30 UTC Go to previous messageGo to next message
avatar trey_mckay  is currently offline trey_mckay
Messages: 7
Registered: July 2013
Go to my shop
Junior Member
I work here
Hey UsefulIdiotDesign,

Really sorry to hear that you're still having these issues. I have reported the problem to our bugs team in hopes that they can figure out what is causing this issue. We are working to get this resolved for you as fast as we can. Personally, every time I visit the model you sent over, I have no problems saving changes, setting default materials, or editing the markup, so this is truly a confusing and frustrating issue (I tested in Chrome on a Mac, and IE9 on Windows 7).

Thanks for your patience on this, I know it has been very frustrating, but we're working to find a solution for you as quickly as we can.

Best,
Trey

p.s. - Is it only the one model that you're having this issue on? If so, then it sounds like something got messed up on the back-end. If you cannot save changes on any of your models, then it sounds like a different issue entirely. Clarifying this would be very helpful. Thanks!

[Updated on: Fri, 17 January 2014 15:35 UTC]


Interaction Designer | Shapeways
Re: Can't edit Model details after uploaded... [message #83380 is a reply to message #83376 ] Fri, 17 January 2014 15:41 UTC Go to previous messageGo to next message
avatar mkroeker  is currently offline mkroeker
Messages: 1772
Registered: June 2012
Go to all my models
Shapie Expert
javascript security problem similar to this thread ?
(If it blocks the entire js code on the page, no wonder that the Save button would fail to work. Do you get a message about js being blocked, perhaps with an option to allow it for that instance ?)
Re: Can't edit Model details after uploaded... [message #83383 is a reply to message #83309 ] Fri, 17 January 2014 16:03 UTC Go to previous messageGo to next message
avatar UsefulIdiotDesign  is currently offline UsefulIdiotDesign
Messages: 18
Registered: November 2012
Go to my shop
Junior Member
I can see all of my pricing options on all of my existing shop models, I could probably edit them too but I am scared to test it out of fear I may screw something up. (leaving well enough alone)

I had my F1 Motor Mount V1 on here and I have already received my prototype. Absolutely no issues with loading and setting that one up in my shop using the home computer. I'm pretty sure I loaded it early January.

I tested my prototype and made revisions to the model, tried to load the newly revised model and that's where this all started.

I've since deleted that first upload as per your advice and just loaded up a new one, still can't get it set up in my shop.

I've added a completely different model as well (Skullyx) to see if it was just the F1 Motor Mount, that model has the same issues, can't set anything or save anything.

SO...

Anything I try to upload now (after the edit page changed) will apparently have the same issues.

Can I just PM you the materials and prices I want for these two new files and then you can add them in?

[Updated on: Fri, 17 January 2014 16:05 UTC]

Re: Can't edit Model details after uploaded... [message #83389 is a reply to message #83383 ] Fri, 17 January 2014 16:27 UTC Go to previous messageGo to next message
avatar trey_mckay  is currently offline trey_mckay
Messages: 7
Registered: July 2013
Go to my shop
Junior Member
I work here
My hunch is in-line with mkroeker (thanks for your help by the way) - it sounds like this is an issue with javascript on the page, as I have no problems on my end doing any of the tasks you cannot complete at the moment.

Feel free to PM me info, but that is not a sustainable solution in the long-run. The issue has been reported to our dev team, so hopefully a true solution can be found quickly. Thanks for baring with us.

Trey


Interaction Designer | Shapeways
Re: Can't edit Model details after uploaded... [message #83601 is a reply to message #83389 ] Wed, 22 January 2014 06:12 UTC Go to previous messageGo to next message
avatar UsefulIdiotDesign  is currently offline UsefulIdiotDesign
Messages: 18
Registered: November 2012
Go to my shop
Junior Member
Ok, downloaded a new browser and... poof!

All of my previous issues went away!

Guess I just don't like to stay too cutting edge with my software, maybe a bit too paranoid.

Huge thanks to all who helped and a monstrously huge THANKS to Trey for getting my inventory in line while I was making these upgrades!
Re: Can't edit Model details after uploaded... [message #83650 is a reply to message #83601 ] Wed, 22 January 2014 21:11 UTC Go to previous message
avatar trey_mckay  is currently offline trey_mckay
Messages: 7
Registered: July 2013
Go to my shop
Junior Member
I work here
Glad you got it sorted out!

Firefox working OK for you thus far then? We actually did find a small bug that affects IE8 the other day, so don't blame yourself or hold yourself accountable in any way.


Don't hesitate to let us know if you experience any other issues in the future, glad to help.

Trey


Interaction Designer | Shapeways

 
   
Previous Topic:What kind of grease or lubricant is safe for use with WSF and BSF
Next Topic:What is the best plastic for use in an Aquarium? Can't float, or release toxic materials

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.