Home » Support » Buying » Polygon Count Wrong
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
Polygon Count Wrong [message #8009] Tue, 01 December 2009 16:46 UTC Go to next message
avatar Wehrdo  is currently offline Wehrdo
Messages: 3
Registered: November 2009
Go to all my models
Junior Member
Hi! I was really excited when I found this website, and I'm trying to print my first order. It is a dog head, with a polygon count of 450,000. Most of the polygons are quads, and if I export to STL, then it triangulates them. So I am exporting to X3D instead, because it retains the quads. The problem is, when I upload it, it says the polygon count is above the limit, when it's 450,000. Does the checker count quads as two polygons(triangles) or does it count a quad as one polygon?

The attached file is the .x3d that I am trying to upload.

Thanks for helping me solve this problem.

Re: Polygon Count Wrong [message #8010 is a reply to message #8009 ] Tue, 01 December 2009 16:51 UTC Go to previous messageGo to next message
avatar Youknowwho4eva  is currently offline Youknowwho4eva
Messages: 5571
Registered: September 2008
Go to my shop
Shapie Expert
I work here
I believe I've seen that people using .x3D have issues with anything over 50,000 polygons.


I learned a long time ago the wisest thing I can do is be on my own side, be an advocate for myself and others like me. -Maya Angelou
michael@shapeways.com Community Advocate
Re: Polygon Count Wrong [message #8014 is a reply to message #8010 ] Tue, 01 December 2009 19:30 UTC Go to previous messageGo to next message
avatar Wehrdo  is currently offline Wehrdo
Messages: 3
Registered: November 2009
Go to all my models
Junior Member
I've done some more researching, and it seems that Shapeways automatically converts everything to triangles before any checks. So It seems that I should get meshlab and try to reduce the amount of polygons.

I would like to keep this amount of detail, so if anybody can confirm or deny this before I reduce the number of polygons, that would be great.
Re: Polygon Count Wrong [message #8015 is a reply to message #8009 ] Tue, 01 December 2009 19:33 UTC Go to previous messageGo to next message
avatar iguffick  is currently offline iguffick
Messages: 74
Registered: April 2009
Go to all my models
Member
I loaded your X3D file into MeshLab, it shows 450,669 vertices and 901,342 faces !
I have done a 'Quadratic edge collapse decimation' to reduce the number of faces in your model and attached the file.
This reduces the count to 56,331 vertices and 112,666 faces.

You may want to look at the model yourself to make sure it is still what you want, but it looks fine to me. Far more detail than I think you'll get out of the 3D print.

I tried uploading and it worked fine, shows the bounding box as 5.9cm x 4.7cm x 5.0cm and priced at $27.95.

I've saved it as an STL file. When using Blender I have had problems with X3D files with more than 50K polys. I don't know if it's the Blender exporter, Shapeways importer or something I've done wrong, but STLs seem to work when X3Ds don't !

Regards, Ian.

Re: Polygon Count Wrong [message #8020 is a reply to message #8015 ] Tue, 01 December 2009 23:55 UTC Go to previous message
avatar Wehrdo  is currently offline Wehrdo
Messages: 3
Registered: November 2009
Go to all my models
Junior Member
iguffick wrote on Tue, 01 December 2009 19:33

I loaded your X3D file into MeshLab, it shows 450,669 vertices and 901,342 faces !
I have done a 'Quadratic edge collapse decimation' to reduce the number of faces in your model and attached the file.
This reduces the count to 56,331 vertices and 112,666 faces.

You may want to look at the model yourself to make sure it is still what you want, but it looks fine to me. Far more detail than I think you'll get out of the 3D print.

I tried uploading and it worked fine, shows the bounding box as 5.9cm x 4.7cm x 5.0cm and priced at $27.95.

I've saved it as an STL file. When using Blender I have had problems with X3D files with more than 50K polys. I don't know if it's the Blender exporter, Shapeways importer or something I've done wrong, but STLs seem to work when X3Ds don't !

Regards, Ian.

Thank you so much Ian! I was able to upload it, and it's now ready to print. I'm really grateful, because I was getting extremely frustrated with it. I should be able to do my next file myself now that I've learned from my mistakes with this one. Thanks again!

 
   
Previous Topic:Speedy shipping?
Next Topic:Dyed SLS pricing model

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.