Home » Support » 3D Printing » Short Edges
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
Short Edges [message #66167] Mon, 15 April 2013 20:40 UTC Go to next message
avatar CunninghamQuillAG  is currently offline CunninghamQuillAG
Messages: 4
Registered: January 2013
Go to all my models
Junior Member
I am trying to print a model I built in rhino, and I have uploaded it to the Shapeways and keep getting an error message without an actual description. I used the "meshrepair" function in Rhino and got this message, so i'm assuming this is the problem...but I don't know what it means... any ideas? Thanks!

This is a bad mesh.

Here is what is wrong with this mesh:
Mesh has 4 extremely short edges.

General information about this mesh:
Mesh does not have any degenerate faces.
Mesh does not have any non manifold edges.
Mesh does not have any naked edges.
Mesh does not have any duplicate faces.
Mesh does not have any faces with directions different from the mesh as a whole.
Mesh does not have any self intersecting faces.
Mesh does not have any disjoint pieces.
Mesh does not have any unused vertices.
Re: Short Edges [message #66170 is a reply to message #66167 ] Mon, 15 April 2013 21:06 UTC Go to previous messageGo to next message
avatar mkroeker  is currently offline mkroeker
Messages: 1700
Registered: June 2012
Go to all my models
Shapie Expert
Try viewing your stl or obj file with netfabb studio basic - the rhino message might be a red herring...
Re: Short Edges [message #66171 is a reply to message #66167 ] Mon, 15 April 2013 21:30 UTC Go to previous messageGo to next message
avatar CunninghamQuillAG  is currently offline CunninghamQuillAG
Messages: 4
Registered: January 2013
Go to all my models
Junior Member
I have fixed that issue, but something still seems to be wrong and shapeways is not accepting it. I have attached the STL file to see if anyone has some insight.

Re: Short Edges [message #66172 is a reply to message #66171 ] Mon, 15 April 2013 21:58 UTC Go to previous message
avatar mkroeker  is currently offline mkroeker
Messages: 1700
Registered: June 2012
Go to all my models
Shapie Expert
Have you tried netfabb yet ? I have no idea what your model should look like, but all I see is bits and pieces
(more like points on a hook-shaped 2D curve) distributed over a huge range of coordinates, far away from the origin.
I'd say your fix eliminated both the problem and the data...

 
   
Previous Topic:3D Preview Doesn't Match Picture Preview
Next Topic:US and CE Market standards

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.