Introducing 14k Gold, read more on the blog.
Home » Support » Bug Reporting » Image Preview Has Holes, Animated Preview is Perfect
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
Image Preview Has Holes, Animated Preview is Perfect [message #63747] Sun, 10 March 2013 13:12 UTC Go to next message
avatar dragonsdesire  is currently offline dragonsdesire
Messages: 31
Registered: March 2013
Go to my shop
Member
Hi there! I encountered another strange thing today. Upon uploading another vrml file (which I adjusted to make it face the "correct" way so that my model won't stand on its head), I noticed that the automatically generated image preview of my model has tiny holes.

Automatically Generated Image with Tiny Holes:
http://images.shapeways.com/model/picture/674x501_966592_864410_1362919495.jpg?key=e9caf964d367c69986939809edd3a881

When I checked the spinning animated preview, it has no holes there and it appears just the same as it looks like in my 3D modeling program (Zbrush). I made sure that my model's fine, no unwanted holes (it only has the powder exit holes) and other things that would get my model rejected.

Zbrush and Animated Preview Without Holes:
http://images.shapeways.com/model/picture/674x501_966592_864420_1362920325.jpg?key=e9caf964d367c69986939809edd3a881

I'm just wondering why the automatically generated image has tiny holes while the animated preview doesn't have holes.

Does anybody have an idea as to why the image preview and the animated spinning preview show different things? Thanks in advance Smile
Re: Image Preview Has Holes, Animated Preview is Perfect [message #63749 is a reply to message #63747 ] Sun, 10 March 2013 14:48 UTC Go to previous messageGo to next message
avatar stonysmith  is currently offline stonysmith
Messages: 1693
Registered: August 2008
Go to my shop
Senior Member
moderator
I am not sure that those are holes. They appear to be places where the geometry is overly complicated and/ or inverted on itself.
If you can, export the model to STL and view it in Netfabb Basic. It will help you verify whether those are actual holes or not.


Patience, Persistance, Politeness - the 3Ps will help us get us to Perfect Printed Products
Re: Image Preview Has Holes, Animated Preview is Perfect [message #63755 is a reply to message #63749 ] Sun, 10 March 2013 20:10 UTC Go to previous messageGo to next message
avatar dragonsdesire  is currently offline dragonsdesire
Messages: 31
Registered: March 2013
Go to my shop
Member
Oh ok I'll try netfabb since it looks to be free for basic. But let's say somebody printed the model the way it is now, would they get those holes or would they get a cleaner version (at least depending on the material) ?

By the way, from what I've read, Shapeways is using the "Z is up, model must face -Y" orientation. I followed that but any VRML files that I create end up with the dragon standing on its head in image and animated preview. I had to rotate the model by 90 degrees so that it would look "correct". The strange part is that any STL file I create doesn't have this problem with the "Z is up, model must face -Y" orientation.

I also use Zbrush 4R5 to make the models and I use the plug-in called 3D Print Exporter to create the STL and VRML files.

Thanks again Smile
Re: Image Preview Has Holes, Animated Preview is Perfect [message #63760 is a reply to message #63755 ] Sun, 10 March 2013 23:17 UTC Go to previous messageGo to next message
avatar dragonsdesire  is currently offline dragonsdesire
Messages: 31
Registered: March 2013
Go to my shop
Member
I tried netfabb earlier and it did read some holes. I followed a simple tutorial to fix it and uploaded the fixed version. The holes were still there. After that, I went back into Zbrush and thought that maybe if I increased the thickness of my shell (I hollowed the model) a little more, those little holes won't show up. It seems that I was right. When I uploaded another version of the model with a thicker shell, the auto-generated picture was flawless.

http://images.shapeways.com/model/picture/674x501_967583_865558_1362956423.jpg?key=b94dde46b8c21fc1dc1ff9145e0ffb4b

Unfortunately as a side effect, the cost of the model also doubled Sad

I guess I'll continue experimenting to find out what's the least thickness necessary to prevent those holes from showing up Smile
Re: Image Preview Has Holes, Animated Preview is Perfect [message #63766 is a reply to message #63760 ] Mon, 11 March 2013 00:09 UTC Go to previous message
avatar dragonsdesire  is currently offline dragonsdesire
Messages: 31
Registered: March 2013
Go to my shop
Member
Update:

I've been experimenting on the thickness from a higher one and back down to the original (the one that had holes). What I found out was that thickness wasn't the only factor in the holes appearing in the auto-generated picture. It also has something to do with my decimation (I use Decimation Master in Zbrush).

The cause of the problem was that I used the default 20% decimation suggestion. Of course this means lower poly count, but I guess it also made some parts of the model very thin and that's why when I increased the thickness in my first experiment, the holes disappeared. This time around, I tried 30% decimation along with the original thickness of 4. I was expecting to have holes in the model but was pleasantly surprised to find out that they've disappeared!

The solution seems to be a proper balancing of thickness and decimation, at least if you're using Zbrush like me. I hope my findings would also help someone who's having a similar problem Smile

 
   
Previous Topic:My Shop problems
Next Topic:Strange issue with part dimensions