Home » Support » 3D Applications » 3dsMax export manifold bug
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
3dsMax export manifold bug [message #4704] Sun, 31 May 2009 01:59 UTC Go to next message
avatar lorddarthvik  is currently offline lorddarthvik
Messages: 39
Registered: November 2008
Go to my shop
Member
Hi fellas

While exporting one of my models from Max5 into STL format, I came upon the following little but realy annoying bug.

I´ve exported the model to STL and checked it in Accutrans for water-tightness and manifold errors. Accutrans warned me that I had edges with 3 or more faces connected to them, which means shapeways will reject my file, as it is a manifold error.

After spending 3 hours systematicly checking all the objects in my model one by one, I localized the cause of the error.
I had made a grill looking thingy in my model, which consists of many simple boxes placed side by side, each placed geometrically exactly beside the other one, with no overlap. When exporting only one column, Accutrans showed no errors, but when exporting the whole grill or multiple connecting rows and columns, it showed a manifold error. This was caused by the exporter somehow welding these perfectly positioned boxes to each other, causing the manifold error. It is not visible in Accutrans, and I was stupid enough not to check the exportetd file in Max, so as this was about the only thing perfectly built in my model I checked this as the last part.

I could solve this problem by modifying all the boxes and placing new ones overlapping each other, this way there was no manifold error. The same "bug" (feature?) occured while exporting to DXF.

I hope this little story helps you in your next "manifold error" hunt!
Re: 3dsMax export manifold bug [message #5086 is a reply to message #4704 ] Wed, 01 July 2009 04:17 UTC Go to previous messageGo to next message
avatar EFFalcon  is currently offline EFFalcon
Messages: 21
Registered: March 2009
Go to all my models
Junior Member
Thanks for posting your findings, its just helped me find a similar issue.
I was exporting from 3DSMAX 9 to 3DS
Then exporting from AccuTrans to Collada with some Rescaling.

If i then loaded the object to Shapeways, i was getting manifold errors.
If i uploaded individual elements of the 3d model, it would work fine.
but i guess it was doing the same as you suggested and merging vertices.

3DSMAX -> STL Seems to have worked better, just had to fix up the scaling.
Re: 3dsMax export manifold bug [message #6280 is a reply to message #4704 ] Sat, 05 September 2009 04:04 UTC Go to previous message
avatar AaronStarr  is currently offline AaronStarr
Messages: 6
Registered: December 2008
Go to all my models
Junior Member
When viewing the error list in your gallery, click on the manifold link, and it will show a Java-generated view of the manifold error, and give you some idea of where to look first. I just got this exact error a couple of minutes ago from the same thing.

Now I'm having scaling issues... grr.

 
   
Previous Topic:Find intersecting triangles?
Next Topic:Blender: From a modelled grid to a solid object

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.