Home » Support » 3D Printing » Error when uploading but can't find the problem
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
Error when uploading but can't find the problem [message #72509] Thu, 01 August 2013 18:33 UTC Go to next message
avatar joie  is currently offline joie
Messages: 38
Registered: June 2011
Go to my shop
Member
Hi there;

The facts:

- I uploaded my model to my shop
- It's a colored WRL (vertex colors)
- It uploaded fine and appeared in my shop (privately though)
- Now I need to add something to it
- I did a boolean operation and since maya didn't do it, I exported it to Rhino in FBX (so it retain the vertex color info)
- I did the boolean and exported a WRL from Rhino keeping vertex color info

Now, when upload the model, I get this error but I don't know what it means:
"Some geometry are not supported: Switch"

Any help would be greatly appreciated.

Thank you.

P.D.: You can find the offending file attached, although is not the final one.

  • Attachment: Base.zip
    (Size: 310.33KB, Downloaded 20 time(s))


Visit my blog at 3djoie.blogspot.com
Re: Error when uploading but can't find the problem [message #72511 is a reply to message #72509 ] Thu, 01 August 2013 19:12 UTC Go to previous messageGo to next message
avatar joie  is currently offline joie
Messages: 38
Registered: June 2011
Go to my shop
Member
Ok, this is so strange... and frustrating.

Since I can't find the problem with the model, I have uploaded it to i.materialise web and You know what?, it uploads correctly and displays the vertex color data and all perfectly.

So, What's the problem with Shapeways?.

Any advise is welcome guys.


Visit my blog at 3djoie.blogspot.com
Re: Error when uploading but can't find the problem [message #72512 is a reply to message #72509 ] Thu, 01 August 2013 19:18 UTC Go to previous messageGo to next message
avatar Youknowwho4eva  is currently offline Youknowwho4eva
Messages: 5401
Registered: September 2008
Go to my shop
Shapie Expert
I work here
Stony and I are looking at it. There appears to be a pile of vertexes at 0,0,0. Stony is better at fixing stuff than I so hopefully he should have you something usable.

Something went wrong in Rhino, I tried to open in meshlab and got a No Geometry error. I was able to open in blender, export as an stl, and import into Netfabb, and it gave me some odd results. I was able to fix it, but of course after converting to STL you'd have to remap.


I learned a long time ago the wisest thing I can do is be on my own side, be an advocate for myself and others like me. -Maya Angelou
michael@shapeways.com
Re: Error when uploading but can't find the problem [message #72513 is a reply to message #72512 ] Thu, 01 August 2013 19:41 UTC Go to previous messageGo to next message
avatar stonysmith  is currently offline stonysmith
Messages: 1921
Registered: August 2008
Go to my shop
Shapie Expert
moderator
I opened up the WRL with a text editor and removed the CHOICE operator, along with some other stuff. Attached is the repaired WRL, along with it converted to STL format.

The STL had three holes in it that Netfabb was able to repair. Unfortunately, STL format loses all the color. I'm not sure whether you'd rather start over with repainting the STL, or try to upload the WRL and see what happens.

Your model is either very very tiny or very very thick, depending upon what dimensions you select. If the dimensions are in millimeters, then it's going to fail for being too thin. If the dimensions are in inches, then it is going to be very expensive to print.

  • Attachment: Base.zip
    (Size: 793.04KB, Downloaded 17 time(s))


Patience, Persistance, Politeness - the 3Ps will help us get us to Perfect Printed Products
Re: Error when uploading but can't find the problem [message #72515 is a reply to message #72513 ] Thu, 01 August 2013 20:14 UTC Go to previous messageGo to next message
avatar mkroeker  is currently offline mkroeker
Messages: 1710
Registered: June 2012
Go to all my models
Shapie Expert
Suggest Shapeways should treat "Switch{" like "Group{" , ignore the "whichChoice" and treat "choice[" like "children[", that
should take care of those Rhino-generated WRL files. (If it really stumbles over multiple choices, nothing is lost compared to
the current situation)
Doing this changes manually probably corresponds to what stony did, the result uploads without obvious issues except size (which
could be fixed manually with a "Transform{ scale 5. 5. 5." instead of the "Group{" replacing the "Switch{".
Re: Error when uploading but can't find the problem [message #72537 is a reply to message #72509 ] Fri, 02 August 2013 07:59 UTC Go to previous messageGo to next message
avatar joie  is currently offline joie
Messages: 38
Registered: June 2011
Go to my shop
Member
So, I need to open the WRL file and delete the first part of it, the part that says the version of the software I used and the "switch" thing and should be OK.

I will try again, but the WRL I uploaded was only a demo and it was only 3 Mb of data..., the actual one is +300 Mb!, How the hell may I open that huge file in a notepad? Very Happy

I'll come back with news Smile

P.D.: I imported the STL file you fixed and I couldn't find the ofending holes..., did you fixed them also?.


Visit my blog at 3djoie.blogspot.com
Re: Error when uploading but can't find the problem [message #72538 is a reply to message #72537 ] Fri, 02 August 2013 08:39 UTC Go to previous messageGo to next message
avatar mkroeker  is currently offline mkroeker
Messages: 1710
Registered: June 2012
Go to all my models
Shapie Expert
joie wrote on Fri, 02 August 2013 07:59

So, I need to open the WRL file and delete the first part of it, the part that says the version of the software I used and the "switch" thing and should be OK.[

From what I saw, the version information in the header did not hurt.
What needs to be done is:
1. replace the word "Switch" with "Group" , and the word "choice" with "children", leaving the various brackets in place.
2. remove the line that starts with "whichChoice"

Quote:

I will try again, but the WRL I uploaded was only a demo and it was only 3 Mb of data..., the actual one is +300 Mb!, How the hell may I open that huge file in a notepad? Very Happy

On a real operating system Very Happy use sed, for Windows look here for a list of choices.

Re: Error when uploading but can't find the problem [message #72551 is a reply to message #72509 ] Fri, 02 August 2013 13:14 UTC Go to previous messageGo to next message
avatar Youknowwho4eva  is currently offline Youknowwho4eva
Messages: 5401
Registered: September 2008
Go to my shop
Shapie Expert
I work here
How do you plan on uploading a 300mb file? The limit is 64mb.


I learned a long time ago the wisest thing I can do is be on my own side, be an advocate for myself and others like me. -Maya Angelou
michael@shapeways.com
Re: Error when uploading but can't find the problem [message #72552 is a reply to message #72551 ] Fri, 02 August 2013 13:36 UTC Go to previous messageGo to next message
avatar mkroeker  is currently offline mkroeker
Messages: 1710
Registered: June 2012
Go to all my models
Shapie Expert
Does this limit apply for the unpacked contents of a zip file ? VRML2 should compress well enough that I would be more
concerned about the 1 million triangle limit. (Any thoughts about increasing that some day ?)
Re: Error when uploading but can't find the problem [message #72554 is a reply to message #72509 ] Fri, 02 August 2013 14:02 UTC Go to previous message
avatar joie  is currently offline joie
Messages: 38
Registered: June 2011
Go to my shop
Member
No problem for that, the 300 mb wrl file is compressed to below 60mb ZIP file Smile


Visit my blog at 3djoie.blogspot.com

 
   
Previous Topic:Printing tall ceramics
Next Topic:Dimensional accuracy/consistency

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.