Home » Support » 3D Printing » missing texture for color printing?
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
missing texture for color printing? [message #70009] Tue, 18 June 2013 04:58 UTC Go to next message
avatar darkczar  is currently offline darkczar
Messages: 15
Registered: May 2012
Go to all my models
Junior Member
Hi,

I'm trying to upload a model with color for printing. I've created the model in Maya. I exported it as an .obj. It has the file texture applied. I import it into Meshlab, and the colors are there. I zip the resulting .x3d file from Meshlab and the texture file (.tif) together and upload. It gets kicked back saying it can't find the texture. I'm choosing face color when I export the .x3d file. I took a look at the top of the .x3d file in notepad, and the texture seems to be at the root, as it were:

<ImageTexture url="baked_v04_final.tif"/>

Can somebody help? I'm uploading the file, just in case...

thanks,

JP

Re: missing texture for color printing? [message #70010 is a reply to message #70009 ] Tue, 18 June 2013 05:02 UTC Go to previous messageGo to next message
avatar darkczar  is currently offline darkczar
Messages: 15
Registered: May 2012
Go to all my models
Junior Member
Also, I extracted the .zip - and the .x3d and .tif are sitting there next to each other as happy as two peas in a pod.
Re: missing texture for color printing? [message #70018 is a reply to message #70010 ] Tue, 18 June 2013 08:48 UTC Go to previous messageGo to next message
avatar mkroeker  is currently offline mkroeker
Messages: 1598
Registered: June 2012
Go to all my models
Senior Member
Use netfabb studio basic to run a standard repair - as is, netfabb reports pretty extreme size&location for your model and does not recognize
any closed hulls.
Re: missing texture for color printing? [message #70021 is a reply to message #70018 ] Tue, 18 June 2013 09:33 UTC Go to previous messageGo to next message
avatar mkroeker  is currently offline mkroeker
Messages: 1598
Registered: June 2012
Go to all my models
Senior Member
Also, the imageTexture node takes single quotes around the double-quoted file argument,
<ImageTexture url=' "baked_v04_final.tif" '/>
which probably caused the original upload problem.
Re: missing texture for color printing? [message #70032 is a reply to message #70021 ] Tue, 18 June 2013 14:38 UTC Go to previous messageGo to next message
avatar stonysmith  is currently offline stonysmith
Messages: 1864
Registered: August 2008
Go to my shop
Senior Member
moderator
I thought the texture formats had to be JPG or PNG.
You might try converting the TIF to JPG and update the url appropriately, then try the upload again.


Patience, Persistance, Politeness - the 3Ps will help us get us to Perfect Printed Products
Re: missing texture for color printing? [message #70035 is a reply to message #70032 ] Tue, 18 June 2013 15:30 UTC Go to previous messageGo to next message
avatar mkroeker  is currently offline mkroeker
Messages: 1598
Registered: June 2012
Go to all my models
Senior Member
Gah. Converting his texture to png was the first thing I did, forgot to mention it as I was in a hurry.
Still believe the geometry issues are real, though perhaps shapeways mesh medic manages to fix
them automatically during upload.
Re: missing texture for color printing? [message #70078 is a reply to message #70035 ] Wed, 19 June 2013 02:47 UTC Go to previous messageGo to next message
avatar darkczar  is currently offline darkczar
Messages: 15
Registered: May 2012
Go to all my models
Junior Member
All I did was change the texture format to .jpg, and it uploaded. I saw it with the correct texture and I ordered it. Yeah!

Now, all I gotta do is wait for the "thin walls" email. haha!

I don't know what that netfabb program is, but the model is sitting at the origin, transforms are frozen, and it is closed. I did not have to add extra quotes to the .x3d file.
Re: missing texture for color printing? [message #70265 is a reply to message #70078 ] Fri, 21 June 2013 14:07 UTC Go to previous message
avatar darkczar  is currently offline darkczar
Messages: 15
Registered: May 2012
Go to all my models
Junior Member
It's being printed! No thin walls! Yeah!

 
   
Previous Topic:Full Color Sandstone Clearance
Next Topic:Printing multiple materials

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.