Home » Community » Work in progress » colors on models and using Blender application
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
colors on models and using Blender application [message #69219] Wed, 05 June 2013 04:54 UTC Go to next message
avatar yvesbodson  is currently offline yvesbodson
Messages: 12
Registered: October 2012
Go to my shop
Junior Member
I am learning to work with shapeways and mostly resolved the modeling and post modeling questions in the context of using the Blender program.
However regarding having color printing seems to be another story which may be specific to Blender and not to other apps like Maya or 3DS and the likes.
In my case I can export my model in x3d and vrml2. Both are supposed to manage the colors either as vertex mapping or textures.
Having no success with a recent model I have started to test using a simple cube, supporting vertex colors on one of his face.
I made attempts using x2d and vrml2 without any colors showing up.
One question I wonder is : does the uploaded object should show the colors once accepted by the system?
Or does colors are only showing when printing and after having selected a material like sand stone that supports full colors?
I went through the exported files in x3d and vrml2 made by Blender. Both reference rgb values but I cannot be sure they are the corrects coordinates at the present point. I will look further into that.
Re: colors on models and using Blender application [message #69223 is a reply to message #69219 ] Wed, 05 June 2013 07:05 UTC Go to previous messageGo to next message
avatar AmLachDesigns  is currently offline AmLachDesigns
Messages: 1360
Registered: September 2011
Go to my shop
Shapie Expert
Hi Yves

first thing is that if the static model in SW does not show colours your model will not print colours. The rotating model sometimes will not show colours, but as long as the static model is ok it should be good.

I am not an expert in this, at all, but maybe the following will help:
1. For colour I use .x3d - I do not even see .vrml as an export option in my version of Blender;
2. If you create a cube and give it a coloured Material and then export it directly with .x3d, upload to SW, you should have a coloured cube in SW;
3. You can use Vertex painting to achieve a similar but more complex result;
4. Only if you are applying a texture do you need to supply SW with the texture and the .x3d in the same zip:
- In blender you have your object and you give it a material, colour does not matter;
- You create or import your texture (the texture file should be in the location where you will save your .x3d) and associate it with the Material of the object
- You export the .x3d and zip it and the texture together (in WIndows, select both files and Send To --> Compressed (Zipped) Folder;
- Upload and voila!

All that I know on this, which is perhaps not so much, I learnt from Blender tutorials on the web and the instructions here, so check out what's available is my advice.

Good luck!
Re: colors on models and using Blender application [message #69226 is a reply to message #69219 ] Wed, 05 June 2013 09:16 UTC Go to previous messageGo to next message
avatar mkroeker  is currently offline mkroeker
Messages: 2012
Registered: June 2012
Go to all my models
Shapie Expert
Vertex painting should work - can you make one of your files available (even if it is only the test cube) ?
There is currently a problem with x3d files using rgba colors instead of plain rgb, but so far this has only
come up with files created by meshlab. Can you check your vrml2 or x3d files with a viewer such as view3dscene ?
Re: colors on models and using Blender application [message #69230 is a reply to message #69226 ] Wed, 05 June 2013 13:11 UTC Go to previous messageGo to next message
avatar yvesbodson  is currently offline yvesbodson
Messages: 12
Registered: October 2012
Go to my shop
Junior Member
Thanks for your input
Here is the cube test I did in vrml2 from Blender 2.67. It references rgb colors but I did not have any colors on the model after loading. It maybe that one need to select a material to have colors involved like in sandstone. that is kinda logical. But then if I select the sandstone material I should see the model becoming colored, which it is not at this time.
Here is the cube model in vrml
I can also load the file from my previous model the armorial which is carrying colors, mapped to vertex and one texture mapped to UV.

Re: colors on models and using Blender application [message #69231 is a reply to message #69230 ] Wed, 05 June 2013 13:37 UTC Go to previous messageGo to next message
avatar AmLachDesigns  is currently offline AmLachDesigns
Messages: 1360
Registered: September 2011
Go to my shop
Shapie Expert
When I import your model cube it has no colour. The material XXX is white.

Here is a test I made earlier to check what I was telling you:

  • Attachment: cube 2.x3d
    (Size: 4.51KB, Downloaded 13 time(s))

Re: colors on models and using Blender application [message #69233 is a reply to message #69231 ] Wed, 05 June 2013 13:45 UTC Go to previous messageGo to next message
avatar yvesbodson  is currently offline yvesbodson
Messages: 12
Registered: October 2012
Go to my shop
Junior Member
You are right I realized this after the loading. I am looking for a solution . I think that the code generated by the x3d and vrml2 from Blender has issues with colors. But not sure at this time yet.
will come back soon as I find something..
Thank you for your input and help.
Yves
Re: colors on models and using Blender application [message #69234 is a reply to message #69233 ] Wed, 05 June 2013 13:55 UTC Go to previous message
avatar mkroeker  is currently offline mkroeker
Messages: 2012
Registered: June 2012
Go to all my models
Shapie Expert
As a quick workaround for your emblem, you could open the x3d in a text editor and correct the
diffuseColor entries for the six materials used - currently, all are the same light gray (0.8 0.8 0.8 )
(At least this is easier to fix than the loooong list of vertex color triples (all 1.0 1.0 1.0 i.e. white) in
the vrml testcase.)

[Updated on: Wed, 05 June 2013 13:55 UTC]


 
   
Previous Topic:What if my model is in pieces?...
Next Topic:Non-Profit Fundraiser Model - Don't Starve, Wilson

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.