Home » Support » 3D Design » Yet another non-manifold C4D object
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
Yet another non-manifold C4D object [message #6043] Tue, 25 August 2009 00:44 UTC Go to next message
avatar SeveQ  is currently offline SeveQ
Messages: 16
Registered: June 2009
Go to my shop
Junior Member
Hello there,

I've been testing my object's compatibility against the Shapeways engine by uploading it again and again (hope that's okay...). But most of the time I get a message that it's a non-manifold object. The uploads passing the manifold-test afterwards fail the normals-test.

The object is created with Cinema 4D R11 which apparently has some STL exporting issues (all normals flipped). I flipped all the normals to the outside of the object using MashLab. But even this corrected revision of the object fails either the manifold- or the normals-test.

I'll attach the object to this post in stl format and would be totally grateful if somebody could take a look into it.

I'm throwing the towel for now. It's late, have to go sleeeee...*chhrrrr*

Thanks a lot and good night folks!

Hendrik

Re: Yet another non-manifold C4D object [message #6046 is a reply to message #6043 ] Tue, 25 August 2009 04:19 UTC Go to previous messageGo to next message
avatar WiKKiDWidgets  is currently offline WiKKiDWidgets
Messages: 224
Registered: April 2009
Go to my shop
Senior Member
Hiya Steve;

Ya, that one was a bastard to figure out, easy to fix, but a pain to actually see what was wrong. I'd explain but I'm too sleepy....

Dead

Re: Yet another non-manifold C4D object [message #6048 is a reply to message #6043 ] Tue, 25 August 2009 10:08 UTC Go to previous messageGo to next message
avatar SeveQ  is currently offline SeveQ
Messages: 16
Registered: June 2009
Go to my shop
Junior Member
Harr! Makes me happy that I was able to give you a challenge. Laughing

I hope you've slept well (at least as well as I have) enough to be able to explain what the problem actually was. That would be absolutely great. I'd like to be able to avoid this kind of issue next time.

Thanks a lot! Smile

Re: Yet another non-manifold C4D object [message #6052 is a reply to message #6048 ] Tue, 25 August 2009 14:02 UTC Go to previous message
avatar WiKKiDWidgets  is currently offline WiKKiDWidgets
Messages: 224
Registered: April 2009
Go to my shop
Senior Member
Avoiding Manifold issues with some software packages isn't really an option. It's just something you have to deal with. (Sketchup is notorious for them)

I wrote a tutorial a while back to help folks deal with them using Blender. (Free!) You can download it from here:

http://www.wikkid-widgets.com/RepairingNon-manifoldmesheswit hBlender.pdf

As for your model, there were two problems:

index.php?t=getfile&id=1189&private=0

The two verticies I have selected are connected by a single line. But the vertex in the red box should have been connected. I just subdivied the line (edge) and then place that vertex precisely over the vertex in the red box, and removed the other one.


The second issue was that the brace you had in the front was flush with the legs on the faces. It's perfectly acceptible to intersect two manifold objects into a single model, but they need to truly intersect. I.e. they need to be slightly "in" each other for them to weld together. Set perfectly flush with each other they are not really one object.

Hope that helps.

WiKKiD


 
   
Previous Topic:Menifold problem
Next Topic:Light permeable