Home » Community » General Discussion » WRL file with texture not working correctly
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
WRL file with texture not working correctly [message #59221] Wed, 26 December 2012 15:35 UTC Go to next message
avatar Patrick3D  is currently offline Patrick3D
Messages: 3
Registered: December 2012
Go to my shop
Junior Member
Hi all. I'm a 3D modeler/animator who is new to 3D print models and their specs.
I have been trying to upload to Shapeways a .wrl file with a .jpg texture referenced to the model itself.
I use Maya and exported the 3D file and texture.
Shapeways customer support keeps having trouble either opening the file and/or finding the texture.
Is there something I may be doing wrong? I've done all I know to fix this and need some tech. advice.
Using Maya 2010.

Thanks,

Patrick
Re: WRL file with texture not working correctly [message #59232 is a reply to message #59221 ] Wed, 26 December 2012 16:46 UTC Go to previous messageGo to next message
avatar denali3ddesign  is currently offline denali3ddesign
Messages: 511
Registered: February 2011
Go to my shop
Senior Member
This may sound too simple, but are you uploading a ZIP file with the .wrl file and the texture inside?


Trouble using SketchUp? Get my book "3D Printing with SketchUp" - http://bit.ly/1jQ4RtV
Re: WRL file with texture not working correctly [message #59233 is a reply to message #59232 ] Wed, 26 December 2012 16:53 UTC Go to previous messageGo to next message
avatar Patrick3D  is currently offline Patrick3D
Messages: 3
Registered: December 2012
Go to my shop
Junior Member
Yes, I exported the .wrl file, referenced the texture .jpg to the file from inside its own zipped folder that I uploaded to shapeways.
I zipped each individual file by selecting the wrl file, the rgb file that was created upon export, and the .jpg texture file.
Thanks Marcus
Re: WRL file with texture not working correctly [message #59235 is a reply to message #59233 ] Wed, 26 December 2012 17:24 UTC Go to previous messageGo to next message
avatar denali3ddesign  is currently offline denali3ddesign
Messages: 511
Registered: February 2011
Go to my shop
Senior Member
You should have only two files inside the ZIP - the Texture (.jpg) and the .wrl file....like so:
index.php?t=getfile&id=24785&private=0

It should not be double-zipped. Does that make sense?


Trouble using SketchUp? Get my book "3D Printing with SketchUp" - http://bit.ly/1jQ4RtV
Re: WRL file with texture not working correctly [message #59243 is a reply to message #59221 ] Wed, 26 December 2012 19:51 UTC Go to previous messageGo to next message
avatar Fredd  is currently offline Fredd
Messages: 350
Registered: November 2011
Go to all my models
Senior Member
Just select the texture and wrl, with both selected compress them, Then upload the zip.
The rgb file you mentioned may not be necessary to zip with the wrl and texture file. Try just the wrl and texture.

I hope it is not the infamous wrl coding problem(Shivers)
Keith


Have any questions regarding Blender, and need fast answers, you are always welcome at the IRC Server Freenode, channel #blender. As a bonus, several there have experience in modelling for 3D prints.

Keith
Re: WRL file with texture not working correctly [message #59246 is a reply to message #59243 ] Wed, 26 December 2012 19:58 UTC Go to previous messageGo to next message
avatar Willie4  is currently offline Willie4
Messages: 3
Registered: December 2012
Go to all my models
Junior Member
Thanks all. Yes, I've been doing this procedure, with selecting both the texture and wrl file , then compressing them both into a .zip archive folder.
No luck so far , have tried twice this way. But I did just upload another archive .zip folder with a new .wrl file and .jpeg file. The rgb file that accompanied the wrl file I was told can be opened in fcheck and saved as a .jpeg..so I did this and will see if this works.
Does anyone know of a free vrml viewer online? I've tried several for my mac but no luck here either. I just want to see on my end if the wrl file opens before I waste my time uploading to Shapeways only to get an error email from CS. Thanks!
Re: WRL file with texture not working correctly [message #59247 is a reply to message #59246 ] Wed, 26 December 2012 20:00 UTC Go to previous messageGo to next message
avatar denali3ddesign  is currently offline denali3ddesign
Messages: 511
Registered: February 2011
Go to my shop
Senior Member
Meshlab opens .wrl files and works on Mac.


Trouble using SketchUp? Get my book "3D Printing with SketchUp" - http://bit.ly/1jQ4RtV
Re: WRL file with texture not working correctly [message #59248 is a reply to message #59247 ] Wed, 26 December 2012 20:01 UTC Go to previous messageGo to next message
avatar Willie4  is currently offline Willie4
Messages: 3
Registered: December 2012
Go to all my models
Junior Member
Thanks Marcus!
Re: WRL file with texture not working correctly [message #59249 is a reply to message #59247 ] Wed, 26 December 2012 20:23 UTC Go to previous message
avatar Patrick3D  is currently offline Patrick3D
Messages: 3
Registered: December 2012
Go to my shop
Junior Member
Ok. I just downloaded and installed MeshLab, and realized that I can just export the model as an .obj in Maya with texture referenced..then open the .obj in Meshlab and save as .wrl. I tried this and it worked, with texture and all! So hopefully no more errors. Thanks all!

Patrick

 
   
Previous Topic:Modelling programs for creating 3D diagrams
Next Topic:Is there a problem with the Co-Creater Upload?

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.