Now Through Sunday Night. Black Friday Deals & Free Shipping! See the deals.
Home » Support » Bug Reporting » STL's Do Not Update
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
STL's Do Not Update [message #55441] Tue, 16 October 2012 13:17 UTC Go to next message
avatar PeregrineStudios  is currently offline PeregrineStudios
Messages: 324
Registered: September 2012
Go to my shop
Senior Member
I'm getting really sick of reporting bug after bug after bug on the website.

I updated various STL files of my products last night and they have yet to update. The preview images have updated, but the 360-degree view has not, and two of my orders were cancelled today because the system is STILL - over 12 hours later - using the old STL's rather than the new ones. At this point, it's infinitely faster to simply delete the old products and upload completely new ones - which is ridiculous. Why include the 'Update 3D File' button if it won't do anything?
Re: STL's Do Not Update [message #55451 is a reply to message #55441 ] Tue, 16 October 2012 18:18 UTC Go to previous messageGo to next message
avatar natalia  is currently offline natalia
Messages: 869
Registered: September 2008
Go to all my models
Senior Member
I work here
Hi There!

Can you email me the specific models you are referring to please? natalia@shapeways.com

The ones that are visible in your shop that were updated in the last week seem fine?

The more info we have, the quicker we can fix it!

Best,
Natalia


Shapeways Community Manager
Re: STL's Do Not Update [message #55472 is a reply to message #55451 ] Wed, 17 October 2012 03:11 UTC Go to previous messageGo to next message
avatar PeregrineStudios  is currently offline PeregrineStudios
Messages: 324
Registered: September 2012
Go to my shop
Senior Member
I e-mailed you several hours ago. Still awaiting a response.
Re: STL's Do Not Update [message #55501 is a reply to message #55472 ] Wed, 17 October 2012 15:54 UTC Go to previous messageGo to next message
avatar PeregrineStudios  is currently offline PeregrineStudios
Messages: 324
Registered: September 2012
Go to my shop
Senior Member
This is f**king ridiculous now. I've never encountered worse service in my entire life. I've been waiting for a reply since yesterday, and while I was waiting, ANOTHER ORDER was cancelled for having 'loose parts'. I deleted my entire product and uploaded a completely new one, and your computer system is still pulling the STL for my old, deleted product! I'm partially convinced that this whole thing is an enormous practical joke. No computer system could be so buggy and no company could be so incompetent that this sort of thing would happen over and over and over again.
Re: STL's Do Not Update [message #55502 is a reply to message #55501 ] Wed, 17 October 2012 15:59 UTC Go to previous messageGo to next message
avatar PeregrineStudios  is currently offline PeregrineStudios
Messages: 324
Registered: September 2012
Go to my shop
Senior Member
I just downloaded the STL directly from one of my products ( http://www.shapeways.com/model/739455/pendant___house_stark. html?key=c8537e9878f48f36c1c83af146b2c390) and there are no loose parts. However it was cancelled because an older product - that I deleted - that bore the same name did have loose parts, and apparently your computer system or 3D printing people are still using the STL from the older, deleted product.

Clicking on that product will show you the preview for the STL I uploaded. Now below is the image that was sent to me in the email saying my order was cancelled. You can clearly see they are two different STL files, and as I've stated numerous times now, just so that it can sink in, I didn't just update my 3D file, I deleted the entire older product and uploaded a new one. WHY is my old, DELETED STL STILL in your computer and WHY are you using THAT one in association with my NEW product?

  • Attachment: 407486.JPG
    (Size: 41.65KB, Downloaded 25 time(s))

[Updated on: Wed, 17 October 2012 16:03 UTC]

Re: STL's Do Not Update [message #55511 is a reply to message #55441 ] Wed, 17 October 2012 17:28 UTC Go to previous messageGo to next message
avatar Youknowwho4eva  is currently offline Youknowwho4eva
Messages: 5689
Registered: September 2008
Go to my shop
Shapie Expert
I work here
Step 1: Take a breath. The SW crew is extremely busy today. I just emailed support with the link to this post to see if they can figure out what is going on. First step when you have a problem like this is to contact them. Shapeways service tries to get back to emails within 16 hours. They usually get back in significantly less time, but like I said today is a busy day.

I have a question, it looks like your items are failing the check before going to printing. This usually happens a few days after ordering. Did you update the file before or after the order? If you ordered before you updated the model, that would be using the older file.


I learned a long time ago the wisest thing I can do is be on my own side, be an advocate for myself and others like me. -Maya Angelou
michael@shapeways.com Community Advocate
Re: STL's Do Not Update [message #55514 is a reply to message #55511 ] Wed, 17 October 2012 17:34 UTC Go to previous messageGo to next message
avatar PeregrineStudios  is currently offline PeregrineStudios
Messages: 324
Registered: September 2012
Go to my shop
Senior Member
Of course I updated before ordering. If I ordered after updating, I would have no one to blame but myself.

If it was only one issue that was understandable I would be happy to wait. But I first encountered the problem mentioned in my first post. Then Natalie told me to e-mail her... yesterday. So I did. And never got a reply or acknowledgement. Then this issue today, which is absolutely no understandable. Whoever designed their software needs to be fired immediately, because he clearly did a sh*t job if I can delete a product, make a new one and have the printers use the STL from a deleted one for my new one.

This is all fine and dandy now, but I'm going to start adding Shapeways printed items to things I sell on Etsy and locally. This kind of screw-up is not understandable now and will be completely inexcusable later when I have customers waiting for their products and I can't deliver because the printers are using out-dated and deleted STL's.

I didn't bother emailing support because I already emailed Natalie at the e-mail address provided above. If she can't be bothered to get back to me in a timely manner there's no reason to assume she or anyone else on the support team has any respect for me or what I need them to deliver.

But on that note, thank you for finally getting back to me. It's nice to see someone out here who is actually taking the time to look at these problems.

[Updated on: Wed, 17 October 2012 17:35 UTC]

Re: STL's Do Not Update [message #55515 is a reply to message #55511 ] Wed, 17 October 2012 17:35 UTC Go to previous messageGo to next message
avatar stonysmith  is currently offline stonysmith
Messages: 2112
Registered: August 2008
Go to my shop
Shapie Expert
moderator
When a customer places an order, a copy of the STL is "frozen", and accompanies the order thruout the rest of the cycle. This method prevents someone from uploading a 1cm3 model, ordering it, and then relpacing it with a 100cm3 model - allowing them to receive the more costly model for the cheaper price.

If you are having orders cancelled, it is because the original STL was faulty and someone ordered it that way. It is "normal" for the process to take several days between Order Acceptance and Production to start checking the model before printing it.

So Yes, you can receive rejection emails even after the STL has been udpated.


Patience, Persistance, Politeness - the 3Ps will help us get us to Perfect Printed Products
Re: STL's Do Not Update [message #55516 is a reply to message #55515 ] Wed, 17 October 2012 17:37 UTC Go to previous messageGo to next message
avatar PeregrineStudios  is currently offline PeregrineStudios
Messages: 324
Registered: September 2012
Go to my shop
Senior Member
stonysmith wrote on Wed, 17 October 2012 17:35

When a customer places an order, a copy of the STL is "frozen", and accompanies the order thruout the rest of the cycle. This method prevents someone from uploading a 1cm3 model, ordering it, and then relpacing it with a 100cm3 model - allowing them to receive the more costly model for the cheaper price.

If you are having orders cancelled, it is because the original STL was faulty and someone ordered it that way. It is "normal" for the process to take several days between Order Acceptance and Production to start checking the model before printing it.

So Yes, you can receive rejection emails even after the STL has been udpated.


The STL was updated before the order was made. In fact, as I spell out very plainly above, I didn't just update the STL, I completely deleted the older one and created an entirely new product that somehow STILL used the old deleted STL, despite the fact that they were two completely different products.
Re: STL's Do Not Update [message #55517 is a reply to message #55441 ] Wed, 17 October 2012 17:49 UTC Go to previous messageGo to next message
avatar Youknowwho4eva  is currently offline Youknowwho4eva
Messages: 5689
Registered: September 2008
Go to my shop
Shapie Expert
I work here
It's very perplexing that creating a new item would have the same problem... If you can share the model with us to look at, if not you can email it to me, and I'll take a look. If it is indeed a software issue, I can't do anything personally about that, but I can tell the right people that it needs to be fixed as that would be a major error.


I learned a long time ago the wisest thing I can do is be on my own side, be an advocate for myself and others like me. -Maya Angelou
michael@shapeways.com Community Advocate
Re: STL's Do Not Update [message #55521 is a reply to message #55517 ] Wed, 17 October 2012 17:55 UTC Go to previous messageGo to next message
avatar PeregrineStudios  is currently offline PeregrineStudios
Messages: 324
Registered: September 2012
Go to my shop
Senior Member
Youknowwho4eva wrote on Wed, 17 October 2012 17:49

It's very perplexing that creating a new item would have the same problem... If you can share the model with us to look at, if not you can email it to me, and I'll take a look. If it is indeed a software issue, I can't do anything personally about that, but I can tell the right people that it needs to be fixed as that would be a major error.


This is the item that was rejected: http://www.shapeways.com/model/739455/c8537e9878f48f36c1c83a f146b2c390 (EDIT: I enabled downloads if you need to download it)

It was rejected for having loose parts. As you can clearly see on the item, there are no loose parts whatsoever. Furthermore, this is the one and only STL that has ever been tied to this product, so they cannot be using an older version. This product's STL has only been uploaded once, when I created the product.

Attached is the picture they sent me. They were clearly working off an STL that was from another product - yes, the same pendant, but I deleted the model from 'My Models' and uploaded a new one because the STL would not update (which was my first problem). That STL should not even be in your system anymore. Yet, clearly, the model was rejected for print because it was using an STL that should not exist anymore.

  • Attachment: 407486.JPG
    (Size: 41.65KB, Downloaded 28 time(s))

[Updated on: Wed, 17 October 2012 17:56 UTC]

Re: STL's Do Not Update [message #55523 is a reply to message #55441 ] Wed, 17 October 2012 18:22 UTC Go to previous messageGo to next message
avatar Youknowwho4eva  is currently offline Youknowwho4eva
Messages: 5689
Registered: September 2008
Go to my shop
Shapie Expert
I work here
I have no idea why they would send you the wrong image, That has to be a reviewer mistake. What I can see about your file so far in Netfab, is that originally it says it was 7 shells, and after repairing in Netfab it's still saying that it's 2 shells. One of the clumps of hair (?) is not attached to the rest of the part. I'm not sure if this is what the reviewer is seeing. I'd try getting the file so that in Netfab it says 1 shell to be sure that the model doesn't have loose pieces.


I learned a long time ago the wisest thing I can do is be on my own side, be an advocate for myself and others like me. -Maya Angelou
michael@shapeways.com Community Advocate
Re: STL's Do Not Update [message #55525 is a reply to message #55523 ] Wed, 17 October 2012 18:28 UTC Go to previous messageGo to next message
avatar PeregrineStudios  is currently offline PeregrineStudios
Messages: 324
Registered: September 2012
Go to my shop
Senior Member
Youknowwho4eva wrote on Wed, 17 October 2012 18:22

I have no idea why they would send you the wrong image, That has to be a reviewer mistake. What I can see about your file so far in Netfab, is that originally it says it was 7 shells, and after repairing in Netfab it's still saying that it's 2 shells. One of the clumps of hair (?) is not attached to the rest of the part. I'm not sure if this is what the reviewer is seeing. I'd try getting the file so that in Netfab it says 1 shell to be sure that the model doesn't have loose pieces.


That works out well, since I'm revamping those models anyway. I was fairly certain all parts were connected but if Netfab says so...

Actually, on second thought, I'm not sure that's what the reviewer was seeing, since there was another model (long since deleted at this point sadly) that was ALSO rejected for printing, and it was most definitely a very solid, single piece. Same story as this one: deleted old product, updated new one, rejected.

My guess is that the reviewer saw the same names come back again and just assumed they were the same model, rejecting them out of hand without actually checking to see if they were fixed, resending me the same images. Which is also unacceptable, but makes sense anyway, since a person making a mistake is more understandable than a huge software error like this could be.

Just to not confuse the issue, I'll upload my new revamped models, rename the STL's to something different, rename the products to something different, and try to print them. These ones will definitely be a single object.
Re: STL's Do Not Update [message #55527 is a reply to message #55441 ] Wed, 17 October 2012 18:48 UTC Go to previous messageGo to next message
avatar Youknowwho4eva  is currently offline Youknowwho4eva
Messages: 5689
Registered: September 2008
Go to my shop
Shapie Expert
I work here
I'm sure we'll find out more, as Natalia cc'd me on her reply to you. She's reported it to bugs to figure out what is going on. I wouldn't delete any more of the items that you included in your email so they can review them to see why they aren't updating properly.


I learned a long time ago the wisest thing I can do is be on my own side, be an advocate for myself and others like me. -Maya Angelou
michael@shapeways.com Community Advocate
Re: STL's Do Not Update [message #55528 is a reply to message #55525 ] Wed, 17 October 2012 18:53 UTC Go to previous messageGo to next message
avatar mkroeker  is currently offline mkroeker
Messages: 2017
Registered: June 2012
Go to all my models
Shapie Expert
Might happen on a client-server network with the clocks badly out of sync - hilarity ensues
when the wrong side decides that its cache content is newer.
Re: STL's Do Not Update [message #55530 is a reply to message #55441 ] Wed, 17 October 2012 19:10 UTC Go to previous message
avatar natalia  is currently offline natalia
Messages: 869
Registered: September 2008
Go to all my models
Senior Member
I work here
Hi Christian,

Since you flagged this issue here a few days ago, the bugs team, Michael and myself have been trying to figure out your problem.

Thank you for emailing me, before I responded to you, I forwarded your stl's to the bugs team. So apologies for the apparent delay, a lot has been happening in the background.

Service is looking into your orders now, and as Michael pointed out, they should always be your first port of call when things go wrong, as they are in the best position to offer advice to fix models.

To avoid discussing your private models on a public forum, I am going to close this thread and direct you to email service directly - I have also emailed you this information.

Thank you,
Natalia


Shapeways Community Manager

 
   
Previous Topic:Price system is totally confusing me :(
Next Topic:Search in Shapeways

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.