Our Gift to You: 20% off your own designs in Strong & Flexible Plastic through Dec 23, with promo code MY2014 · details
Home » Community » It arrived! » My object is wrong :-(
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
My object is wrong :-( [message #5064] Mon, 29 June 2009 09:23 UTC Go to next message
avatar duenove  is currently offline duenove
Messages: 9
Registered: May 2009
Go to all my models
Junior Member
My object is very different to what i want. I'm sure i made a mistaken somewhere but i don't know what .
Every circular line in my object became polygonal (not only what the red arrow points) and also where there would be some empty slots for my coins there are slots full of plastic.
This is what i made:
I draw my project with autocad 2008.
Then i opened it with 3ds Max 2010 Trial version.
I exported it with .dae extension and finally i loaded it in the shapeways database.

So what was wrong?

http://img3.imageshack.us/img3/6496/errorez.jpg
Re: My object is wrong :-( [message #5069 is a reply to message #5064 ] Mon, 29 June 2009 15:55 UTC Go to previous messageGo to next message
avatar duenove  is currently offline duenove
Messages: 9
Registered: May 2009
Go to all my models
Junior Member
Nobody can help me?
Re: My object is wrong :-( [message #5070 is a reply to message #5069 ] Mon, 29 June 2009 16:07 UTC Go to previous messageGo to next message
avatar joris  is currently offline joris
Messages: 426
Registered: May 2008
Go to all my models
Senior Member
Did it look ok in Max?
Re: My object is wrong :-( [message #5071 is a reply to message #5070 ] Mon, 29 June 2009 16:29 UTC Go to previous messageGo to next message
avatar duenove  is currently offline duenove
Messages: 9
Registered: May 2009
Go to all my models
Junior Member
I would say yes but... it's not true.
Here is the problem. When 3ds Max import the dwg something go wrong.
So how can i convert my dwg?

And the second problem? why my slots are full and not empty for my coins?
Re: My object is wrong :-( [message #5077 is a reply to message #5071 ] Mon, 29 June 2009 23:32 UTC Go to previous messageGo to next message
avatar isilme  is currently offline isilme
Messages: 1
Registered: June 2009
Go to all my models
Junior Member
Your issue is the conversion from CAD to Max. The way that AutoCAD does things is different from that of Max, so objects will not always look the same, such as the smooth edges and holes. Unfortunately, I don't know any fixes other than remaking it in Max, but I'd ask around 3d communities, because I don't know much about either program. Wish I could help more
Re: My object is wrong :-( [message #5078 is a reply to message #5064 ] Tue, 30 June 2009 03:51 UTC Go to previous messageGo to next message
avatar er1c  is currently offline er1c
Messages: 44
Registered: September 2008
Go to my shop
Member
it's been ages since I used autocad, but I think you should check your surftab1 and surftab2 which defines how many segments autocad uses to draw curves

you might have to redraw those sections of the model tho, I don't think surftab settings affect entites already drawn, but I could be wrong.


http://er1c3dp.wordpress.com/
Re: My object is wrong :-( [message #5080 is a reply to message #5078 ] Tue, 30 June 2009 07:32 UTC Go to previous messageGo to next message
avatar duenove  is currently offline duenove
Messages: 9
Registered: May 2009
Go to all my models
Junior Member
Thank you everybody for the help.
I don't know anything about "surftab" so i don't know if it is the problem, but i don't think it's an autocad problem. In the dwg file the object is perfect. you can see it in the first image. I made the second only to show the difference from the first.
Conversion Process Is The Problem [message #5083 is a reply to message #5080 ] Tue, 30 June 2009 09:32 UTC Go to previous messageGo to next message
avatar ziusuadra  is currently offline ziusuadra
Messages: 10
Registered: August 2008
Go to all my models
Junior Member
Whilst you are superficially right (there is nothing wrong with the Autocad model) it is the conversion process that is causing your problem. Autocad uses mathematically defined curves to draw circles and similar (i.e. your model) but Shapeways uses polygons in all the formats it accepts (and it takes a lot of polygons to accurately represent a large curve to within a small degree of error.)
When you attempt to convert formats, the software looks at your model, says "This is perfectly nice curves, but I must turn them into polygons, or it won't work." So it does - but it doesn't know how many polygons exactly you want for each curve, or anything like that. Instead it takes a rough guess, and the result is your model gets messed up as shown above.
Two general solutions may or may not apply, depending on what you want.

1) Change the model inside Autocad, either so that it assumes more polygons for each curve when converted, or by converting the curves to polygons yourself.

2) Or, export the model and then manually correct the curves by subdividing and smoothing them using some other software, so as to achieve a decent approximation of the original curves.

Neither of these is particularly handy, but at least one of them should work.
Re: My object is wrong :-( [message #5124 is a reply to message #5064 ] Fri, 03 July 2009 19:49 UTC Go to previous messageGo to next message
avatar MaxSMoke777  is currently offline MaxSMoke777
Messages: 182
Registered: August 2008
Go to my shop
Senior Member
I don't know much about Autocad, but I'm very familiar with 3D Studio Max. It looks like you're model is defined by Splines, instead of straight up Polygons. If you go into the Edit tab and "Convert to Mesh", you'll see what your model truly looks like.

I'm willing to bet there's a conversion tab somewhere that allows you to define how many polygons are created for each and every arc you have. You just need to turn up the number until it's smooth enough to fit your needs. For instance, instead of 1 or 2 per 90 degree arc, you probably want more like 32 to 48.
Re: My object is wrong :-( [message #5302 is a reply to message #5124 ] Mon, 20 July 2009 11:31 UTC Go to previous messageGo to next message
avatar tones3-d  is currently offline tones3-d
Messages: 114
Registered: July 2009
Go to my shop
Senior Member
In AutoCAD, you need to type FACETRES at the command line. The default value is 0.5. Set it to 5 or higher. This will smooth your curves, including existing ones.

I'd not bother with 3dMax ... just export direct from AutoCAD:
Drop the file menu, choose "export", drop the filetypes list, choose "lithography(*.stl)".

The .STL file is directly usable by Shapeways.
Re: My object is wrong :-( [message #5310 is a reply to message #5302 ] Mon, 20 July 2009 18:10 UTC Go to previous message
avatar duenove  is currently offline duenove
Messages: 9
Registered: May 2009
Go to all my models
Junior Member
Thank You very very much Very Happy Very Happy Very Happy

 
   
Previous Topic:Tridude printed
Next Topic:Tiny starfighters

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.