Home » Support » Buying » Lost package - no more answers from support
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
Lost package - no more answers from support [message #5109] Fri, 03 July 2009 08:06 UTC Go to next message
avatar tokka  is currently offline tokka
Messages: 3
Registered: June 2008
Go to my shop
Junior Member
Hello !

I ordered 2 Models on the third of May and the package got shipped on the 22th of May.

I contacted UPS and Shapeways and Joris wrote me that Elena would take care of it.
In the Meantime UPS called me to tell me that the package got lost somehow. I tried to contact Joris and Elena three times per email. But didn't get any response, yet.

Today's the 3rd of July, so my question is will I ever get a reprint of the model ???

btw: Order # is 101948

-Thorsten
Re: Lost package - no more answers from support [message #5113 is a reply to message #5109 ] Fri, 03 July 2009 12:52 UTC Go to previous messageGo to next message
avatar joris  is currently offline joris
Messages: 426
Registered: May 2008
Go to all my models
Senior Member
Thorsten,

I'm so sorry. We will get to the bottom of your package as soon as we can.

Joris
Re: Lost package - no more answers from support [message #5114 is a reply to message #5109 ] Fri, 03 July 2009 13:08 UTC Go to previous messageGo to next message
avatar lelena70  is currently offline lelena70
Messages: 9
Registered: December 2008
Go to all my models
Junior Member
I work here
Thorsten,

I am sorry.
We have been lucking in follow up. UPS is still searching for your package, but after 6 weeks we should have realized they are not going to find it anymore.
I have entered a production order with refence 4032 to have your models reprinted.
The models will be shipped to you next week

Elena
Re: Lost package - no more answers from support [message #5117 is a reply to message #5114 ] Fri, 03 July 2009 14:44 UTC Go to previous messageGo to next message
avatar tokka  is currently offline tokka
Messages: 3
Registered: June 2008
Go to my shop
Junior Member
Thanks to both of you !

It was just terrible to get no response on any email.
UPS called me about a week after the reporting the package as lost and told me they would notify you...

Anyhow...glad to hear that my package could finally arrive Smile

Re: Lost package - no more answers from support [message #5177 is a reply to message #5109 ] Thu, 09 July 2009 18:29 UTC Go to previous messageGo to next message
avatar tokka  is currently offline tokka
Messages: 3
Registered: June 2008
Go to my shop
Junior Member
IT ARRIVED !!!

Thanks guys/girls ! This time it arrived safely and perfectly looking.
I will make a few pictures and post it in the "it arrived" section.

Thanks again.

-Tokka
Re: Lost package - no more answers from support [message #5182 is a reply to message #5177 ] Fri, 10 July 2009 06:56 UTC Go to previous message
avatar joris  is currently offline joris
Messages: 426
Registered: May 2008
Go to all my models
Senior Member
Phew!

Thats good news!

Joris

 
   
Previous Topic:Production+Shipping time for larger quatities
Next Topic:Selling models: markup invoice