Home » Community » General Discussion » "Triangles with mixed winding order found" error
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
"Triangles with mixed winding order found" error [message #46146] Thu, 29 March 2012 16:51 UTC Go to next message
avatar Sophie Kahn  is currently offline Sophie Kahn
Messages: 14
Registered: February 2011
Go to my shop
Junior Member
Hi everyone,

I was recently attempting to upload an stl and got the "Triangles with mixed winding order found" error. I'm a pretty experienced Netfabb Pro user and tried all the fixes with no success (self-intersections removed, piece booleaned into a single shell, etc).

Has anyone else ever run into this? Even the support staff member who emailed me said she didn't know what it meant!

I saw one other post on this subject, but that was a beginner with a problematic mesh, and mine looks clean as far as I can tell...


http://www.sophiekahn.net
Re: "Triangles with mixed winding order found" error [message #46169 is a reply to message #46146 ] Thu, 29 March 2012 23:36 UTC Go to previous messageGo to next message
avatar stonysmith  is currently offline stonysmith
Messages: 1691
Registered: August 2008
Go to my shop
Senior Member
moderator
In Netfabb, did you apply the "Flipped Triangles" repair?

That's usually the cause of this message.


Patience, Persistance, Politeness - the 3Ps will help us get us to Perfect Printed Products
Re: "Triangles with mixed winding order found" error [message #46173 is a reply to message #46169 ] Fri, 30 March 2012 02:16 UTC Go to previous messageGo to next message
avatar Sophie Kahn  is currently offline Sophie Kahn
Messages: 14
Registered: February 2011
Go to my shop
Junior Member
I did already, I'm afraid. Netfabb is showing 0 triangles with invalid orientation. Thanks for the suggestion though, good to know it could be a normals issue...


http://www.sophiekahn.net
Re: "Triangles with mixed winding order found" error [message #46207 is a reply to message #46173 ] Fri, 30 March 2012 19:09 UTC Go to previous messageGo to next message
avatar paulburkittgray  is currently offline paulburkittgray
Messages: 20
Registered: April 2011
Go to my shop
Junior Member
I had this issue with a model a while ago, always got the "triangles with mixed winding order" message, despite the model showing as fine in Netfabb and watertight in Accutrans. The really confusing thing was that the faulty model was a slight modification of one that went through without problems.
In the end I discovered a hole hidden inside the model, and when I fixed it manually the model uploaded successfully. The hole had been auto-fixed by Netfabb, and was present and didn't cause any problems on the original model, so I'm not entirely sure why this solved the problem, but it did.
So, possibly there is a hole somewhere that is mysteriously causing the problem despite it apparently being fixed by Netfabb?

[Updated on: Fri, 30 March 2012 19:10 UTC]

Re: "Triangles with mixed winding order found" error [message #46209 is a reply to message #46146 ] Fri, 30 March 2012 19:55 UTC Go to previous messageGo to next message
avatar Mary.Huang  is currently offline Mary.Huang
Messages: 27
Registered: June 2011
Go to my shop
Junior Member
I work here
One thing that Netfabb on Shapeways does is it also unions all the pieces that are touching.
This is so you don't get charged for the overlapping volume.

Netfabb basic doesn't have that function, so that might be why you get some extra error messages from Shapeways.

Sounds like you figured out what your issue was, so that's good. Smile
Re: "Triangles with mixed winding order found" error [message #46211 is a reply to message #46209 ] Fri, 30 March 2012 20:25 UTC Go to previous messageGo to next message
avatar stop4stuff  is currently offline stop4stuff
Messages: 2991
Registered: June 2010
Go to my shop
Senior Member
Mary.Huang wrote on Fri, 30 March 2012 19:55

One thing that Netfabb on Shapeways does is it also unions all the pieces that are touching.
This is so you don't get charged for the overlapping volume.

Netfabb basic doesn't have that function, so that might be why you get some extra error messages from Shapeways.

Sounds like you figured out what your issue was, so that's good. Smile


Netfabb Basic doesn't union shells, but Netfabb Cloud service - http://cloud.netfabb.com/ - does so very neatly and is well worth using at any time before uploading - Wink

DIdn't the OP's issue used to be called a 'winding check error'? - I used to get that quite regular attempting to upload a .dae file before I figured out to convert to and check everything as an stl file for non-colour models.

Re: "Triangles with mixed winding order found" error [message #46215 is a reply to message #46211 ] Fri, 30 March 2012 21:14 UTC Go to previous messageGo to next message
avatar Sophie Kahn  is currently offline Sophie Kahn
Messages: 14
Registered: February 2011
Go to my shop
Junior Member
Thanks for all the thoughts, everyone!

I am actually using Netfabb Pro already. I'm still stuck unfortunately. I may just have to go back to an earlier version of the file and see if Shapeways will accept that.


http://www.sophiekahn.net
Re: "Triangles with mixed winding order found" error [message #47184 is a reply to message #46215 ] Wed, 18 April 2012 19:46 UTC Go to previous messageGo to next message
avatar nervoussystem  is currently offline nervoussystem
Messages: 98
Registered: July 2008
Go to my shop
Member
I had this same error today and fixed it by running a boolean union on the finished part in Netfabb Pro

this operation removes self-intersecting portions


http://n-e-r-v-o-u-s.com
Re: "Triangles with mixed winding order found" error [message #47186 is a reply to message #47184 ] Wed, 18 April 2012 19:49 UTC Go to previous messageGo to next message
avatar Sophie Kahn  is currently offline Sophie Kahn
Messages: 14
Registered: February 2011
Go to my shop
Junior Member
Cool, I'll try that, thanks for the tip Smile


http://www.sophiekahn.net
Re: "Triangles with mixed winding order found" error [message #47832 is a reply to message #47186 ] Thu, 03 May 2012 16:59 UTC Go to previous message
avatar tsw  is currently offline tsw
Messages: 14
Registered: May 2011
Go to all my models
Junior Member
I work here
Sophie, are you still having issues with the file? If so, can you send me the file to look at and analyze? Since we are always trying to improve the acceptance rate of uploads, this will also give us another data point on error files.

 
   
Previous Topic:does anyone actually post in the 'my collections' sticky?
Next Topic:WSF and the Material Pages