Home » Support » 3D Applications » Stereo Buffer Problems -- is it a problem for Shapeway?
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
Stereo Buffer Problems -- is it a problem for Shapeway? [message #44222] Mon, 20 February 2012 20:03 UTC Go to next message
avatar WebmistressM  is currently offline WebmistressM
Messages: 17
Registered: February 2012
Go to all my models
Junior Member
Currently using Maya 2009 on my Asus laptop. It has the GeForce 260M card and was working fine. At some point it seems my nVidia driver or some other update created issue with the stereo buffer of my video card.

The problem is still not fixed, but that's not what I'm asking about. The issue with the stereo buffer only affects my ability to render scenes and animation as far as any texturing and "look" of my 3D objects.

However, in consideration of using Shapeway to print my 3D creations in real life.... are any texture related issues going to put a damper on my desire to design stuff for myself when I submit it to shapeways. I figure that, unlike me, they will have no problem rendering on their side as they are the ones that have to be concerned with the final output of the item.

I did look at this tutorial to see if the Collada plug-in does anything with the texture files that are assigned in Maya's Hypershade window, but there doesn't seem to state anything that suggests the final file format even "cares" about textures.

http://www.shapeways.com/tutorials/exporting-from-maya-with- collada-3dprinting

Can anyone clue me in? Do you design your shapes in 3D with or without any textures (other than the grey that is assigned by Maya outright) ?
Re: Stereo Buffer Problems -- is it a problem for Shapeway? [message #44229 is a reply to message #44222 ] Tue, 21 February 2012 00:09 UTC Go to previous messageGo to next message
avatar aeron203  is currently offline aeron203
Messages: 447
Registered: July 2008
Go to my shop
Senior Member
The materials assigned for rendering are usually not considered when the object is 3D printed. Normally the only material is the one output by whatever machine is being used. The only exception is with Full Color Sandstone material, which can have material color printed along with it. It only accepts VRML format, and the colors can be stored in faces, vertices, or as UV mapped textures (JPG or PNG). Things like bump, specularity, displacement etc. are ignored, as are the smoothing groups. Unless you are designing for color printing, you will not have to worry about any material display problems. All the issues you describe are only for screen output anyway (except the few renderers that use GPU assistance), and will not affect the model. It would just be hard to create and verify the material colors with those display problems. The final say on whether your full-color models are correct (other than holding the print in your hand) will be the appearance in the preview render after you upload the model.




Aaron - 40westdesigns.com/blog
Re: Stereo Buffer Problems -- is it a problem for Shapeway? [message #44230 is a reply to message #44229 ] Tue, 21 February 2012 00:16 UTC Go to previous message
avatar WebmistressM  is currently offline WebmistressM
Messages: 17
Registered: February 2012
Go to all my models
Junior Member
Oh, that is a huge relief! I meaan, I still hope there is a solution for my problem someday but its nice that I dont have to wait for that solution in order to get something designed in Shapeway. As it was, Im sure Im gonna probably have a test product created and sent to my home just to see the fine details of my tweaks.

I guess now, the only issue Ill have to worry about is if I am going to have a way to get a 3D still showing a preview in the material Im allowing it to be made in (should someone actually like my designs). I speak on that from knowing that I have a specific item I need made but only in a particular material (stainless steel). Sadly, the stainless steel texture work I could do in Maya, would not look good when I render it since software rendering (vs hardware) is what is adversely affected by this issue.

For anyone curious, here is the exact description of the Maya problem, just in case you have had this problem too:

http://forums.nvidia.com/index.php?showtopic=212044

 
   
Previous Topic:good 3d apps for OS X?
Next Topic:Google Sketchup Resizing=Model Degradation Help!