Home » Support » Bug Reporting » 3D preview applet could be better...
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
3D preview applet could be better... [message #32126] Fri, 05 August 2011 16:56 UTC Go to next message
avatar stefan_z  is currently offline stefan_z
Messages: 40
Registered: July 2011
Go to my shop
Member
Somehow the 3D applet is not very good.
You can neither resize the window nor does it show textures.

But worst: It crashes a LOT or doesn't show up at all with the new Java on OSX.

Or is there some workaround?
Re: 3D preview applet could be better... [message #32132 is a reply to message #32126 ] Fri, 05 August 2011 17:49 UTC Go to previous messageGo to next message
avatar stop4stuff  is currently offline stop4stuff
Messages: 3111
Registered: June 2010
Go to my shop
Shapie Expert
You wouldn't want it to show textures... 3D printers can't see them Wink

As for the rest, maybe put a request in for what features you'd like to see?
Re: 3D preview applet could be better... [message #32134 is a reply to message #32132 ] Fri, 05 August 2011 17:52 UTC Go to previous messageGo to next message
avatar stefan_z  is currently offline stefan_z
Messages: 40
Registered: July 2011
Go to my shop
Member
Full Color Sandstone?

Also bigger viewport for the applet, less crashing (Safari crashes if you close the window, but is fine if you go back one page) or simply a working version for now Smile

Also: I know 3D-viewers are somehow "funky" when it comes to browsers... yet it's 2011 and there should be something out there that can do the job, right?

[Updated on: Fri, 05 August 2011 17:56 UTC]

Re: 3D preview applet could be better... [message #32137 is a reply to message #32134 ] Fri, 05 August 2011 18:04 UTC Go to previous messageGo to next message
avatar stop4stuff  is currently offline stop4stuff
Messages: 3111
Registered: June 2010
Go to my shop
Shapie Expert
Oh right, UV colour maps... nope those don't work in the 3D preview... did you try Accutrans3D yet? It works fine on my XP machine with my UV models loaded locally, but afaik, there's not a way to see other people's models in full colour 3D preview via Shapeways.

Re: 3D preview applet could be better... [message #32140 is a reply to message #32137 ] Fri, 05 August 2011 18:09 UTC Go to previous messageGo to next message
avatar stefan_z  is currently offline stefan_z
Messages: 40
Registered: July 2011
Go to my shop
Member
Locally is not an issue. Just talking about the shapeways site.

I like to check my models before print if all the polys are in shape and so on... And the color-preview is way too small.
Re: 3D preview applet could be better... [message #32141 is a reply to message #32126 ] Fri, 05 August 2011 18:12 UTC Go to previous messageGo to next message
avatar Youknowwho4eva  is currently offline Youknowwho4eva
Messages: 5401
Registered: September 2008
Go to my shop
Shapie Expert
I work here
I know the 3D preview is something that is on the update list. I'll see if I can poke and prod to see where it's at.


I learned a long time ago the wisest thing I can do is be on my own side, be an advocate for myself and others like me. -Maya Angelou
michael@shapeways.com
Re: 3D preview applet could be better... [message #32163 is a reply to message #32126 ] Fri, 05 August 2011 21:57 UTC Go to previous messageGo to next message
avatar Youknowwho4eva  is currently offline Youknowwho4eva
Messages: 5401
Registered: September 2008
Go to my shop
Shapie Expert
I work here
Ok, I dug around. There is an update that is scheduled for a September release. Not sure if color renders will be involved or not.


I learned a long time ago the wisest thing I can do is be on my own side, be an advocate for myself and others like me. -Maya Angelou
michael@shapeways.com
Re: 3D preview applet could be better... [message #32173 is a reply to message #32126 ] Fri, 05 August 2011 23:15 UTC Go to previous messageGo to next message
avatar tsw  is currently offline tsw
Messages: 15
Registered: May 2011
Go to all my models
Junior Member
I work here
Are you getting crashes mainly on Safari? I've found that the 3D viewer is much more stable with Firefox on OSX.

By the way, which version of Java are you using?
Re: 3D preview applet could be better... [message #32190 is a reply to message #32173 ] Sat, 06 August 2011 11:02 UTC Go to previous messageGo to next message
avatar stefan_z  is currently offline stefan_z
Messages: 40
Registered: July 2011
Go to my shop
Member
Safari-user - but FF wont load it now either - both display just a white rectangle.
Version is the latest 1.6.0_26-b3b3845 64bit under OSX 10.6
Re: 3D preview applet could be better... [message #32271 is a reply to message #32190 ] Mon, 08 August 2011 16:50 UTC Go to previous messageGo to next message
avatar tsw  is currently offline tsw
Messages: 15
Registered: May 2011
Go to all my models
Junior Member
I work here
I haven't tried the new Java yet, but I do know that Firefox worked with older Java 1.6 versions on OSX 10.6. Have you checked the Add-ons on Firefox and made sure that the Java plugin is enabled?

We'll be taking a look at the Safari crashing issue for the next release.

Here's a link about Firefox and Java applets that may or may not be useful for your case.

http://support.mozilla.com/en-US/questions/795732

[Updated on: Mon, 08 August 2011 16:59 UTC]

Re: 3D preview applet could be better... [message #35900 is a reply to message #32126 ] Wed, 05 October 2011 00:43 UTC Go to previous messageGo to next message
avatar stefan_z  is currently offline stefan_z
Messages: 40
Registered: July 2011
Go to my shop
Member
Ok, it seems that shapeways has some sort of new / different 3D plugin.

On OSX he loads, displays a loading-dialog in a seperate windows and then dies Smile

But we are half way there, right? Smile
My Java Version is 1.6.0_26-b03-384
running on current iMac i7 under the latest OSX 10.6

Would be awesome if you guy got this running!


Here is what he said in the console:
SAFARI
05.10.11 02:28:25	PluginProcess[12110]	Process manager already initialized -- can't fully enable headless mode.
05.10.11 02:28:25	[0x0-0x17f17f].com.apple.Safari[4921]	2011-10-05 02:28:25.309 PluginProcess[12110:903] Process manager already initialized -- can't fully enable headless mode.
05.10.11 02:28:45	[0x0-0x17f17f].com.apple.Safari[4921]	Exception in thread "AWT-AppKit" 
05.10.11 02:28:45	[0x0-0x17f17f].com.apple.Safari[4921]	netscape.javascript.JSException: Plugin instance for applet ID 1 was already released
05.10.11 02:28:45	[0x0-0x17f17f].com.apple.Safari[4921]		at sun.plugin2.main.server.LiveConnectSupport.getInfo(LiveConnectSupport.java:405)
05.10.11 02:28:45	[0x0-0x17f17f].com.apple.Safari[4921]		at sun.plugin2.main.server.LiveConnectSupport.shutdown(LiveConnectSupport.java:41)
05.10.11 02:28:45	[0x0-0x17f17f].com.apple.Safari[4921]		at sun.plugin2.main.server.JVMInstance.unregisterApplet(JVMInstance.java:1400)
05.10.11 02:28:45	[0x0-0x17f17f].com.apple.Safari[4921]		at sun.plugin2.main.server.JVMInstance.recycleAppletID(JVMInstance.java:393)
05.10.11 02:28:45	[0x0-0x17f17f].com.apple.Safari[4921]		at sun.plugin2.main.server.JVMManager.recycleAppletID(JVMManager.java:349)
05.10.11 02:28:45	[0x0-0x17f17f].com.apple.Safari[4921]		at sun.plugin2.main.server.MozillaPlugin.stopApplet(MozillaPlugin.java:298)
05.10.11 02:28:45	[0x0-0x17f17f].com.apple.Safari[4921]		at sun.plugin2.main.server.MozillaPlugin.destroy(MozillaPlugin.java:203)


FIREFOX
05.10.11 02:29:19	firefox-bin[12100]	Process manager already initialized -- can't fully enable headless mode.
05.10.11 02:29:39	[0x0-0x56c56c].org.mozilla.firefox[12100]	Exception 
05.10.11 02:29:39	[0x0-0x56c56c].org.mozilla.firefox[12100]	in thread "AWT-AppKit" 
05.10.11 02:29:39	[0x0-0x56c56c].org.mozilla.firefox[12100]	netscape.javascript.JSException: Plugin instance for applet ID 1 was already released
05.10.11 02:29:39	[0x0-0x56c56c].org.mozilla.firefox[12100]		at sun.plugin2.main.server.LiveConnectSupport.getInfo(LiveConnectSupport.java:405)
05.10.11 02:29:39	[0x0-0x56c56c].org.mozilla.firefox[12100]		at sun.plugin2.main.server.LiveConnectSupport.shutdown(LiveConnectSupport.java:41)
05.10.11 02:29:39	[0x0-0x56c56c].org.mozilla.firefox[12100]		at sun.plugin2.main.server.JVMInstance.unregisterApplet(JVMInstance.java:1400)
05.10.11 02:29:39	[0x0-0x56c56c].org.mozilla.firefox[12100]		at sun.plugin2.main.server.JVMInstance.recycleAppletID(JVMInstance.java:393)
05.10.11 02:29:39	[0x0-0x56c56c].org.mozilla.firefox[12100]		at sun.plugin2.main.server.JVMManager.recycleAppletID(JVMManager.java:349)
05.10.11 02:29:39	[0x0-0x56c56c].org.mozilla.firefox[12100]		at sun.plugin2.main.server.MozillaPlugin.stopApplet(MozillaPlugin.java:298)
05.10.11 02:29:39	[0x0-0x56c56c].org.mozilla.firefox[12100]		at sun.plugin2.main.server.MozillaPlugin.destroy(MozillaPlugin.java:203)



If I activate the Java Console he outputs:
Java-Plug-in 1.6.0_26
Verwendung der JRE-Version 1.6.0_26-b03-384-10M3425 Java HotSpot(TM) 64-Bit Server VM
Home-Verzeichnis des Benutzers = /Users/usernameMessage: VERSION: 1.5.3.11
Message: VERSION: 1.5.3.11
OpenGL details:
Card vendor: ATI Technologies Inc.
Spec Version: 2.1 ATI-1.6.38
Renderer: ATI Radeon HD 6970M OpenGL Engine
High-resolution shaders enabled
Calculated location [0.0, 0.0, 0.06963202] orient [0.0, 1.0, 0.0, 0.0]
Re: 3D preview applet could be better... [message #35962 is a reply to message #35900 ] Wed, 05 October 2011 17:18 UTC Go to previous message
avatar tsw  is currently offline tsw
Messages: 15
Registered: May 2011
Go to all my models
Junior Member
I work here
I can load a model in the viewer in Firefox and Safari on my MacBook without problems.

These are my specs:

OSX 10.6.7
ATI Radeon X1600
Java 1.6.0_26-b03-384
Firefox 3.6.23
Safari 5.05

Doing some research online indicates that you are not the only one who has had this problem. Here are some suggestions that you can try out:

- Make sure that you clear out your Java cache so the 3D viewer files gets download to your computer when loading the applet. You can do this in Java Preferences / Network tab / Delete Files. You also might want to clear out the browser cache to start fresh.

- In your Java Preferences / General tab, try setting the applets to run "In their own process". Also, try not to have multiple applets running in a browser.

- There could be a conflict between browser plugins. One report indicated a conflict between the Java plugin and the AdBlockPlus extension. Maybe you can try disabling suspect plugins/extensions and see if anything changes.


 
   
Previous Topic:video
Next Topic:Shop Descriptions and the "More Info" button

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.