Home » Support » 3D Design » Blender subsurf non-manifold problem...
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
Blender subsurf non-manifold problem... [message #3082] Mon, 23 February 2009 16:53 UTC Go to next message
avatar Albinal  is currently offline Albinal
Messages: 14
Registered: June 2008
Go to all my models
Junior Member
Hello... I've been running into some problems with a model I'm trying to prepare... in Blender.

It's a low poly model that has subsurf applied but before I upload to print I Alt+C to convert the modifiers leaving me with a high-poly model.

While it's in low-poly mode it's easy to handle and I can see what's going on... when it's in high-poly mode there's verts all over the place and I find it difficult to see what's going on.

My model is being returned with a "Only manifold objects can be printed" problem and I'm trying to find the problems using Select > Non-manifold and I can't see anything. However, in low-poly mode there are no 'doubles' but once converted there are several hundred.

I assume I have to convert the modifiers first but to what level?! My guess is I'm going too high. My model is about 80,000 polys.

Any other ideas greatly appreciated.
Re: Blender subsurf non-manifold problem... [message #3084 is a reply to message #3082 ] Mon, 23 February 2009 18:57 UTC Go to previous messageGo to next message
avatar daddymack  is currently offline daddymack
Messages: 157
Registered: August 2008
Go to my shop
Senior Member
Hi albinal, if you upload the model as an .obj I'll have a look at it for you
Re: Blender subsurf non-manifold problem... [message #3086 is a reply to message #3084 ] Mon, 23 February 2009 20:42 UTC Go to previous messageGo to next message
avatar AO  is currently offline AO
Messages: 76
Registered: September 2008
Go to all my models
Member
Hi daddymack,
If you can't fix it ( what I actually doubt ) I can try to fix the obj. or stl.
But I only can do tonight or tomorrow morning, I'll be out for a few days.

Greetings Arjan Moors

or arjanmoors@hotmail.com
Re: Blender subsurf non-manifold problem... [message #3090 is a reply to message #3086 ] Tue, 24 February 2009 09:01 UTC Go to previous messageGo to next message
avatar bartv  is currently offline bartv
Messages: 1668
Registered: December 2007
Go to my shop
Shapie Expert
Hey Albinal,

I can check out the .blend file for you as well, if you like. If you don't want to post it here, you can also mail it to service@shapeways.com.

Cheers,

Bart


Community Manager Europe | Shapeways
Re: Blender subsurf non-manifold problem... [message #3091 is a reply to message #3084 ] Tue, 24 February 2009 09:09 UTC Go to previous messageGo to next message
avatar Albinal  is currently offline Albinal
Messages: 14
Registered: June 2008
Go to all my models
Junior Member
Ok, many thanks! Here it is...

I know the wrapped text might be a bit of a problem and it's a bit messy but I'm hoping the imperfections are too small to show up when it's printed. But you've got more experience so maybe you can tell me!?!

Cheers!

Re: Blender subsurf non-manifold problem... [message #3092 is a reply to message #3090 ] Tue, 24 February 2009 09:15 UTC Go to previous messageGo to next message
avatar Albinal  is currently offline Albinal
Messages: 14
Registered: June 2008
Go to all my models
Junior Member
Ok Bart... here's the blend. Layer 1 has the model low-poly with a lattice to deform it and layer 2 it's high-poly and the right size for printing (I think!?!)... though I won't be sure until it's successfully uploaded.

Much appreciated!

Re: Blender subsurf non-manifold problem... [message #3093 is a reply to message #3092 ] Tue, 24 February 2009 10:00 UTC Go to previous messageGo to next message
avatar bartv  is currently offline bartv
Messages: 1668
Registered: December 2007
Go to my shop
Shapie Expert
I actually did find 8 non-manifold edges in the 'hat'. Here's the fixed model, enjoy!

Bart

PS: if you want to read the .STL back in Blender, be sure to do a 'remove doubles' after importing.


Community Manager Europe | Shapeways
Re: Blender subsurf non-manifold problem... [message #3094 is a reply to message #3093 ] Tue, 24 February 2009 10:10 UTC Go to previous messageGo to next message
avatar Albinal  is currently offline Albinal
Messages: 14
Registered: June 2008
Go to all my models
Junior Member
Cool... thanks Bart! What do you think about the website text on the back? How well do you think it'll print?

Many thanks for helping! Razz
Re: Blender subsurf non-manifold problem... [message #3095 is a reply to message #3082 ] Tue, 24 February 2009 11:00 UTC Go to previous messageGo to next message
avatar Albinal  is currently offline Albinal
Messages: 14
Registered: June 2008
Go to all my models
Junior Member
Also, I uploaded the STL you gave me which was a success... however, it was too small. I brought it back into Blender, removed the doubles and re-scaled it... uploaded it again and it failed... though I'm not sure why as Gmail is down at the mo!

What am I doing wrong?
Re: Blender subsurf non-manifold problem... [message #3127 is a reply to message #3095 ] Fri, 27 February 2009 10:38 UTC Go to previous message
avatar bartv  is currently offline bartv
Messages: 1668
Registered: December 2007
Go to my shop
Shapie Expert
Hey Albinal,

what was the error this time? Non-manifold again? To check for non-manifoldness, enter editmode in Blender, deselect all faces and press CTRL+ALT+SHIFT+M.

Feel free to mail me your file again and I'll fix it up for you Smile

Cheers,

Bart


Community Manager Europe | Shapeways

 
   
Previous Topic:holes appear dished
Next Topic:i appear to attract errors

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.