Home » Support » 3D Design » Co|Create STL problems...
Search Search  
Show: Today's Messages    Show Polls    Message Navigator
icon3.gif  Co|Create STL problems... [message #2889] Sun, 08 February 2009 16:02 UTC Go to next message
avatar minisumo  is currently offline minisumo
Messages: 15
Registered: February 2009
Go to my shop
Junior Member
I've recently download the Co|Create's Personal Edition, it's 3D aimed at engineering design, but it's export appears to be flawed with regards to shapeways upload and check.

The model checks out OK but the exported STL gives a manifold problem, considering VRML the files can not be processed.

Poking around I found MiniMagics, with a view to looking at the STL file and looking for problems. It didn't report any and re-saving the file seemed to resolve the upload/manifold issues.

Has anyone else seen this issue? Is there a problem with Co|Create's STL files?

best regards,
Colin
Re: Co|Create STL problems... [message #2893 is a reply to message #2889 ] Sun, 08 February 2009 21:30 UTC Go to previous messageGo to next message
avatar cignoni  is currently offline cignoni
Messages: 6
Registered: June 2008
Go to my shop
Junior Member
You can also try MeshLab, a multiplatform free (open source) mesh processing system that can inspect, check and correct STL files.

Available at
http://meshlab.sourceforge.net


P.
Re: Co|Create STL problems... [message #2898 is a reply to message #2889 ] Mon, 09 February 2009 08:29 UTC Go to previous messageGo to next message
avatar chris89  is currently offline chris89
Messages: 140
Registered: January 2009
Go to my shop
Senior Member
i've had all my STL exports from 3dsmax get manifold problems as well, whereas VRML works with exactly the same model.

Not sure why, could be the initial coordinate orientation of the programs vs. STL
Re: Co|Create STL problems... [message #2901 is a reply to message #2889 ] Mon, 09 February 2009 11:13 UTC Go to previous messageGo to next message
avatar minisumo  is currently offline minisumo
Messages: 15
Registered: February 2009
Go to my shop
Junior Member
Thanks for the tips, I'll have a look at MeshLab.

Co|Create does give a warning on the export of STL with regard to model space.

regards,
Colin

Re: Co|Create STL problems... [message #2925 is a reply to message #2901 ] Tue, 10 February 2009 08:35 UTC Go to previous messageGo to next message
avatar bartv  is currently offline bartv
Messages: 1668
Registered: December 2007
Go to my shop
Shapie Expert
Hi,

regarding the STL files: yes, there seem to be some different 'dialects' of STL, and sometimes loading and re-exporting it from a tool like MeshLab will fix those issues.

About non-manifold errors that appear with STL but not with VRML: I find this *extemely* interesting. Could you mail an example of such a case to bart@shapeways.com so I can see what's going on there?

Thanks!

Bart


Community Manager Europe | Shapeways
Re: Co|Create STL problems... [message #2933 is a reply to message #2889 ] Tue, 10 February 2009 20:21 UTC Go to previous messageGo to next message
avatar chris89  is currently offline chris89
Messages: 140
Registered: January 2009
Go to my shop
Senior Member
sent you an email.
Re: Co|Create STL problems... [message #2940 is a reply to message #2889 ] Wed, 11 February 2009 09:49 UTC Go to previous messageGo to next message
avatar bartv  is currently offline bartv
Messages: 1668
Registered: December 2007
Go to my shop
Shapie Expert
Hey Chris,

hmm, this is odd. The OBJ and STL file both contain some non-manifold areas, but the VRML is fine - like you say. However, when I export the OBJ from Blender to VRML, I'm getting the same non-manifold errors. So it would seem that the Max VRML exporter somehow cleans up the mesh in the process, which would be awesome of course Wink

I don't think it's due to the orientation of the model like you suggested; this shouldn't solve non-manifold topologies.

So, in short: I'm not sure what's going on. Maybe you just got lucky with that VRML exporter?

Cheers,

Bart


Community Manager Europe | Shapeways
Re: Co|Create STL problems... [message #2956 is a reply to message #2925 ] Thu, 12 February 2009 07:25 UTC Go to previous message
avatar minisumo  is currently offline minisumo
Messages: 15
Registered: February 2009
Go to my shop
Junior Member
I've forwarded the STL and WRML files, I hope it helps.

Best regards,
Colin

 
   
Previous Topic:Unusual appearance of part in Gallery Viewer
Next Topic:holes appear dished

Logo

Hello.

We're sorry to inform you that we no longer support this browser and can't confirm that everything will work as expected. For the best Shapeways experience, please use one of the following browsers:

Click anywhere outside this window to continue.